SlideShare a Scribd company logo
1 of 9
Download to read offline
CCNA4.com

CCNA Commands In 10 Minutes
IP ROUTING

#sh ip route - To view IP routing tables created on a Cisco router.

-Static Routing- Routers are manually configured for networks that are not directly connected,
to be able to route to all networks via the next-hop interface.

Example- Let 192.168.30.0/24 be the IP of a network not directly connected
Let 192.168.20.2 be the next hop interface

(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2

-to remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2

-Default Routing- Used on stub networks only to send packets with remote destination
network not in the routing table to the next hop router.

(Assume IP 192.168.40.1 is not in routing table)

-first remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1
(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1

-RIP-A distance vector routing protocol that passes complete routing table contents to
neighbouring routers

Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router
interfaces and 192.168.30.0 be non-directly connected

-first delete all static routes
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2
(config)#router rip
(config-router)#192.168.10.0
(config-router)#192.168.20.0
(config-router)#^z
#

-Verifying RIP
1.Sh ip route
2.debug ip

-Holding Down RIP Propagation-To stop RIP update sending but allow its receipt
-say for s0/0 with ip 192.168.10.0

(config)#router rip
(config-router)#network 192.168.10.0
(config-router)#passive-interface serial 0/0

-IGRP-Also a distance routing protocol

CCNA4.com
CCNA4.com
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router
interfaces with autonomous system number of 10 and 192.168.30.0 be non-directly connected

#router igrp 10
(config-router)#network 192.168.10.0
(config-router)#network 192.168.20.0
(config-router)#^z
#

-Verifying IGRP
1.sh ip route
2.sh protocols- Displays routed protocols and their interfaces
3.sh ip protocols- Displays routing protocols configured
4.debug igrp events- Displays summary of IGRP routing information running on the network
5.debug igrp transactions- Displays messages request from neighbour routers

-Turning off all possible debugging
#un all

-EIGRP-Uses classless routing which is subnet mask information sent with routing protocol
updates.

Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router
interfaces with autonomous system number of 20 and 192.168.30.0 be non-directly connected

#router eigrp 20
(config-router)#network 192.168.10.0
(config-router)#network 192.168.20.0
(config-router)#^z

-To stop EIGRP from working on an interface-no sending no receipt
(config)#router eigrp 20
(config-router)#passive-interface serial 0/0

-To enable EIGRP on discontiguos networks(two different subnetworks of classfull network
connected by another different classful subnetwork)
Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote
subnetwork of 192.168.10.0, then to enable EIGRP, we use

(config)#router eigrp 100
(config-router)#network 172.16.0.0
(config-router)#network 10.0.0.0
(config-router)#no auto-summary
N.B-The no auto-summary command sholuld be enabled in routers that encloses such
networks.

-Verifying EIGRP
1. sh ip route- Shows entire routing table
2. sh ip route eigrp- Shows only EIGRP entries in the routing table
3. ip eigrp neighbours- Shows all EIGRP neighbours
4. ip eigrp topology- Shows entries in the EIGRP topology table


CCNA4.com
CCNA4.com
OSPF- A link-state routing protocol

Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to
be enabled; with ospf ID of 1 and area o

(config)#router ospf 1
(config-router)#network 10.0.0.0 0.255.255.255 area0

-Loopback Interface- They are configured to be used as the routers RID to advertise the routes
and elect DR and BDR.

Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1

(config)#int loopback 0
(config-if)#ip address 172.16.10.1 255.255.255.0
(config-if)#no shut
(config-if)#^z

-Verifying OSPF Configuration
1. sho ip ospf- Used to display all OSPF information
2. sho ip ospf database- indicates the number of links and neighboring router ID
3. sho ip ospf interface- Displays all OSPF interface related info
4. sho ip ospf neighbour- Summarizes OSPF info about neighbours
5. sho ip protocols- Overview of all present running protocols

- Verifying Loopback and RID
1. sho running-config- To verify loopback address
2. sho ip ospf database- Verifies the new RID of each router
3. sho ip ospf interface- Verifies the new RID of each router

-Initial configuration of a 1900 Switch with ip 172.16.10.16

>en
#config t
(config)#enable password level 1 kennifeh
(config)#enable password level 15kennifeh 1
(config)#enable secret kennifeh 2(when enabled no need 4 enable password)
(config)#hostname kenn 1900
(config)#ip address 172.16.10.16 255.255.255.0
(config)#ip default-gateway 172.16.10.1
(config)#int f0/1
(config-if)#description Finance_vlan (No space for 1900)
(config-if)#int f0/26
(config-if)#description Trunk_to_Biulding
(config-if)#exit
(config)#

-Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0

>en
#config t
(config)#hostame kenn2950

CCNA4.com
CCNA4.com
(config)#enable password kenn
(config)#enable password kenn1(enable and enable secret password must be different)
(config)#line vty 0 15
(config-line)#login
(config-line)#password telnet
(config-line)#line con 0
(config-line)#login
(config-line)#password console
(config-line)#exit
(config)#int vlan 1
(config-if)#ip address 172.16.10.17 255.255.255.0
(config-if)#no shut
(config-if)#int f0/1
(config-if)#description sales printer(with space)
(config-if)#int f0/12
(config-if)description connection to backbone
config-if)#exit
(config)#ip default-gateway 172.16.10.1
(config)#

-Erasing Switching Configuration 1900

#delete nvram
yes

-Erasing Switching Configuration 2950

#erase startup-config
Enter


-Configuring VLANS 1900

>en
#config t
(config)#vlan 2 name Cisco
(config)#vlan 3 name Microsoft
(config)#vlan 4 name Comptia
(config)#exit

verify with command sh run

-Configuring for 2950

>en
#vlan database
(vlan)#vlan 2 name Cisco
(vlan)#vlan 3 name Microsoft
(vlan)#vlan 4 name Comptia
(vlan)#apply
(vlan)#^c


CCNA4.com
CCNA4.com
verify with command sh vlan brief

-Assigning Switch Ports To Vlan-1900

(config)#int e0/2
(config-if)#vlan-membership static 2
(config-if)#int e0/3
(config-if)#vlan-membership static 3
(config-if)#exit

verify with sh vlan

-Assigning Switch Ports To Vlan-2950

(config)#int f0/2
(config-if)#switchport access vlan 2
(config-if)#int f0/3
(config-t)#switchport access vlan 3
(config-if)#int f0/4
(config-if)#switchport access vlan 4
(config-if)#

verify with sh vlan brief

-Configuring Trunks ports

(config)#int f0/26
(config-if)#trunk on

-Configuring Trunk Ports for 2950

(config)#int f0/12
(config-if)#switchport mode trunk
(config-if)#^z
#

-To disable Trunk use- switchport mode access

-To verify Trunking use sh running config

-Configuring Inter-vlan Routing for 1900 connecting to 2600

(config)#int f0/0.1
(config-if)#encapsulation isl vlan (d number)

-Configuring Inter-vlan Routing for 2950 connecting to 2600

(config)#int f0/0.1
(config-if)#encapsulation dot1q vlan (d number)
-Configuring VTP for 1900

(config)#vtp server

CCNA4.com
CCNA4.com
(config)vtp domain kenn
(config)#vtp password kenn

-Configuring VTP for 2950

(config)#vtp mode server
(config)#vtp domain routersim
(config)#^z

-verify with sh vtp status

-Checking the Current Configuration Register Values

show version or show ver

-Changing Configuration Register

(config)#config-register 0x101 (d default is 0x2102)
(config)#^z

-Recovering Passwords

-1. Interrupt the Router Boot Sequene
ctrl+Break key (windows wont perform break key, only 95/98)

-2. Changing the configuration register
-for 2600 series router
rammon>confreg 0x2142

-for 2500
type 0 after a break and enter the command o/r 0x2142

-3. Reloading the Router and Entering Privilged mode
-for 2600-type reset
-for 2500-type I

-4. Viewing and changing the configuration
-copy run start

-5. Resetting the configuration Register and Reloading the Router
-config t
-config-register 0x2102
-copy run start-to save

-Backing up and restoring the Cisco ios

-1. verifying flash memory-Ensuring flash memory has enough room
router#sh flash

-2. Backing-up the ciso ios
first verify server connectivity by- Router#ping 192.168.0.120
then; router#copy flash tftp

CCNA4.com
CCNA4.com
-3. Restoring or upgrading the cisco router ios
router#copy tftp flash
[confirm][ENTER]
?[ENTER]

-Backing up and Restoring the Cisco configuration

1.Backing up the cisco router configuration
-copy runing config tftp

2. verifying the current configuration
-sh run

3. copying the current cofiguration to NVRAM
-copy run start

4. copying the current configuration to a TFTP server
-copy run TFTP

5. Restoring the Cisco Router Configuration
-copy TFTP run

6. Erasing the configuration
-erase startup-config

-Getting CDP timers and Holdtime information
Router#config t
Router(config)#cdp timer 90
Router(config)#cdp holdtime 240
Router(config)#^z

-To turn-off CDP Completely-no cdp run

-Gathering Neighbour information
kenn2509#sh cdp nei- delivers information about directly connected devices
OR kenn2509#sh cdp neighbour detail Also sh cdp entry

-Gathering Interface Traffic Information
kenn2509#sh cdp traffic

-Gathering port and Interface information
kenn2509#sh cdp interface

-To turn off cdp on a router, use
no cdp enable then ^z

-Using Telnet
kenn2509#telnet 172.16.10.2

-Telnetting into multiple devices simultaneously
kenn2509#telnet 172.16.10.2
then, 2501B>{cntl+shift+6, then x}

CCNA4.com
CCNA4.com

-checking Telnet connections
kenn2509#sh sessions-connections from your router to remote

-checking Telnet users
kenn2509#sh user

-closing Telnet sessions
1900switch>exit OR
kenn2509#disconnect1 (num of active networks)

-Resolving Hostname
kenn2509#config t
kenn2509(config)#ip host 2501B 172.16.10.2
kenn2509(config)#ip host 1900switch 192.168.0.148
kenn2509(config)#^z

-To remove a hostname from a table, use
RouterA(config)#no ip host routerB

-Using DNS to resolve names

#config t
(config)#ip domain-lookup (usually turned on by default)
(config)#ip name-server 192.168.0.70 (ip of an assumed DNS set)
(config)#ip domain-name kenn.com (Appends the domain name to a host)
(config)#^z

-Check Network Connectivity
use ping command
#ping kenn2509

-Using Traceroute command
#trace 2501B

-Creating a Standard Access Lists (1-99 or 1,300-1,999)

(config)#access-list 10 deny 172.16.30.2 (using the ip as a test)

-Controlling vty(Telnet) sessions

(config)#access-list 50 permit 172.16.30.2
(config)#line vty 0 4
(config-line)#access-class 50 in

-Creating Extended Access-lists (100 to 199) OR (2000 to 2699)

(config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log
(config)#access-list 110 permit ip any any
(config)#int f0/0
(config-if)#ip access-group 110 in
(config-if)#ip access-group 110 out

CCNA4.com
CCNA4.com
            By kennifeh




CCNA4.com

More Related Content

What's hot

Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commandsRobin Rohit
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsAlejandro Marin
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing ProtocolsDsunte Wilson
 
Resumen comandos router
Resumen comandos routerResumen comandos router
Resumen comandos routerjlvive
 
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfpoojaswami31
 
CCNA Lab 5-Configuring Inter-VLAN Routing
CCNA Lab 5-Configuring Inter-VLAN RoutingCCNA Lab 5-Configuring Inter-VLAN Routing
CCNA Lab 5-Configuring Inter-VLAN RoutingAmir Jafari
 
Actividad Topologías VoIP
Actividad Topologías VoIPActividad Topologías VoIP
Actividad Topologías VoIPcyberleon95
 
Comandos Básicos HUAWEI
Comandos Básicos HUAWEIComandos Básicos HUAWEI
Comandos Básicos HUAWEIBootcamp SCL
 
Internal & External of Routers
Internal & External of RoutersInternal & External of Routers
Internal & External of RoutersKishore Kumar
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsBootcamp SCL
 
CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6Nil Menon
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview3Anetwork com
 
Huawei switch configuration commands
Huawei switch configuration commandsHuawei switch configuration commands
Huawei switch configuration commandsHuanetwork
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basicTapan Khilar
 
Spanning tree protocol
Spanning tree protocolSpanning tree protocol
Spanning tree protocolMuuluu
 

What's hot (20)

Cisco router-commands
Cisco router-commandsCisco router-commands
Cisco router-commands
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Router commands
Router commandsRouter commands
Router commands
 
Router commands
Router commandsRouter commands
Router commands
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing Protocols
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
 
Resumen comandos router
Resumen comandos routerResumen comandos router
Resumen comandos router
 
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
 
CCNA Lab 5-Configuring Inter-VLAN Routing
CCNA Lab 5-Configuring Inter-VLAN RoutingCCNA Lab 5-Configuring Inter-VLAN Routing
CCNA Lab 5-Configuring Inter-VLAN Routing
 
Actividad Topologías VoIP
Actividad Topologías VoIPActividad Topologías VoIP
Actividad Topologías VoIP
 
Comandos Básicos HUAWEI
Comandos Básicos HUAWEIComandos Básicos HUAWEI
Comandos Básicos HUAWEI
 
Internal & External of Routers
Internal & External of RoutersInternal & External of Routers
Internal & External of Routers
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
 
CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 
Huawei switch configuration commands
Huawei switch configuration commandsHuawei switch configuration commands
Huawei switch configuration commands
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basic
 
Spanning tree protocol
Spanning tree protocolSpanning tree protocol
Spanning tree protocol
 
Libro cisco ios
Libro cisco iosLibro cisco ios
Libro cisco ios
 

Viewers also liked

Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)Muhammad Ibrahim
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And AnswersCCNAResources
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerSorath Asnani
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer) Arz Sy
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorialIT Tech
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPTAIRTEL
 
User practical
User practicalUser practical
User practicalMuuluu
 
Overview of Spanning Tree Protocol
Overview of Spanning Tree ProtocolOverview of Spanning Tree Protocol
Overview of Spanning Tree ProtocolArash Foroughi
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic ConfigurationProf. Erwin Globio
 
CCNA Industrial Training Presentation
CCNA Industrial Training PresentationCCNA Industrial Training Presentation
CCNA Industrial Training PresentationTalvinder Singh
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bullsSwapnil Kapate
 
Ccna Presentation
Ccna PresentationCcna Presentation
Ccna Presentationbcdran
 

Viewers also liked (17)

Ccna full
Ccna fullCcna full
Ccna full
 
Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And Answers
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet Tracer
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
User practical
User practicalUser practical
User practical
 
Overview of Spanning Tree Protocol
Overview of Spanning Tree ProtocolOverview of Spanning Tree Protocol
Overview of Spanning Tree Protocol
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
 
Ccna notes
Ccna notesCcna notes
Ccna notes
 
CCNA Industrial Training Presentation
CCNA Industrial Training PresentationCCNA Industrial Training Presentation
CCNA Industrial Training Presentation
 
CCNA training report
CCNA training reportCCNA training report
CCNA training report
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bulls
 
Ccna complete notes
Ccna complete notesCcna complete notes
Ccna complete notes
 
CCNA ppt
CCNA pptCCNA ppt
CCNA ppt
 
Ccna Presentation
Ccna PresentationCcna Presentation
Ccna Presentation
 

Similar to Ccna Commands In 10 Minutes

Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)IT Tech
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration3Anetwork com
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iiiNetwax Lab
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)IT Tech
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2MAFANTIRI SELLO
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)Netwax Lab
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realyNetProtocol Xpert
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands OverviewMuhammed Niyas
 
OSPF (open shortest path first) part ii
OSPF (open shortest path first) part  iiOSPF (open shortest path first) part  ii
OSPF (open shortest path first) part iiNetwax Lab
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF ConfigurationNetwax Lab
 

Similar to Ccna Commands In 10 Minutes (20)

Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commands   Ccna commands
Ccna commands
 
Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iii
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realy
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
 
Ccna command
Ccna commandCcna command
Ccna command
 
OSPF (open shortest path first) part ii
OSPF (open shortest path first) part  iiOSPF (open shortest path first) part  ii
OSPF (open shortest path first) part ii
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF Configuration
 

More from CCNAResources

Building Scalable Cisco Internetworks (Bsci)
Building Scalable Cisco Internetworks (Bsci)Building Scalable Cisco Internetworks (Bsci)
Building Scalable Cisco Internetworks (Bsci)CCNAResources
 
Ccna Wireless Study Guide
Ccna Wireless Study GuideCcna Wireless Study Guide
Ccna Wireless Study GuideCCNAResources
 
Ccna Wireless Study Guide
Ccna  Wireless Study GuideCcna  Wireless Study Guide
Ccna Wireless Study GuideCCNAResources
 
Subneting And Summarization
Subneting And  SummarizationSubneting And  Summarization
Subneting And SummarizationCCNAResources
 
Subneting And Summarization
Subneting And SummarizationSubneting And Summarization
Subneting And SummarizationCCNAResources
 
Quick Guide Layer 2 Switching
Quick Guide   Layer 2 SwitchingQuick Guide   Layer 2 Switching
Quick Guide Layer 2 SwitchingCCNAResources
 
Quick Guide Ip Routing
Quick Guide   Ip RoutingQuick Guide   Ip Routing
Quick Guide Ip RoutingCCNAResources
 
Ccna Wireless Resources
Ccna Wireless ResourcesCcna Wireless Resources
Ccna Wireless ResourcesCCNAResources
 
Ccna Quick Notes –VLANs
Ccna Quick Notes –VLANsCcna Quick Notes –VLANs
Ccna Quick Notes –VLANsCCNAResources
 
Lab08 Rip Routing (Ccna4.Com)
Lab08 Rip Routing (Ccna4.Com)Lab08 Rip Routing (Ccna4.Com)
Lab08 Rip Routing (Ccna4.Com)CCNAResources
 
Lab09 Rip Routing (Ccna4.Com)
Lab09 Rip Routing (Ccna4.Com)Lab09 Rip Routing (Ccna4.Com)
Lab09 Rip Routing (Ccna4.Com)CCNAResources
 
Eigrp Summary (Ccna4.Com)
Eigrp Summary  (Ccna4.Com)Eigrp Summary  (Ccna4.Com)
Eigrp Summary (Ccna4.Com)CCNAResources
 

More from CCNAResources (16)

Iscw Cram Sheet
Iscw Cram SheetIscw Cram Sheet
Iscw Cram Sheet
 
Building Scalable Cisco Internetworks (Bsci)
Building Scalable Cisco Internetworks (Bsci)Building Scalable Cisco Internetworks (Bsci)
Building Scalable Cisco Internetworks (Bsci)
 
Ccna Wireless Study Guide
Ccna Wireless Study GuideCcna Wireless Study Guide
Ccna Wireless Study Guide
 
Ip Access Lists
Ip Access ListsIp Access Lists
Ip Access Lists
 
Ccna Wireless Study Guide
Ccna  Wireless Study GuideCcna  Wireless Study Guide
Ccna Wireless Study Guide
 
Subneting And Summarization
Subneting And  SummarizationSubneting And  Summarization
Subneting And Summarization
 
Subneting And Summarization
Subneting And SummarizationSubneting And Summarization
Subneting And Summarization
 
Quick Guide VLANs
Quick Guide   VLANsQuick Guide   VLANs
Quick Guide VLANs
 
Quick Guide Layer 2 Switching
Quick Guide   Layer 2 SwitchingQuick Guide   Layer 2 Switching
Quick Guide Layer 2 Switching
 
Quick Guide Ip Routing
Quick Guide   Ip RoutingQuick Guide   Ip Routing
Quick Guide Ip Routing
 
Ccna Wireless Resources
Ccna Wireless ResourcesCcna Wireless Resources
Ccna Wireless Resources
 
Ccna Quick Notes –VLANs
Ccna Quick Notes –VLANsCcna Quick Notes –VLANs
Ccna Quick Notes –VLANs
 
Lab08 Rip Routing (Ccna4.Com)
Lab08 Rip Routing (Ccna4.Com)Lab08 Rip Routing (Ccna4.Com)
Lab08 Rip Routing (Ccna4.Com)
 
Lab09 Rip Routing (Ccna4.Com)
Lab09 Rip Routing (Ccna4.Com)Lab09 Rip Routing (Ccna4.Com)
Lab09 Rip Routing (Ccna4.Com)
 
Ip Access Lists
Ip Access ListsIp Access Lists
Ip Access Lists
 
Eigrp Summary (Ccna4.Com)
Eigrp Summary  (Ccna4.Com)Eigrp Summary  (Ccna4.Com)
Eigrp Summary (Ccna4.Com)
 

Recently uploaded

Boost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfBoost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfsudhanshuwaghmare1
 
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...apidays
 
Polkadot JAM Slides - Token2049 - By Dr. Gavin Wood
Polkadot JAM Slides - Token2049 - By Dr. Gavin WoodPolkadot JAM Slides - Token2049 - By Dr. Gavin Wood
Polkadot JAM Slides - Token2049 - By Dr. Gavin WoodJuan lago vázquez
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Jeffrey Haguewood
 
MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024MIND CTI
 
CNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In PakistanCNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In Pakistandanishmna97
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Victor Rentea
 
FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024The Digital Insurer
 
Vector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptxVector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptxRemote DBA Services
 
MS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsMS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsNanddeep Nachan
 
WSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2
 
DBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDropbox
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerThousandEyes
 
Strategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherStrategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherRemote DBA Services
 
Artificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyArtificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyKhushali Kathiriya
 
ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesrafiqahmad00786416
 
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...apidays
 
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Angeliki Cooney
 

Recently uploaded (20)

Boost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfBoost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdf
 
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
 
Polkadot JAM Slides - Token2049 - By Dr. Gavin Wood
Polkadot JAM Slides - Token2049 - By Dr. Gavin WoodPolkadot JAM Slides - Token2049 - By Dr. Gavin Wood
Polkadot JAM Slides - Token2049 - By Dr. Gavin Wood
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
 
MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024MINDCTI Revenue Release Quarter One 2024
MINDCTI Revenue Release Quarter One 2024
 
CNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In PakistanCNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In Pakistan
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
 
FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024
 
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
+971581248768>> SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHA...
 
Vector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptxVector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptx
 
MS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsMS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectors
 
WSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering Developers
 
DBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor Presentation
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 
Strategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherStrategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a Fresher
 
Artificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyArtificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : Uncertainty
 
ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challenges
 
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
 
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
 

Ccna Commands In 10 Minutes

  • 1. CCNA4.com CCNA Commands In 10 Minutes IP ROUTING #sh ip route - To view IP routing tables created on a Cisco router. -Static Routing- Routers are manually configured for networks that are not directly connected, to be able to route to all networks via the next-hop interface. Example- Let 192.168.30.0/24 be the IP of a network not directly connected Let 192.168.20.2 be the next hop interface (config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2 -to remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 -Default Routing- Used on stub networks only to send packets with remote destination network not in the routing table to the next hop router. (Assume IP 192.168.40.1 is not in routing table) -first remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1 (config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1 -RIP-A distance vector routing protocol that passes complete routing table contents to neighbouring routers Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces and 192.168.30.0 be non-directly connected -first delete all static routes (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 (config)#router rip (config-router)#192.168.10.0 (config-router)#192.168.20.0 (config-router)#^z # -Verifying RIP 1.Sh ip route 2.debug ip -Holding Down RIP Propagation-To stop RIP update sending but allow its receipt -say for s0/0 with ip 192.168.10.0 (config)#router rip (config-router)#network 192.168.10.0 (config-router)#passive-interface serial 0/0 -IGRP-Also a distance routing protocol CCNA4.com
  • 2. CCNA4.com Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 10 and 192.168.30.0 be non-directly connected #router igrp 10 (config-router)#network 192.168.10.0 (config-router)#network 192.168.20.0 (config-router)#^z # -Verifying IGRP 1.sh ip route 2.sh protocols- Displays routed protocols and their interfaces 3.sh ip protocols- Displays routing protocols configured 4.debug igrp events- Displays summary of IGRP routing information running on the network 5.debug igrp transactions- Displays messages request from neighbour routers -Turning off all possible debugging #un all -EIGRP-Uses classless routing which is subnet mask information sent with routing protocol updates. Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 20 and 192.168.30.0 be non-directly connected #router eigrp 20 (config-router)#network 192.168.10.0 (config-router)#network 192.168.20.0 (config-router)#^z -To stop EIGRP from working on an interface-no sending no receipt (config)#router eigrp 20 (config-router)#passive-interface serial 0/0 -To enable EIGRP on discontiguos networks(two different subnetworks of classfull network connected by another different classful subnetwork) Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote subnetwork of 192.168.10.0, then to enable EIGRP, we use (config)#router eigrp 100 (config-router)#network 172.16.0.0 (config-router)#network 10.0.0.0 (config-router)#no auto-summary N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks. -Verifying EIGRP 1. sh ip route- Shows entire routing table 2. sh ip route eigrp- Shows only EIGRP entries in the routing table 3. ip eigrp neighbours- Shows all EIGRP neighbours 4. ip eigrp topology- Shows entries in the EIGRP topology table CCNA4.com
  • 3. CCNA4.com OSPF- A link-state routing protocol Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be enabled; with ospf ID of 1 and area o (config)#router ospf 1 (config-router)#network 10.0.0.0 0.255.255.255 area0 -Loopback Interface- They are configured to be used as the routers RID to advertise the routes and elect DR and BDR. Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1 (config)#int loopback 0 (config-if)#ip address 172.16.10.1 255.255.255.0 (config-if)#no shut (config-if)#^z -Verifying OSPF Configuration 1. sho ip ospf- Used to display all OSPF information 2. sho ip ospf database- indicates the number of links and neighboring router ID 3. sho ip ospf interface- Displays all OSPF interface related info 4. sho ip ospf neighbour- Summarizes OSPF info about neighbours 5. sho ip protocols- Overview of all present running protocols - Verifying Loopback and RID 1. sho running-config- To verify loopback address 2. sho ip ospf database- Verifies the new RID of each router 3. sho ip ospf interface- Verifies the new RID of each router -Initial configuration of a 1900 Switch with ip 172.16.10.16 >en #config t (config)#enable password level 1 kennifeh (config)#enable password level 15kennifeh 1 (config)#enable secret kennifeh 2(when enabled no need 4 enable password) (config)#hostname kenn 1900 (config)#ip address 172.16.10.16 255.255.255.0 (config)#ip default-gateway 172.16.10.1 (config)#int f0/1 (config-if)#description Finance_vlan (No space for 1900) (config-if)#int f0/26 (config-if)#description Trunk_to_Biulding (config-if)#exit (config)# -Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0 >en #config t (config)#hostame kenn2950 CCNA4.com
  • 4. CCNA4.com (config)#enable password kenn (config)#enable password kenn1(enable and enable secret password must be different) (config)#line vty 0 15 (config-line)#login (config-line)#password telnet (config-line)#line con 0 (config-line)#login (config-line)#password console (config-line)#exit (config)#int vlan 1 (config-if)#ip address 172.16.10.17 255.255.255.0 (config-if)#no shut (config-if)#int f0/1 (config-if)#description sales printer(with space) (config-if)#int f0/12 (config-if)description connection to backbone config-if)#exit (config)#ip default-gateway 172.16.10.1 (config)# -Erasing Switching Configuration 1900 #delete nvram yes -Erasing Switching Configuration 2950 #erase startup-config Enter -Configuring VLANS 1900 >en #config t (config)#vlan 2 name Cisco (config)#vlan 3 name Microsoft (config)#vlan 4 name Comptia (config)#exit verify with command sh run -Configuring for 2950 >en #vlan database (vlan)#vlan 2 name Cisco (vlan)#vlan 3 name Microsoft (vlan)#vlan 4 name Comptia (vlan)#apply (vlan)#^c CCNA4.com
  • 5. CCNA4.com verify with command sh vlan brief -Assigning Switch Ports To Vlan-1900 (config)#int e0/2 (config-if)#vlan-membership static 2 (config-if)#int e0/3 (config-if)#vlan-membership static 3 (config-if)#exit verify with sh vlan -Assigning Switch Ports To Vlan-2950 (config)#int f0/2 (config-if)#switchport access vlan 2 (config-if)#int f0/3 (config-t)#switchport access vlan 3 (config-if)#int f0/4 (config-if)#switchport access vlan 4 (config-if)# verify with sh vlan brief -Configuring Trunks ports (config)#int f0/26 (config-if)#trunk on -Configuring Trunk Ports for 2950 (config)#int f0/12 (config-if)#switchport mode trunk (config-if)#^z # -To disable Trunk use- switchport mode access -To verify Trunking use sh running config -Configuring Inter-vlan Routing for 1900 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation isl vlan (d number) -Configuring Inter-vlan Routing for 2950 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation dot1q vlan (d number) -Configuring VTP for 1900 (config)#vtp server CCNA4.com
  • 6. CCNA4.com (config)vtp domain kenn (config)#vtp password kenn -Configuring VTP for 2950 (config)#vtp mode server (config)#vtp domain routersim (config)#^z -verify with sh vtp status -Checking the Current Configuration Register Values show version or show ver -Changing Configuration Register (config)#config-register 0x101 (d default is 0x2102) (config)#^z -Recovering Passwords -1. Interrupt the Router Boot Sequene ctrl+Break key (windows wont perform break key, only 95/98) -2. Changing the configuration register -for 2600 series router rammon>confreg 0x2142 -for 2500 type 0 after a break and enter the command o/r 0x2142 -3. Reloading the Router and Entering Privilged mode -for 2600-type reset -for 2500-type I -4. Viewing and changing the configuration -copy run start -5. Resetting the configuration Register and Reloading the Router -config t -config-register 0x2102 -copy run start-to save -Backing up and restoring the Cisco ios -1. verifying flash memory-Ensuring flash memory has enough room router#sh flash -2. Backing-up the ciso ios first verify server connectivity by- Router#ping 192.168.0.120 then; router#copy flash tftp CCNA4.com
  • 7. CCNA4.com -3. Restoring or upgrading the cisco router ios router#copy tftp flash [confirm][ENTER] ?[ENTER] -Backing up and Restoring the Cisco configuration 1.Backing up the cisco router configuration -copy runing config tftp 2. verifying the current configuration -sh run 3. copying the current cofiguration to NVRAM -copy run start 4. copying the current configuration to a TFTP server -copy run TFTP 5. Restoring the Cisco Router Configuration -copy TFTP run 6. Erasing the configuration -erase startup-config -Getting CDP timers and Holdtime information Router#config t Router(config)#cdp timer 90 Router(config)#cdp holdtime 240 Router(config)#^z -To turn-off CDP Completely-no cdp run -Gathering Neighbour information kenn2509#sh cdp nei- delivers information about directly connected devices OR kenn2509#sh cdp neighbour detail Also sh cdp entry -Gathering Interface Traffic Information kenn2509#sh cdp traffic -Gathering port and Interface information kenn2509#sh cdp interface -To turn off cdp on a router, use no cdp enable then ^z -Using Telnet kenn2509#telnet 172.16.10.2 -Telnetting into multiple devices simultaneously kenn2509#telnet 172.16.10.2 then, 2501B>{cntl+shift+6, then x} CCNA4.com
  • 8. CCNA4.com -checking Telnet connections kenn2509#sh sessions-connections from your router to remote -checking Telnet users kenn2509#sh user -closing Telnet sessions 1900switch>exit OR kenn2509#disconnect1 (num of active networks) -Resolving Hostname kenn2509#config t kenn2509(config)#ip host 2501B 172.16.10.2 kenn2509(config)#ip host 1900switch 192.168.0.148 kenn2509(config)#^z -To remove a hostname from a table, use RouterA(config)#no ip host routerB -Using DNS to resolve names #config t (config)#ip domain-lookup (usually turned on by default) (config)#ip name-server 192.168.0.70 (ip of an assumed DNS set) (config)#ip domain-name kenn.com (Appends the domain name to a host) (config)#^z -Check Network Connectivity use ping command #ping kenn2509 -Using Traceroute command #trace 2501B -Creating a Standard Access Lists (1-99 or 1,300-1,999) (config)#access-list 10 deny 172.16.30.2 (using the ip as a test) -Controlling vty(Telnet) sessions (config)#access-list 50 permit 172.16.30.2 (config)#line vty 0 4 (config-line)#access-class 50 in -Creating Extended Access-lists (100 to 199) OR (2000 to 2699) (config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log (config)#access-list 110 permit ip any any (config)#int f0/0 (config-if)#ip access-group 110 in (config-if)#ip access-group 110 out CCNA4.com
  • 9. CCNA4.com By kennifeh CCNA4.com