1._ejercicio1
//Guardar 10 números en un arreglo//
//Mostrar cuántos valores son negativos, positivos y cero//
Proceso gua...
menor<-99
para i<-1 hasta n hacer
si edad[i]<menor entonces
menor<-edad[i]
d<-i
FinSi
FinPara
escribir "la edad menor es "...
cod[j]<-temp
FinSi
FinPara
FinPara
FinSubProceso
Subproceso orden_D(cod)
Definir i, j, temp Como Entero
Para i<- 1 hasta 9...
Próxima SlideShare
Cargando en…5
×

Arreglos ejercicios resueltos

114 visualizaciones

Publicado el

0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
114
En SlideShare
0
De insertados
0
Número de insertados
3
Acciones
Compartido
0
Descargas
1
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Arreglos ejercicios resueltos

  1. 1. 1._ejercicio1 //Guardar 10 números en un arreglo// //Mostrar cuántos valores son negativos, positivos y cero// Proceso guardar dimension num[10] definir num,n,i,ne,pos,cero como entero escribir "ingrese cantidad de numeros" leer n ne<-0 pos<-0 cero<-0 Para i<-1 hasta n hacer escribir "n", i leer num[i] finpara para i<-1 hasta n hacer escribir "n",i, ": ",num[i] FinPara para i<-1 hasta n hacer si num[i]>0 entonces pos<-pos+1 Sino si num[i]<0 entonces ne<-ne+1 Sino si num[i]=0 entonces cero<-cero+1 finsi finsi finsi finpara escribir "positivos: ",pos escribir "negativos: ",ne escribir "cero: ", cero FinProceso -------------------------------------------------------------------------------- 2._ejercicio2 //guardar n edades (máximo 50) de deportistas en un vector y// //mostrar la menor de las edades y a que deportista corresponde.// Proceso menores_edades dimension edad[50] definir n,i,edad,menor,d como entero escribir "ingresar cantidad de deportistas" leer n para i<-1 hasta n hacer escribir "edad_", i leer edad[i] FinPara para i<-1 hasta n Hacer escribir "edad_", i, " " , edad[i] FinPara
  2. 2. menor<-99 para i<-1 hasta n hacer si edad[i]<menor entonces menor<-edad[i] d<-i FinSi FinPara escribir "la edad menor es ", menor," y pertenece al deportista ", d FinProceso -------------------------------------------------------------------------------- ---- 3._ejercicio 3 //Se desea ingresar por teclado 10 números, utilice un Menú de opciones para:// //a.- Ordenar y Listar los Números en forma ascendente// //b.- Ordenar y Listar los Números en forma descendente// Proceso Principal Dimension codigo[10] Definir codigo Como Entero llenarVector(codigo) menu( ) seleccion(codigo) Escribir "Arreglo ordenado" mostrarVector(codigo) FinProceso Subproceso menu( ) Escribir "Menú Ordenamiento" Escribir "1. Orden ascendente" Escribir "2. Orden descendente" Escribir "3. Salir" FinSubProceso Subproceso seleccion(cod) definir op como entero Escribir "Escoger una opción:" Leer op Segun op Hacer 1: orden_A(cod) 2: orden_D(cod) 3: FinSegun FinSubProceso Subproceso llenarVector(cod) Definir i como Entero Para i <-1 hasta 10 hacer Escribir "Codigo ", i Leer cod[i] FinPara FinSubProceso Subproceso mostrarVector(cod) Definir i como Entero Para i <-1 hasta 10 hacer Escribir "Codigo ", i," " Escribir cod[i] FinPara FinSubProceso Subproceso orden_A(cod) Definir i, j, temp Como Entero Para i<- 1 hasta 9 hacer Para j<- i+1 hasta 10 hacer Si cod[i]>cod[j] entonces temp<-cod[i] cod[i]<-cod[j]
  3. 3. cod[j]<-temp FinSi FinPara FinPara FinSubProceso Subproceso orden_D(cod) Definir i, j, temp Como Entero Para i<- 1 hasta 9 hacer Para j<- i+1 hasta 10 hacer Si cod[i]<cod[j] entonces temp<-cod[i] cod[i]<-cod[j] cod[j]<-temp FinSi FinPara FinPara FinSubProceso

×