Programacion
Upcoming SlideShare
Loading in...5
×
 

Programacion

on

  • 1,749 reproducciones

 

Estadísticas

reproducciones

reproducciones totales
1,749
reproducciones en SlideShare
1,749
reproducciones incrustadas
0

Actions

Me gusta
1
Descargas
40
Comentarios
0

0 insertados 0

No embeds

Accesibilidad

Categorias

Detalles de carga

Uploaded via as Microsoft Word

Derechos de uso

© Todos los derechos reservados

Report content

Marcada como inapropiada Marcar como inapropiada
Marcar como inapropiada

Seleccione la razón para marcar esta presentación como inapropiada.

Cancelar
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Tu mensaje aparecerá aquí
    Processing...
Publicar comentario
Edite su comentario

Programacion Programacion Document Transcript

  • UNIDAD EDUCATIVA EXPERIMENTAL BERNARDO VALDIVIESO CONTENIDOS DEL SEGUNDO DE BACHILLERATO DE LA MATERIA DE INFORMÁTICA.BLOQUE 1. Pseudocódigo. Formato de pseudocódigo. Palabras Reservadas. Paso de un diagrama de flujo a un pseudocódigo. PSeInt.BLOQUE 2. Estructuras Secuenciales. Estructura de la estructura secuencial. Instrucción de asignación. Instrucción entrada de datos. Instrucción salida de datos.BLOQUE 3. Estructuras Selectivas. Estructura selectiva simple. Estructura selectiva doble. Estructura selectiva anidada.BLOQUE 4. Estructura Repetitivas. Bucle. Variables tipo contador. Variables tipo acumulador. Variables tipo bandera. Tipos de estructuras repetitivas. o Estructura repetir. o Estructura mientras. o Estructura para.BLOQUE 5. Metodología Orientada a Objetos. Clase. Objeto. Herencia. Polimorfismo. Diagramación en UML.BLOQUE 6. Programación Básica Orienta a Objetos. Lenguaje de Programación Orientada a Objetos.
  • DESARROLLO DE LOS CONTENIDOS DE BLOQUEBLOQUE 1. Pseudocódigo.1.1 Formato de pseudocódigo. El pseudocódigo es una herramienta excelente para el seguimiento de la lógica de un algoritmo y para transformar con facilidad los algoritmos a programas escritos en un lenguaje de programación estructurado como: C/C++, Java, Visual Basic, javascript, php, phyton, C#, entre otros. El pseudocódigo es un lenguaje de especificación de algoritmos que utiliza palabras reservadas de un idioma y exige la identación, o sea sangría en el margen izquierdo, de algunas líneas. Formato 1: algoritmo nombre_algoritmo [const <declaraciones de constantes>] [tipo <declaraciones de tipos de datos] [variables <declaraciones de variables>] Inicio instrucción 1 instrucción 2 instrucción 3 ……………. ……………. Instrucción n fin Formato 2 (PSeInt): Proceso nombre_proceso Definir <var1>, <var2>,…..,<varN> Como [REAL/ENTERO/LOGICO/CARACTER]; instrucción 1 instrucción 2 instrucción 3 ……………. ……………. instrucción n FinProceso1.2 Palabras Reservadas. En los lenguajes de programación, una palabra reservada es una palabra que tiene un significado gramatical especial para ese lenguaje y no puede ser utilizada para nombrar a las variables, funciones, procedimientos, objetos y demás elementos de programación que cree. Generalmente Las palabras reservadas en el desarrollo de algoritmos utilizando pseudocódigos se escribirán en minúsculas y en negrillas. Proceso Leer Segun_Hacer Para_Hasta_Con Paso_Hacer
  • FinProceso Escribir FinSegun FinPara Definir…. Como Si_Entonces De Otro Modo Borrar Pantalla Sino Mientras_Hacer esperar Segundos FinSi FinMientras1.3 Paso de un diagrama de flujo a un pseudocódigo. El paso de un diagrama de flujo a pseudocódigo o viceversa no presenta inconvenientes, como podemos observar en el siguiente ejemplo. (dibujar el ejemplo planteado por el docente)1.4 PSeInt. Es una herramienta para aprender la lógica de programación, orientada a estudiantes sin experiencia en dicha área. Mediante la utilización de un simple y limitado pseudo-lenguaje, intuitivo y en español, permite comenzar a comprender conceptos básicos y fundamentales de un algoritmo computacional. Nacido originalmente como proyecto final para la materia Programación I de la carrera Ingeniería en Informática de la Facultad de Ingeniería Hídricas de la Universidad Nacional del Litoral, es en realidad un intérprete de pseudocódigo basado en los contenidos de la cátedra de Fundamentos de Programación de dicha carrera.A continuación se muestra un ejemplo escrito Para los perfiles Estricto y Flexible, ilustrando algunasdiferencias entre configuraciones:Proceso Estricto Proceso Flexible Definir VAL_MAYOR,ARREGLO,CANT,I ComoEnteros; Escribir "Ingrese la cantidad de Dimension ARREGLO[100]; numeros:" Escribir "Ingrese la cantidad de Leer CANTnumeros:"; Dimension ARREGLO[CANT] Leer CANT; Para Cada Elemento de ARREGLO Para I<-0 Hasta CANT-1 Hacer Escribir "Ingrese un numero:" Escribir "Ingrese un numero:"; Leer ELEMENTO Leer ARREGLO[I]; Fin Para FinPara VAL_MAYOR<-0 VAL_MAYOR<-0; Para Cada ELEMENTO de ARREGLO Para I<-0 Hasta CANT-1 Hacer Si ELEMENTO Es Mayor Que VAL_MAYOR Si ARREGLO[I]>VAL_MAYOR Entonces VAL_MAYOR<-ELEMENTO VAL_MAYOR<-ARREGLO[i]; Fin Si FinSi Fin Para FinPara Si VAL_MAYOR Es Par Si VAL_MAYOR % 2 = 0 Entonces Escribir "El mayor es " VAL_MAYOR
  • Escribir "El mayor es ",VAL_MAYOR," " y es par"y es par"; Sino Sino Escribir "El mayor es " VAL_MAYOR Escribir "El mayor es ",VAL_MAYOR," " y es impar"y es impar"; Fin Si FinSi FinProcesoFinProceso
  • BLOQUE 2. Estructuras Secuenciales.2.1 Estructura de la estructura secuencial. Introducción. El procesador de cualquier computadora ejecuta los pasos y acciones de un algoritmo uno a uno. El orden en el que va ejecutando las acciones se conoce como flujo de control, y decimos que conforme el algoritmo se va ejecutándose, el control va pasando de una acción a otra. Todo algoritmo estructurado tiene estructuras de control básicas, que todos los lenguajes de programación lo tienen, los mismos que son los siguientes: La estructura secuencial donde el control pasa de una acción a la siguiente. La estructura selectiva que nos permite de acuerdo a una condición tomar un camino u otro. La estructura repetitiva en donde un conjunto de acciones se repiten un cierto número de veces. Estructura Secuencial. Secuencial es la realización de un acto inmediatamente después de otro. Las acciones dentro de un algoritmo son ejecutadas en el orden en el cual se encuentran escritos. Mediante esta estructura se pueden representar: Instrucciones de asignación. Instrucciones de entrada de datos. Instrucciones de salida de datos. La estructura secuencial, como todas las estructuras que forman parte de la programación estructurada, tienen una sola entrada y una sola salida. Representación de la estructura secuencial. (Poder dibujo hecho en clase o escaneado)2.2 Instrucción de asignación. Por medio de esta instrucción se asigna a una variable el resultado de evaluar una expresión. Al lado izquierdo de la instrucción se encuentra la variable, al derecho la expresión y uniendo el signo “=” o “ “, denominado operador de asignación. Asignar a S = (B*H)/2 Al ejecutarse una instrucción de asignación se evalúa la expresión, el cual da como resultado un único valor ; éste es llevado a la dirección de memoria asignada a la variable que recibe información. El dato o valor que arroje la expresión debe ser del mismo tipo que la variable; de esta manera si el resultado es numérico la variable debe ser numérica, si es lógico o carácter la variable también lo debe ser. Por ejemplo:
  • A = 62 Asigna a la variable A un número entero. PI = 3.141592 Asigna a la variable PI un número real. RESP = (A>B) OR (X<Y) Asigna un valor lógico. NOMBRE = “SAMUEL” Asigna un dato carácter.2.3 Instrucción de entrada de datos. Leer [<lista de variables separadas por comas >] Una instrucción de entrada de datos es una orden, para que desde un medio externo se ingresen valores, y dichos datos sean llevados a las direcciones de memoria, asignadas a las variables utilizadas para almacenar los datos de entrada en el proceso. En diagrama de flujo A,B,C En pseudocódigo Leer (A,B,C)2.4 Instrucción de salida de datos. Escribir [< lista de variables separadas por comas o comentarios >] Mediante la instrucción de salida se extraen valores de salida permitido. En esta instrucción se permite acompañar los resultados con comentarios explicativos de los valores que se muestran en el medio de salida. En diagrama de flujo En pseudocódigo. Escribir (A,B,C) A,B,C “Los valores son:”, A,B,C Escribir(“Los valores son:”, A,B,C) Si en una instrucción de salida se tiene un grupo de caracteres entre comillas, este será impreso sin ninguna modificación en el medio de salida y lo que aparezca sin comillas se asume que es una variable; por lo tanto, se extrae de la memoria el contenido de ésta.