Ejercicios pseint
Upcoming SlideShare
Loading in...5
×
 

Ejercicios pseint

on

  • 64,892 reproducciones

Aqui comparto un material muy

Aqui comparto un material muy

Estadísticas

reproducciones

reproducciones totales
64,892
reproducciones en SlideShare
64,380
reproducciones incrustadas
512

Actions

Me gusta
3
Descargas
909
Comentarios
1

5 insertados 512

http://royer-proyectosdeinformtica1.blogspot.com 416
http://royer-proyectosdeinformtica1.blogspot.mx 83
http://royer-proyectosdeinformtica1.blogspot.com.ar 9
http://royer-proyectosdeinformtica1.blogspot.com.es 3
http://www.slideshare.net 1

Accesibilidad

Categorias

Detalles de carga

Uploaded via as Adobe PDF

Derechos de uso

© Todos los derechos reservados

Report content

Marcada como inapropiada Marcar como inapropiada
Marcar como inapropiada

Seleccione la razón para marcar esta presentación como inapropiada.

Cancelar
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Tu mensaje aparecerá aquí
    Processing...
Publicar comentario
Edite su comentario

Ejercicios pseint Ejercicios pseint Document Transcript

  • Ejercicio 1.-Proceso arregloContinuar<-"si";Mientras Continuar="si" Hacer Dimension C[100], P[100], G[100]; Escribir "Ingrese la Cantidad de Viviendas que se alquilan actualmente"; Leer Cant_vivi; Para i<-1 Hasta Cant_vivi Hacer Escribir "Ingrese Cuanto se Paga mensualmente por la Vivienda,",i, ":"; Leer C[i]; FinPara Para i<-1 Hasta Cant_vivi Hacer Escribir "Ingrese que porcentaje se obtiene de ganancia por la Vivienda,",i, ":"; Leer P[i]; Porcentaje<-P[i]/100; FinPara Para i<-1 Hasta Cant_vivi Hacer G[i]<-C[i]*Porcentaje; Escribir "La Ganancia que se obtiene de la Casa,",i, ":"; Escribir "Es de:", G[i]; FinPara Si Cant_vivi>100 Entonces Escribir "Cantidad de Viviendas no disponible"; FinSi Escribir "¿Desea continuar?"; Leer Continuar;FinMientrasEscribir “Gracias por usar Una pagina y un programa desarrollado por Omar Web Technology”;FinProceso
  • Ejercicio 2.-Proceso sueldo_de_empleados Escribir "Bienvenidos, por favor ingrese el sueldo del primer Empleado"; Leer Empleado1; Escribir "Ahora por favor ingrese el sueldo del segundo Empleado"; Leer Empleado2; Escribir "Para finalizar ingrese el sueldo del tercer Empleado"; Leer Empleado3; Aumento1<-Empleado1*0.10; Salario1<-Empleado1+Aumento1; Escribir "El Sueldo con un aumento del 10% al Primer Empleado es de:", Salario1; Aumento2<-Empleado2*0.12; Salario2<-Empleado2+Aumento2; Escribir "El sueldo con un aumento del 12% al Segundo Empleado es de:", Salario2; Aumento3<-Empleado3*0.15; Salario3<-Empleado3+Aumento3; Escribir "El sueldo con un aumento del 15% al Tercer Empleado es de:", Salario3; Escribir “Gracias por usar Una pagina y un programa desarrollado por Omar WebTechnology”;FinProceso
  • Ejercicio 3.-Proceso calculo_de_superficies opcion<-0; Escribir "CALCULO DE SUPERFICIES (version 1.0)"; Escribir "Para hallar el Area de un Cuadrado presione 1"; Escribir "Para hallar el Area de un Circulo presione 2"; Escribir "Para hallar el Area de un Rectangulo presione 3"; Escribir "Para hallar el Area de un Trapecio presione 4"; Escribir "Para hallar el Area de un Triangulo presione 5"; Leer opcion; Si opcion=1 Entonces Escribir "Para calcular el area de un Cuadrado, ingrese el valor del lado"; Leer lado; Areacuadrado<-lado*lado; Escribir "El valor del Area del cuadrado es de:", Areacuadrado; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint y el estudiante Omar"; Sino Si opcion=2 Entonces Escribir "Para hallar el area de un circulo, ingrese el valor del radio"; Leer radio; Areacirculo<-3.14*radio*radio; Escribir "El area de un circulo es de:", Areacirculo; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint y el estudiante Omar"; Sino Si opcion=3 Entonces Escribir "Para hallar el valor del Rectangulo, ingrese el valor de la base"; Leer base; Escribir "Ahora ingrese la altura"; Leer altura; Arearectangulo<-base*altura; Escribir "El Area del Rectangulo es", Arearectangulo; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint y el estudiante Omar"; Sino Si opcion=4 Entonces Escribir "Para encontrar el Area de un Trapecio, ingrese el valor de la base1"; Leer base1; Escribir "Ingrese ahora la base2"; Leer base2; Escribir "Finalmente ingrese el valor de la altura"; Areatrapecio<-(base1+base2)*altura/2; Escribir "El area de un trapecio es de:", Areatrapecio; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint y el estudiante Omar"; Sino Si opcion=5 Entonces Escribir "Para hallar el valor del area de un triangulo, por favor ingrese el valor de la base"; Leer base; Escribir "Ahora ingrese el valor de la altura"; Leer altura; Areatriangulo<-(base*altura)/2; Escribir "El area del Triangulo es de:", Areatriangulo; Escribir "Gracias por usar nuestro programa, desarrollado por Pseint y el estudiante Omar"; FinSi FinSi FinSi FinSi FinSiFinProceso
  • Ejercicio 4.-Proceso calificacion_aprobado Escribir "Bienvenido Estimado Docente"; Escribir "Por favor, Ingrese la Calificacion del Estudiante"; Leer Calificacion; Si Calificacion>8 Entonces Escribir "El Alumno, Aprobo el Examen"; Sino Escribir "El Alumno, No Aprobo el Examen"; FinSi Escribir “Gracias por usar Una pagina y un programa desarrollado por Omar WebTechnology”;FinProceso
  • Ejercicio 5.-Proceso sin_titulo Continuar<-"s"; Mientras Continuar= "s" Hacer Escribir "Estimado Usuario, ingrese El nombre del Paciente"; Leer Nombre; Escribir "Ingrese el Numero de Dias Hospitalizado"; Leer Dh; Escribir "Que tipo de Enfermedad posee segun las opciones"; Escribir "Presione 1 Fiebre Costo/Paciente/Dias = 1500"; Escribir "Presione 2 Dengue Costo/Paciente/Dias = 1700"; Escribir "Presione 3 Influenza Costo/Paciente/Dias = 1900"; Leer Opcion; Segun Opcion Hacer 1: Total<-Dh*1500; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar", Total; 2: Total<-Dh*1700; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar", Total; 3: Total<-Dh*1900; Escribir "Paciente:", Nombre; Escribir "Dias Hospitalizado:", Dh; Escribir "Tipo de Enfermedad:", Opcion; Escribir "Total a Pagar:", Total; FinSegun Si Opcion>3 Entonces Escribir "Error, cierre y vuelva abrir el programa" FinSi Escribir "¿Desea Continuar?"; Leer Continuar FinMientras Escribir “Gracias por usar Una pagina y un programa desarrollado por Omar WebTechnology”;FinProceso
  • Ejercicio 6.-Proceso contador N<-0; contador<-0; sumador<-0; Mientras contador<=8 Hacer contador<-contador+2; sumador<-sumador+contador; FinMientras Escribir "El valor de los numeros impares es:", sumador;FinProceso
  • Ejercicio 7.-Proceso positivos_y_se_detiene_en_negativos numero<-0; contador<-0; Escribir "Ingrese el numero"; Leer numero; Mientras numero>0 Hacer contador<-contador+1; Escribir "Ingrese el numero"; Leer numero; FinMientras Escribir "El numero es:", contador;FinProceso
  • Ejercicio 8.-Proceso Vectores Dimension V1(500), V2(500) Escribir "Por favor ingrese la cantidad de vectores a almacenar" Leer Cant_vect; Para i<-1 Hasta Cant_vect Hacer Escribir "Ingrese el valor del vector", i; Leer V1 (i); FinPara Para i<-1 Hasta Cant_vect Hacer V2(i)<- V1(i)^2; Escribir "El valor al cuadrado de la posicion:", i; Escribir "Es de:", V2(i); Escribir "Y el valor Original es de:", V1(i); FinPara Escribir "Gracias por Usar un programa desarrollado por Omar Landaeta";FinProceso
  • Ejercicio 9.-Proceso Ecuación_d_ Segundo_grado Escribir "Bienvenido, por favor ingrese un valor para a"; Leer a; Escribir "Ahora ingrese un valor para b"; Leer b; Escribir "Ingrese un valor para c"; Leer c; J<- b^2-(4*a*c); Si J<0 Entonces Escribir "No procesa"; Sino X1<- -b + RC (J)/2*a; X2<- -b - RC (J)/2*a; Escribir "El Valor de X1 es:", X1; Escribir "El Valor de X2 es:", X2; FinSiFinProceso
  • Ejercicio 10.-Proceso empresa_arreglos Dimension Obrero (200); Escribir "Ingrese el precio del salario pagado por horas trabajadas"; Leer Sph; Escribir "ingrese la Cantidad de Obreros de su empresa"; Leer Cant_obreros; Para i<-1 Hasta Cant_obreros Hacer Escribir "Ingrese el nombre del Obrero"; Leer Obrero (i); Escribir "Ingrese la cantidad de horas trabajadas"; Leer Ht; Si Ht>40 y Ht<=48 Entonces Tp<-Sph^2*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar por horas extras es de:", Tp; FinSi Si Ht>48 Entonces Tp<-Sph^3*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar por horas extras es de:", Tp; FinSi Si Ht<=40 Entonces Tp<-Sph*Ht; Escribir "El nombre del trabajador::",i; Escribir " ", Obrero(i); Escribir "El precio a pagar es de:", Tp; FinSi FinPara Escribir "Gracias por Usar un programa desarrollado por Omar Landaeta";FinProceso