KAREN ARLETH REYNA ARCOS &JOCELYN VIANEY MEDINA CASTILLO
PSEUDOCODIGOS
1.-Desarrolle un algoritmo que permita leer los dos...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
3.- NATALI tiene 36 años y tiene una hija llamada Heidi de 8 año...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
Inicio
Valor (L1)Valor (L2)
A=Multiplicar L1*L2
Obtener resultad...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
7.- Una persona decide invertir su capital en el banco y desea s...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
SALIR
Compra = 15% = Descuento
Imprimir
Salir
10.- Desarrolle un...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
IMPRIMIR
SALIR
Inicio
H = x M = y
(H) 100%
(M) 100%
M + H = ?
Ob...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
INICIO Inicio
Ingresar nuevo salario
(NUEVO SALARIO)=salario ant...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
16.- Jocelyn se compró un pantalón con un costo de $750.00 pesos...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
INICIO
Ingresarcosto de c/u
(Pollo-$85.00 , Espagueti-$10.00, F....
22.- Realizar un diagrama de flujo de un programa que permita escribir en pantalla los 100
primeros números pares.
Proceso...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
par <- par + 1;
FinSi
FinPara
porcentaje <- par/cant*100.0;
Escr...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
Escribir "Ingrese el numero ",i;
Leer numero;
suma <- suma + num...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
29.- Elaborar el diagrama de flujo de un programa que realice la...
KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO
30.-Realizar el diagrama de flujo de un programa para calcular l...
Próxima SlideShare
Cargando en…5
×

Ejemplos de cómo realizarlosavanzado

272 visualizaciones

Publicado el

0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
272
En SlideShare
0
De insertados
0
Número de insertados
7
Acciones
Compartido
0
Descargas
15
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Ejemplos de cómo realizarlosavanzado

  1. 1. KAREN ARLETH REYNA ARCOS &JOCELYN VIANEY MEDINA CASTILLO PSEUDOCODIGOS 1.-Desarrolle un algoritmo que permita leer los dos valores distintios determinar cual de los dos valores es el mayor y escribirlo INICIO Inicializar las variables A , B y C Leer los tres valores Almacenar en las variables A , B y C Si A >B y a>c Entonces Escribir A “Es el mayor” Sino Si B > A y B > C Entonces Escribir B “Es el mayor” Sino Escribir C “ Es el mayor “ Fin_Si Fin_Si Fin 2.- Esperanza y Miriam van a cumplir años el mismo día 13 de marzo, pero Esperanza nació en 1988 y Miriam en 1992. ¿Por cuantos años es más grande Esperanza? INICIOINICIO ESPERANZA-1988 Y MIRIAM-1992 1992-1988 IMPRIMIR RESULTADO =4Ingresar años de nacimiento Salir 1992 - 1988 Resultado = 4 Salir
  2. 2. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO 3.- NATALI tiene 36 años y tiene una hija llamada Heidi de 8 años. A los cuantos años NATALI tuvo a HEIDI? INICIOInicio Ingresar edades NATALI - 36 Y JEIDI - 8 Sumar (36–8) IMPRIMIR RESULTADO =28 Ingresar edades SALIR Sumar 36 - 8 Imprimir resultado 28 años Salir 4.- Si ARISAI y KAREN van a comprar un oso de peluche que cuesta $1,457.00 y tienen que dejar el 20% para poder apartarlo, cuánto dinero tienen que dejar? INICIOInicio Costo sin descuento 1,457 Descuento 20% (.20)Costo sin descuento Multiplicar 1,457*O.20 1,457 IMPRIMIR RESULTADO 291.4 SALIR Descuento 20% (.20) Multiplicar 1,457 * .20 Imprimir resultado Salir 5.- Determinar el área de un rectángulo cualquiera. Área y perímetro de un rectángulo INICIO Ingresar el valor del lado 1 Ingresar el valor de lado 2 L1 El área se obtiene de multiplicar lado por lado L1*L2 El perímetro se obtiene de sumar todos sus lados,L1+L2+L1+L2L2 IMPRIMIR RESULATDO SALIR
  3. 3. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO Inicio Valor (L1)Valor (L2) A=Multiplicar L1*L2 Obtener resultado P = Sumar L1+L2+L1+L2 Imprimir resultado Salir 6.-Buscar area de un circulo , considerando el símbolo π, cuyo radio mide 2 cm , INICIOInicio Ingresar el radio Formula de πRadio Multipicar IMPRIMIR RESULTADOFormula π*radio SALIR *Radio (π) =? 3.1416 x Radio ( 2cm) Imprimir Salir
  4. 4. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO 7.- Una persona decide invertir su capital en el banco y desea saber cuánto dinero ganara después de un mes, si el banco paga el 2% mensual. Inicio INICIO Ingresar capitalCapital Ganancia de capital*.02 IMPRIMIR GANANCIAGanancia= Capital SALIR *.02 Ganancia total Salir 8.- Un vendedor recibe un sueldo base, más un 10% extra por comisiones de sus ventas. El vendedor desea saber cuánto dinero obtendrá por concepto de comisiones por las tres ventas que realizo en el mes y el total que recibirá en el mes tomando en cuenta el sueldo base y sus comisiones INICIO Inicio Ingresar sueldo base Obtener porcentaje de comisión 10% Sueldo base Comisión de ventas V1,V2 y V3. Sueldo mensual Porcentaje de ventas IMPRIMIR SUELDO (v1 , v2 , v3) SALIR Comisión (v1,v2,v3) Mensualidad Comisión Salir 9.-Una tienda ofrece un descuento del 15% sobre el total de la compra y un cliente desea saber cuánto deberá pagar finalmente por su compra INICIOInicio Pago original (sin descuento) Pago con descuento Paga original de la compra Pago total de la compra IMPRIMIR Descuento = compra por 15%
  5. 5. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO SALIR Compra = 15% = Descuento Imprimir Salir 10.- Desarrolle un algoritmo que permita leer los dos valores distintos, determinar cual de,los valores es el mayor y escribirlo. Fin 11.- Un maestro desea saber que porcentajes de hombres y mujeres hay en un grupo INICIO Cantidad de hombres y mujeres Multiplicar por el 100% para obtener un porcentaje Dividir el resultado entre la suma total de alumnos Obtener el porcentaje de H y M
  6. 6. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO IMPRIMIR SALIR Inicio H = x M = y (H) 100% (M) 100% M + H = ? Obtener porcentaje de H=% y M=% (Resultado) Imprimir Salir 12.-Dada una cantidad en pesos, obtener la equivalencia en dólares, asumiendo que la unidad cambiaria es un dato desconocido. INICIOInicio Cantidad en pesos Ingresar costo del dólarCantidad en pesos Dividir la cantidad de pesos entre el costo de un dólar Obtener la unidad cambiaria Dólar = ? IMPRIMIR SALIR$/Dolar Unidad Cambiaria Imprimir Salir 13.- Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% de su salario anterior
  7. 7. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO INICIO Inicio Ingresar nuevo salario (NUEVO SALARIO)=salario anterior*25% Nuevo Salario Obtener incremento Imprimir (NS) (SA) * 25% SALIR Obtener Incremento Imprimir Salir 14.-Desarrollar un algoritmo y un diagrama de flujo que determine cuál de los dos números es mayor INICIO N1>N2 Obtener valor de N1 Y n2 Comparar los valores Resultado IMPRIMIR SALIR INICIO N1>N2 Obtener valor de N1 y N2 Comparar los valores Resultado IMPRIMIR SALIR 15. -
  8. 8. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO 16.- Jocelyn se compró un pantalón con un costo de $750.00 pesos, pero el pantalón tenía un descuento del 40%. Cuanto pago Jocelyn por el pantalón? INICIO Costo (sin descuento):$750 Descuento 40% (750*0.40) Imprimir costo con descuento = $300 SALIR INICIO Costo (sin descuento):$750 Descuento 40% (750*0.40) Imprimir costo con descuento $300 SALIR 17.- Arleth fue a la tienda de don Cástulo y compro 3 refrescos 4 chicles y 2 baguettes. Si cada refresco cuesta $9.00; los chicles $2.00 c/u y cada baguette cuesta $25.00 ¿Cuánto dinero gasto en total? INICIO Ingresar los precios de cada producto Sumar los precios en cantidades que compro IMPRIMIR RESULTADO SALIR INICIO Ingresar precios de cada producto Sumar precios en cantidades IMPRIMIR RESULTADO SALIR 18.- Don Esteban hizo un pedido en los “Pollos Lucy”(pollos asados) de10 pollos, 12/2 de espagueti y 15/2 de frijoles charros para la fiesta de su nieta. Si cada pollo cuesta $85.00, el 1/2 de espagueti cuesta $10.00 y los frijoles charros $12.00 ¿Cuánto pago en total Don esteban? INICIO Ingresar el costo de c/u de los pedidos (Pollo-$85.00 , Espagueti-$10.00, F.CH.-$12.00) Sumar el costo de cada pedido IMPRIMIR COSTO TOTAL SALIR
  9. 9. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO INICIO Ingresarcosto de c/u (Pollo-$85.00 , Espagueti-$10.00, F.CH.-$12.00) Sumar el costo de cada pedido IMPRIMIR COSTO TOTAL SALIR 19.-Karen hizo una fiesta en su casa y compro 10 pollos asados e invito a 6 amigos (Lucía , Juan , Miguel , Rocío , Jorge y Gerardo ) si cada pollo trae 8 piezas y en total se comieron 45 piezas ¿Cuántas piezas quedaron? INICIO Multiplicar núm. piezas cada pollo por núm. Pollos que compro Obtener núm. total de piezas IMPRIMIR SALIR INICIO Multiplicar núm. piezas c/pollo * núm. pollos que compro Obtener núm. total de piezas IMPRIMIR SALIR 21.-Hacer el pseudocódigo para sumar dos números leidos por teclado y escribir el resultado INICIO Num1,Num2,suma=entero Leer num1,num2 Suma=num1+num2 Escribir ”la suma es:”,suma Imprimir Salir Inicio Num1,Num2,suma=entero Leer num1,num2 Suma=num1+num2 Escribir ”la suma es:”,suma Imprimir Salir
  10. 10. 22.- Realizar un diagrama de flujo de un programa que permita escribir en pantalla los 100 primeros números pares. Proceso CienPrimerosPares Escribir "Los 100 primeros pares son"; num<- 0; Mientras num< 200 Hacer Escribir num; num<- num +2; FinMientras FinProceso 23.-Realizar el algoritmo y diagrama de flujo para calcular el volumen de un prisma recto. Proceso volumenPrisma Escribir "VOLUMEN DE UN PRISMA RECTO"; Escribir "Ingresar el area de la base"; Leer abase; Escribir "Ingresar la altura"; Leer altura; volumen <- abase*altura; Escribir "El volumen del prisma es: ", volumen; FinProceso 24.-Realizar el diagrama de flujo de un algoritmo que lea N números e imprima el porcentaje de números pares e impares. Proceso PorcentajeNumeros Escribir "Ingrese la cantidad de numeros:"; Leer cant; par <-0; Para i<-1 Hasta cant Con Paso 1 Hacer Escribir "Ingrese el numero ", i, " :"; Leer num; Si num%2 = 0 Entonces
  11. 11. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO par <- par + 1; FinSi FinPara porcentaje <- par/cant*100.0; Escribir "El porcentaje de : "; Escribir " - numeros pares: ", porcentaje; Escribir " - numeros impares: ", 100 - porcentaje; FinProceso 25.-Ejercicio: Realizar el diagrama de flujo para hallar el perímetro de un triangulo, el valor de los lados del triangulo se debe ingresar por teclado. Proceso PerimetroTriangulo Escribir "PERIMETRO DE UN TRIANGULO"; Escribir "Ingresar los lados: "; Escribir "Lado 1: "; Leer L1; Escribir "Lado 2: "; Leer L2; Escribir "Lado 3: "; Leer L3; perimetro<- L1+L2+L3; Escribir "Perimetro = ",perimetro; FinProceso 26.- Realizar un diagrama de flujo de un programa que permita la carga de 10 valores por teclado y muestre la suma de los valores ingresados y su promedio. Proceso SumaNumeros suma<-0; Para i<-1 Hasta cant Con Paso 10 Hacer
  12. 12. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO Escribir "Ingrese el numero ",i; Leer numero; suma <- suma + numero; FinPara Escribir "La suma es: ",suma; Escribir "El promedio es: ", suma/10; FinProceso 27.- Se te pide leer tres notas del alumno, calcular su promedio y enviar un mensaje donde se diga si el alumno aprobó el curso y lo minimo para pasar es 7. INICIOINICIO Cal1,cal2,cal3,:Real Res:real Lea nota1,nota2,nota3c CAL1 CAL2 CAL3 Res(cal1+cal2+cal3)/3 Si res<7 entonces Escriba “Reprobo el curso”Res(cal1+cal2+cal3)/3 Sino Escriba “Aprobo el curso”Si Fin-si Res<7 IMPRIMIR No SALIR Reprobó el curso Aprobó el curso Fin 28.-Desarrolle un algoritmo que permita leer los tres valores Y almacenados en las variables A,B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cuál es el menor. Recuerda constatar que los tres valores introducidos por el teclado sean valores distintos .Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.
  13. 13. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO 29.- Elaborar el diagrama de flujo de un programa que realice la suma de los números pares en un rango dado, los números inferior y superior del rango deben ser ingresados por teclado. Proceso SumaNumerosPares Escribir "SUMA DE NUMEROS PARES EN UN RANGO"; Escribir "Ingrese numero inferior: "; Leer inferior; Escribir "Ingrese numero superior: "; Leer superior; suma <- 0; Mientras inferior < superior Hacer Si inferior%2=0 Entonces suma <- suma + inferior; FinSi inferior <- inferior + 1; FinMientras Escribir "La suma de numeros pares es: ", suma; FinProceso
  14. 14. KAREN ARLETH REYNA ARCOS & JOCELYN VIANEY MEDINA CASTILLO 30.-Realizar el diagrama de flujo de un programa para calcular la suma de los 10 primeros números pares. Proceso SumaPares num<- 0; sum <- 0; Mientras num< 11 Hacer Si num%2 = 0 Entonces sum <- sum + num; FinSi num<- num + 1; FinMientras Escribir "La suma de los 10 primeros pares es: ",sum; FinProceso

×