FUNCIONESEN EXCEL
DIA.LAB
Descripción:
Devuelve un número que representa una fecha, obtenida al sumar un cierto número de
...
Descripción:
Devuelve el número de días laborables entre fecha_inicial y fecha_final. Los días
laborables no incluyen los ...
FUNCION POTENCIA
Descripción:
La función POTENCIA sirve para elevar un número a una potencia. La función requiere
dos (2) ...
Aplicaríamos la función de la siguiente forma:
=MAX(A1:A10)
Y en este caso el número mayor es: 90
FUNCION SI
Descripción:
...
La función quedaría de la siguiente forma:
=SI(A1>5,"MAYOR","NO ES MAYOR")
Como se aprecia en la imagen.
Posteriormente la...
=HIPERVINCULO("http://www.intelweb.com.mx","Directorio de empresas de
méxico")
Como nuestros argumentos son de tipo texto ...
Funcion RESIDUO
Descripción:
La función RESIDUO(numero,numero_divisor) nos da como resultado el residuo de dividir 2 numer...
Descripción:
Esta función devuelve un valor aleatorio entre dos numeros, es decir, cualquier numero entero entre los
numer...
Descripción:
Esta función se utiliza para contar los números en el rango seleccionado, omitiendo las celdas vacías y
las q...
Entero de un número
=ENTERO(6.95)
=ENTERO(-8.2)
En el primer caso el resultado es 6.En el segundo caso el resultado es -9 ...
Ejemplos de Operación:
Suma de un rango.
=SUMA(A1:A4)
En el ejemplo anterior se sumarán todos los números que se encuentre...
Nuestra condición a aplicar sobre los valores será escoger los que estén entre 100 y 350:
=SI(Y(valor>=100;valor<=350);val...
la función final que hemos logrado es:
=SI($C2="";CONTAR($C$2:$C$11)+1;JERARQUIA($C2;$C$2:$C$11;1)+CONTAR.SI($C$2:$C2;C2)-...
Próxima SlideShare
Cargando en…5
×

Funciones en excel

167 visualizaciones

Publicado el

Publicado en: Educación
0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
167
En SlideShare
0
De insertados
0
Número de insertados
3
Acciones
Compartido
0
Descargas
1
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Funciones en excel

  1. 1. FUNCIONESEN EXCEL DIA.LAB Descripción: Devuelve un número que representa una fecha, obtenida al sumar un cierto número de días laborales a una fecha inicial. Los días laborables excluyen los días de fin de semana y cualquier fecha identificada en el argumento vacaciones. Use DIA.LAB para excluir fines de semana o días festivos cuando calcule fechas de vencimiento de facturas, las fechas de entrega esperadas o el número de días de trabajo realizado. La función acepta como parámetros un dato de tipo fecha, el número de días laborales y de manera opcional, una matriz que contenga los días festivos. Sintaxis Completa: DIA.LAB(fecha_inicial;días_lab;vacaciones) Ejemplo de Operación: =DIA.LAB(C1,C2,C3) Resultado: 39980 (Número que representa la fecha 16/06/2009) Nota: Para convertir el número entero a su fecha correspondiente, solo debes aplicar formato de Fecha a la(s) celda(s) con este tipo de datos.
  2. 2. Descripción: Devuelve el número de días laborables entre fecha_inicial y fecha_final. Los días laborables no incluyen los fines de semana ni otras fechas que se identifiquen en el argumento festivos. Utilice DIAS.LAB para calcular el número de días trabajados de un empleado, considerando días de vacaciones dentro del período. Ejemplo de Operación: Un empleado trabajó en el período del 10/01/2008 (B2) al 31/01/2008 (C2) y tuvo vacaciones los días 11/01/2008 (A5) y 21/01/2008 (A6). Calcular el número de días laborados. =DIAS.LAB(B2,C2,A5:A6) Resultado: 14 días laborados en el período. FECHA Y HORA Descripción: Devuelve la fecha y la hora actuales con formato de fecha y hora. Esta función resulta muy útil cuando hacemos cálculos utilizando la fecha u hora actual o para mostrar la fecha actual en una hoja de cálculo. Esta función no tiene argumentos. Ejemplo de Operación: =AHORA() Resultado de muestra: 25/05/2009 16:11
  3. 3. FUNCION POTENCIA Descripción: La función POTENCIA sirve para elevar un número a una potencia. La función requiere dos (2) argumentos: Numero: El numero que queremos elevar. Potencia: La potencia a la que queremos elevar el valor que indicamos como número. Ejemplo de operación: Cual es el resultado de elevar 16 a la séptima potencia. La función sería entonces: =POTENCIA(16,7) El resultado es que 16 elevado a la 7ma potencia es igual a:268435456 Por último, es importante mencionar que los argumentos pueden ser referencia a celdas que tengan un valor numérico como se muestra en la siguiente imagen: FUNCION MAX Descripción: La función MAX sirve cuando tenemos un conjunto de números y deseamos saber cual es el mayor. Puede tener como argumento una serie de celdas individuales, un rango de celdas o una combinación de ambas. Esta función ignorará aquellos valores que sean de tipo texto o lógico. Ejemplo de operación: Utilizando la función MAX obtener cual es el numero más grande de los siguientes números: 10, 86, 87,15, 1, 16, 54, 68, 90, 62. Suponiendo que acomodamos todos los numero es la columna A como en aprecia en la siguiente imagen:
  4. 4. Aplicaríamos la función de la siguiente forma: =MAX(A1:A10) Y en este caso el número mayor es: 90 FUNCION SI Descripción: La función SI sirve para cuando requerimos evaluar una condición y dependiendo de si se cumple o no tener uno u otro resultado, es decir, si se cumple la condición tendríamos un resultado y si no se cumple el resultado sería otro. Esta función requiere de tres (3) argumentos: Prueba_Lógica: En la expresión que queremos evaluar. Valor_si_verdadero: Como su nombre lo indica, es el resultado si la prueba lógica resulta verdadera Valor_si_falso: Indica es el resultado si la prueba lógica resulta falsa. Ejemplo de operación: Si el numero que tenemos en la columna A es mayor que 5 la columna B debe decir “MAYOR”, de lo contrarioen B debe decir “NO ES MAYOR”
  5. 5. La función quedaría de la siguiente forma: =SI(A1>5,"MAYOR","NO ES MAYOR") Como se aprecia en la imagen. Posteriormente la función se debe repetir para cada valor que tengamos en “A” como se muestra en la imagen. Finalmente tenemos el resultado. FUNCION HIPERVINCULOS Descripción: La función HIPERVINCULO sirve para crear un link o enlace hacia un recurso, como puede ser un archivo almacenado en nuestra computadora o a un sitio Web en Internet, entre otros. Requiere 2 argumentos: Ubicación del vinculo.- Es la ubicación del recurso al que queremos hacer referencia. Si se trata de un archivo en nuestra computadora sería algo como: “C:ejemplosenlaces.xls”. Por otro lado si se trata de algún sitio Web sería algo como : http://www.intelweb.com.mx/. Nombre descriptivo: Es la etiqueta o rotulo que tendrá nuestro enlace. Si se trata de un archivo, siguiendo con el mencionado anteriormente, enlaces.xls, el Nombre pudiera ser “Archivo de Enlaces”, en el caso del sitio Web puede ser el Nombre Comercial del mismo, por ejemplo: “Directorio de Empresas de México”. Ejemplo de Operación: Crear un enlace hacia el sitio Webhttp://www.intelweb.com.mx que tenga como etiqueta o titulo “Directorio de Empresas de México. La función quedaría de la siguiente manera:
  6. 6. =HIPERVINCULO("http://www.intelweb.com.mx","Directorio de empresas de méxico") Como nuestros argumentos son de tipo texto van entre comillas como se puede apreciar. El resultado de esta función es: Al dar un clic sobre el texto se abrirá en el navegador de Internet la página indicada FUNCION PROMEDIO Descripción: La función PROMEDIO() sirve para obtener el promedio o media aritmética de un conjunto de valores. Como argumentos puede tener celdas individuales y/o rangos de celdas que tengan valores numéricos. Ejemplo de operación: Obtener el promedio de 2 valores: 10 y 6 =PROMEDIO(A1,A2) =PROMEDIO(A1:A2) En la primera imagen podemos apreciar 2 valores 10 y 6, como podemos ver, manejamos como argumentos de la función las 2 celdas correspondientes de manera individual (A1,A2). En la segunda imagen tenemos como argumento un rango (A1:A2) y el resultado es el mismo.
  7. 7. Funcion RESIDUO Descripción: La función RESIDUO(numero,numero_divisor) nos da como resultado el residuo de dividir 2 numeros (numero/numero_divisor). Ejemplos de operación: RESIDUO de dos números =RESIDUO(5,3) En este caso obtendremos el residuo de dividir 5/3, el cociente será igual a 1 y tendremos como resultado el residuo, es decir, 2. RESIDUO de valores almacenados en celdas (imagen de ejemplo) =RESIDUO(A1,A2) En este caso se dará la división del valor que tenemos en A1 entre el que esta en A2, siguiendo la imagen de ejemplo tenemos 10/3. El resultado de la división tendrá como cociente 3 y nuestro residuo y resultado de la función es 1. Funcion COCIENTE Descripción: La función COCIENTE(num1,num2), nos devuelve la parte entera de una división. Requiere 2 argumentos que deben ser números, el primero será el numerador o dividendo y el segundo será el denominador o divisor. Ejemplos de operación: COCIENTE de dos números =COCIENTE (4,2) En este caso obtendremos la parte entera de la división 4 entre 2 (4/2) cuyo resultado es igual a 2. COCIENTE de dos números almacenados en celdas (ejemplo en la imagen) =COCIENTE(A1,A2) En este caso obtendremos la parte entera de la división entre los valores que se encuentran en A1 y A2 (A1/A2), siguiendo la imgen de ejemplo, la división será 10/3, dando como resultado 3. En este caso la división tiene un residuo de 1 que no es tomado en cuenta para el resultado. Funcion ALEATORIO.ENTRE
  8. 8. Descripción: Esta función devuelve un valor aleatorio entre dos numeros, es decir, cualquier numero entero entre los numeros que indiquemos como argumentos (limite inferior y limite superior). El numero indicado como limite inferior debe ser menor o igual al limite superior, de lo contrario la función regresará el error #¡NUM!. Ejemplos de operación: Numero Aleatorio entre dos numeros =ALEATORIO.ENTRE(25,50) El resultado de esta función será cualquier numero entero entre 25 y 50, por ejemplo 32 Numero aleatorio entre dos numeros almacenados cada uno en una celda (siguiendo la imagen de ejemplo) =ALEATORIO.ENTRE(A1,A2) Resultado: Obtendremos un número entero entre los numeros que se encuentran almacenados en A1 y A2, siguiendo la imagen de ejemplo, entre 50 y 100 cuyo resultado puede ser por ejemplo 76. Funcion ALEATORIO Descripción: Esta función devuelve un valor aleatorio entre 0 y 1, es decir, cualquier numero real entre 0 y 1. Esta función no requiere argumentos. Ejemplos de operación: =ALEATORIO() El resultado de esta función será cualquier valor entre 0 y 1, por ejemplo 0.937904760616898 Si se requiere obtener un número aleatorio entre 0 y 100 se puede utilizar la siguiente fórmula, complementando la función ALEATORIO con la función ENTERO. =ENTERO(ALEATORIO()*100) Resultado: Al multiplicar el resultado de la función ALEATORIO (p.ej.0.937904760616898) por 100, obtendremos un número entre 0 y 100 (93.790476061689), posteriormente utilizamos la función ENTERO para obtener únicamente la parte entera de este número. El resultado final sería en este caso 93. Funcion CONTAR
  9. 9. Descripción: Esta función se utiliza para contar los números en el rango seleccionado, omitiendo las celdas vacías y las que contienen datos no numéricos. Ejemplos de operación: =CONTAR(A1:B5) En este caso, utilizando el ejemplo de la imagen, el resultado será igual a 8. Funcion FACT Descripción: Esta función nos da como resultado el factorial de un número (1*2*3*....Número) ; el numero debe ser positivo. La función puede tener como argumento un número o una referencia a una celda que contenga un número. Ejemplos de operación: Factorial de un número =FACT(4) En este caso el resultado sera 1*2*3*4, lo que es igual a 24. Factorial de un numero que está en una celda =FACT(A1) En este caso se obtiene el factorial del numero que este en la celda A1, tomando el valor de la imagen de ilustración que es 5, el resultado será 1*2*3*4*5, lo que es igual a 120. Funcion ENTERO Descripción: Redondea un número hasta el entero inferior más próximo. Ejemplos de operación:
  10. 10. Entero de un número =ENTERO(6.95) =ENTERO(-8.2) En el primer caso el resultado es 6.En el segundo caso el resultado es -9 ya que es el entero inferior más próximo. Entero del valor de una celda =ENTERO(A1) En este caso el resultado es el entero inferior más próximo del numero que se encuentre en la celda A1. Resultado (de la imagen de ejemplo) = 4 Función ABS Descripción: Devuelve el valor absoluto de un número. El valor absoluto de un número es el número sin signo. La función ABS se utiliza cuando requerimos el valor de un número sin tomar en cuenta su signo. Ejemplos de Operación: Valor absoluto de un número =ABS(-130) =ABS(130) En el primer caso se obtiene el valor sin signo del número -130, en el segundo caso se obtiene el valor sin signo de 130. Ambos ejemplos devuelven el mismo resultado. Resultado: 130 Valor absoluto del valor de una celda =ABS(A1) En este caso se obtiene el valor absoluto del número que se encuentra en la celda A1. Resultado: 130 Función SUMA Descripción: Suma todos los números de uno o varios rangos de celdas.
  11. 11. Ejemplos de Operación: Suma de un rango. =SUMA(A1:A4) En el ejemplo anterior se sumarán todos los números que se encuentren en el rango A1:A4, es decir A1+A2+A3+A4. Resultado: A1+A2+A3+A4 Suma de celdas separadas =SUMA(A1,B2,C3) En el ejemplo anterior se sumarán los valores de las celdas A1,A2 y A3 Resultado: A1+B2+C3 Suma de varios rangos =SUMA(A1:A3,B2:B4) En el ejemplo anterior se sumarán las celdas del rango A1:A3 (A1,A2,A3) más las celdas del rango B2:B4 (B2,B3,B4) Resultado: A1+A2+A3+B2+B3+B4 FUNCION JERARQUIA La cuestión que deseo plantear es la siguiente: necesito construir una función o algo así que me devuelva de un rango de celdas la posición (posición y contenido de la celda sería lo ideal) de la celda/s que cumplan una determinada condición (o condiciones, si tal cosa es posible). En la lengua de andar por casa que por ejemplo, a partir de un rango de celdas pueda sacar una lista con las posiciones de las celdas donde haya datos que sean menores que uno dado (o iguales o diferentes o otra condición que se desee imponer) y cuales son los valores que corresponden a cada celda de la lista obtenida. . Partiremos, para intentar solucionar esta cuestión, del siguiente listado de valores:
  12. 12. Nuestra condición a aplicar sobre los valores será escoger los que estén entre 100 y 350: =SI(Y(valor>=100;valor<=350);valor;"") con lo que obtenemos una nueva lista sólo con los valores que cumplen nuestra restricción. Ahora los ordenaremos, para lo cual utilizaremos la función de Excel JERARQUIA. =JERARQUIA(número; referencia; [orden]) Debemos tener cuidado con esta función, ya que si tuvieramos valores repetidos dentro de nuestro rango de estudio la función JERARQUIA asigna la misma jerarquía a los números duplicados, por lo que para poder resolver este inconveniente, incluiremos una nueva función =CONTAR.SI(rango; criterio) con esta función conseguiremos determinar qué valores están repetidos en nuestro rango de datos, y cuantas veces. Tenemos, por tanto, en este segundo paso, las siguientes funciones: =JERARQUIA(valor;rango_valores_restringidos;1) de donde obtenemos en qué posición se encuentra cada valor respecto a los valores que cumplen la condición inicial como si nuestro listado se ordenara en forma ascendente; y la función =CONTAR.SI($C$2:$C2;valor) nos fijamos que el rango determinado en el primer argumento de la función es móvil en cuanto a las filas, es decir, según copiamos la función el rango va creciendo. hemos conseguido con esto saber fila a fila cuantas veces se ha repetido un valor. Por último, uniendo en una sola función lo anteriormente expuesto, tenemos el siguiente orden:
  13. 13. la función final que hemos logrado es: =SI($C2="";CONTAR($C$2:$C$11)+1;JERARQUIA($C2;$C$2:$C$11;1)+CONTAR.SI($C$2:$C2;C2)-1) hemos incluido nuestra función dentro de un condicional SI para eliminar los errores de aquellos valores que no cumplían la condición inicial (valores entre 100 y 350). Sólo nos queda obtener el resultado final:

×