EJERCICIOS DEL MIENTRAS
Proceso EJERCICIO 1
contado<-0
sueldobase<-100000
Escribir "digite el numero de vendedores"
Leer v...
Leer obreros
Mientras contador<obreros y respuesta="s" Hacer
contador<-contador+1
Escribir "digite el numero de horas trab...
contador<-contador+1
Escribir " digite su gener (hombre/mujer)"
Leer genero
Si genero="mujer" o genero="MUJER" o genero="M...
Leer placas_2
total_amarillo<-placas_1+placas_2
3,4:
Escribir "cantidad de autos con placa terminada en 1"
amarillo<-amari...
FinProceso
Proceso EJERCICIO6
contador<-0
sumatoria<-0
Escribir " digite la cantidad de estudiantes"
Leer cantidad
Mientra...
Fin Mientras
Escribir "el total que recibira", total_1
FinProceso
Proceso EJERCICIO7
contador<-0
sumatoria<-0
hombre<-0
mu...
Escribir "total hombres",hombre
Escribir "total mujeres",mujer
total1<-sumatoria1/mujer
total2<-sumatoria2/hombre
total3<-...
menor1<-numero1
Sino
menor1<-menor1
FinSi
FinMientras
Escribir "El numero menor es ",menor1
Proceso EJERCICIO9
contador<-1...
FinSi
FinMientras
Escribir "El numero mayor es ",mayor1
FinProceso
Proceso EJERCICIO10
sumatoria<-0
contador<-0
cajadia<-1...
contador<-1
Mientras contador<=5 Hacer
Escribir "Digite el peso obtenido en la anterior reunion:"
Leer pesoanterior
lectur...
contador<-contador+1
FinMientras
FinProceso
Próxima SlideShare
Cargando en…5
×

Ejercicios mientras

65 visualizaciones

Publicado el

hjhg

Publicado en: Ingeniería
0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
65
En SlideShare
0
De insertados
0
Número de insertados
3
Acciones
Compartido
0
Descargas
0
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Ejercicios mientras

  1. 1. EJERCICIOS DEL MIENTRAS Proceso EJERCICIO 1 contado<-0 sueldobase<-100000 Escribir "digite el numero de vendedores" Leer vendedores Escribir "digite el valor total de las ventas" Leer ventas respuesta<-"s" Mientras contador<vendedores y respuesta="s" Hacer contador<-contador+1 comisiones<-ventas*0.1 total<-(comisiones+sueldobase) totalneto<-vendedores*total Escribir "total de cada uno de los vendedores es ",total Escribir "el total de todo es ",totalneto Escribir "desea continuar con otro calculo s/n?" Leer respuesta Fin Mientras Fin proceso Proceso EJERCICIO 2 contador<-0 respuesta<-"s" Escribir "digite el numero de obreros "
  2. 2. Leer obreros Mientras contador<obreros y respuesta="s" Hacer contador<-contador+1 Escribir "digite el numero de horas trabajadas" Leer horas Si horas<=40 Entonces salario1<-(horas*20) Escribir "el salario total es ",salario1 Sino salario2<-((horas-40)*25)+(horas*20) Escribir "el salario total es ",salario2 Fin Si Escribir " desea continuar con otro calculo s/n?" leer respuesta Fin Mientras FinProceso roceso EJERCICIO3 contador<-0 hombre<-0 mujer<-0 Escribir "digite el umero de personas" Leer numerop Mientras contador<numerop Hacer
  3. 3. contador<-contador+1 Escribir " digite su gener (hombre/mujer)" Leer genero Si genero="mujer" o genero="MUJER" o genero="Mujer" Entonces mujer<-mujer+1 Sino hombre<-hombre+1 Fin Si Fin Mientras Escribir "el total de hombre es ",hombre Escribir " el total de mujeres es",mujer FinProceso Proceso EJERCICIO4 contador<-0 Escribir "digite el numero de autos que ingresan" leer cantidad Mientras contador<cantidad Hacer contador<-contador+1 Escribir "ultimo digito de la placa" Leer digito Segun digito Hacer 1,2: Escribir "cantidad de autos con placa terminada en 1" Leer placas_1 Escribir "cantidad de autos con placa terminada en 2"
  4. 4. Leer placas_2 total_amarillo<-placas_1+placas_2 3,4: Escribir "cantidad de autos con placa terminada en 1" amarillo<-amarillo+1 5,6,5: Escribir "cantidad de autos con placa terminada en 1" rosa<-rosa+1 7,8: Escribir "cantidad de autos con placa terminada en 1" rosa<-rosa+1 9,0: Escribir "cantidad de autos con placa terminada en 1" rojo<-rojo+1 Fin Segun total<-amarillo+rosa+roja+verde+azul Fin Mientras Escribir "la cantidad de carros que ingresaron a ciudad de mexico son" Escribir "amarillos ",amarillo Escribir "rosa ",rosa Escribir "rojo ",rojo Escribir "verde ",verde Escribir "azul ",azul Escribir "total ",total
  5. 5. FinProceso Proceso EJERCICIO6 contador<-0 sumatoria<-0 Escribir " digite la cantidad de estudiantes" Leer cantidad Mientras contador<cantidad Hacer contador<-contador+1 Escribir "digite el promedio del estudiante",contador Leer nota1 sumatoria<-sumatoria+nota1 Fin Mientras promedio<-sumatoria/cantidad Escribir " el promedio general del curso",promedio FinProceso Proceso sin_titulo contador<-1 Escribir "digite el velor de la inversion" Leer inversion total_1<-(inversion*0.02)+inversion Mientras contador<12 Hacer contador<-contador+1 intereses<-total_1*0.02 total_1<-total_1+intereses
  6. 6. Fin Mientras Escribir "el total que recibira", total_1 FinProceso Proceso EJERCICIO7 contador<-0 sumatoria<-0 hombre<-0 mujer<-0 Escribir "digite la cantidad de alumnos" Leer cantidad Mientras contador<cantidad Hacer contador<-contador+1 Escribir "digite su edad" Leer edad Escribir "digite su genero" Leer genero Si genero="mujer" o genero="Mujer"o genero="MUJER" Entonces mujer<-mujer+1 sumatoria1<-sumatoria1+edad Sino hombre<-hombre+1 sumatoria2<-sumatoria2+edad Fin Si Fin Mientras
  7. 7. Escribir "total hombres",hombre Escribir "total mujeres",mujer total1<-sumatoria1/mujer total2<-sumatoria2/hombre total3<-sumatoria1+sumatoria2 total4<-total3/cantidad Escribir " la edad promedio de los mujeres es ",total1 Escribir "la edad promedio de las hombres es ",total2 Escribir "la edad promedio del grupo",total4 FinProceso Proceso EJERCICIO8 contador<-1 Escribir "Digite la cantidad de numeros:" Leer n Escribir "Digite un numero:" Leer numero1 Escribir "Numero ingresado: ",numero1 menor1<-numero1 Mientras contador<=n Hacer contador<-contador+1 Escribir "Digite un numero:" Leer numero1 Escribir "Numero ingresado: ",numero1 Si numero1<menor1 Entonces
  8. 8. menor1<-numero1 Sino menor1<-menor1 FinSi FinMientras Escribir "El numero menor es ",menor1 Proceso EJERCICIO9 contador<-1 Escribir "Digite la cantidad de numeros:" Leer n Escribir "Digite un numero:" Leer numero1 Escribir "Numero ingresado: ",numero1 mayor1<-numero1 Mientras contador<=n Hacer contador<-contador+1 Escribir "Digite un numero:" Leer numero1 Escribir "Numero ingresado: ",numero1 Si numero1>mayor1 Entonces mayor1<-numero1 Sino mayor1<-mayor1
  9. 9. FinSi FinMientras Escribir "El numero mayor es ",mayor1 FinProceso Proceso EJERCICIO10 sumatoria<-0 contador<-0 cajadia<-100000 Escribir "digite la cantidad de los aeticulos" Leer cantidad Mientras contador<cantidad Hacer contador<-contador+1 Escribir "digite el valor del articulo" Leer valor1 sumatoria<-sumatoria+valor1 cajadia<-cajadia+sumatoria Escribir "el valor del articulo es ",valor1 Escribir "el valor total a pagar es",sumatoria Escribir "total de articulos es ",contador Fin Mientras Escribir "el valor total a pagar es",sumatoria Escribir "total caja del dia",cajadia FinProceso Proceso EJERCICIO11
  10. 10. contador<-1 Mientras contador<=5 Hacer Escribir "Digite el peso obtenido en la anterior reunion:" Leer pesoanterior lecturapeso<-0 suma<-0 Repetir lecturapeso<-lecturapeso+1 Escribir "Digite la lectura de peso ",lecturapeso,":" Leer pesoac suma<-suma+pesoac Hasta Que lecturapeso=10 promedio<-suma/10 Si (pesoanterior-promedio)<0 Entonces Escribir "La persona SUBIO de peso" Escribir "La persona aumento ",(promedio-pesoanterior)," kilos" Sino Si (pesoanterior-promedio)>0 Entonces Escribir "La persona BAJO de peso" Escribir "La persona BAJO ",(pesoanterior-promedio)," kilos" Sino Escribir "La persona sigue IGUAL de peso" FinSi FinSi
  11. 11. contador<-contador+1 FinMientras FinProceso

×