SlideShare a Scribd company logo
1 of 10
Routing Information Protocol & RIP Configuration
Introduction to Routing Information Protocol (RIP)
IP RIP (Routing Information Protocol) comes in two different versions: 1 and 2. Version 1
is a distance vector protocol (RFC 1058) and Version 2 is a hybrid protocol (RFCs 1721
and 1722).
Routing Information Protocol Version 1 (RIPv1)
RIPv1 uses local broadcasts to share routing information. These updates are periodic in
nature, occurring, by default, every 30 seconds. To prevent packets from circling around
a loop forever, both versions of RIP solve counting to infinity by placing a hop count limit
of 15 hops on packets. Any packet that reaches the sixteenth hop will be dropped. RIPv1
is a classful protocol. RIP supports up to six equal-cost paths to a single destination.
Equal-cost path are the paths where the metric is same (Hop count).
Routing Information Protocol (RIPv2)
RIPv2 is a distance vector protocol with routing enhancements built into it, and it is based
on RIPV1. Therefore, it is commonly called a hybrid protocol.
RIPv2 uses multicasts instead of broadcasts. RIPv2 supports triggered updates. When a
change occurs, a RIPv2 router will immediately propagate its routing information to its
connected neighbors. RIPv2 is a classless protocol and it supports variable-length subnet
masking (VLSM).
Both RIPv1 and RIPv2 uses hop count as the metric.
Differences between RIPv1 and RIPv2
RIPv1
Supports only classful routing (Does not support VLSM).
• No authentication.
• RIPv1 uses Broadcast.
RIPv2
•Supports classless routing (Supports VLSM).
RIPv2 incorporates the addition of the network mask in the update to allow classless
routing advertisements.
• Authentication is available.
1
• RIPv2 uses multi-cast instead of broadcast. Multicast communication reduces the
burden on the network devices that do not need to listen to RIP updates.
Routing Information Protocol (RIP) Configuration
Routing Information Protocol (RIP) can be configured in a router using the following IOS
commands. The “version 2″ IOS command specifies that we are using RIPv2.
Router>enable
Router#configure terminal
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network network_id
Routing Information Protocol (RIP) – Lab Practice
The following diagram shows our lab setup. We have three routers, three switches and
three hosts connected as below. The host names, IP addresses and the interfaces of the
routers are shown in diagram. The IP addresses of the hosts are also shown in the
diagram.

Hostname and IP address configuration in Router01
2
Connect to Router01 console and use the following IOS commands to configure host
name as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration
mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use the following IOS commands to open the serial interface S0/0 configuration mode on
Router01 and configure IP addressas 172.17.0.1/16. You have to set a clock rate also
using the “clock rate” command on S0/0 interface, since this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect to Router02 console and use the following IOS commands to configure host
name as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
3
Router02(config)#
Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration
mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use the following IOS commands to open the serial interface S0/0 configuration mode on
Router02 and configure IP addressas 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use the following IOS commands to open the serial interface S0/1 configuration mode on
Router02 and configure IP addressas 172.19.0.1/16. You have to set a clock rate also
using the “clock rate” command on S0/1 interface, since this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect to Router03 console and use the following IOS commands to configure host
name as Router03.
Router>enable
4
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration
mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use the following IOS commands to open the serial interface S0/1 configuration mode on
Router03 and configure IP addressas 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in Router01
Connect to Router01 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router01. Please refer the beginning of this
lesson to view the Routing Information Protocol Version 2 (RIPv2) configuration IOS
commands.
Using the IOS “network” command, as shown below, we specify only the directly
connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#router rip
Router01(config-router)#version 2
5
Router01(config-router)#network 172.16.0.0
Router01(config-router)#network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in Router02
Connect to Router02 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router02. Please refer the beginning of this
lesson to view the Routing Information Protocol Version 2 (RIPv2) configurationIOS
commands.
Using the IOS “network” command, as shown below, we specify only the directly
connected networks of this router.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#router rip
Router02(config-router)#version 2
Router02(config-router)#network 172.17.0.0
Router02(config-router)#network 172.18.0.0
Router02(config-router)#network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in Router03
Connect to Router03 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router03. Please refer the beginning of this
lesson to view the Routing Information Protocol Version 2 (RIPv2) configurationIOS
commands.
Using the IOS “network” command, as shown below, we specify only the directly
connected networks of this router.
6
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#router rip
Router03(config-router)#version 2
Router03(config-router)#network 172.19.0.0
Router03(config-router)#network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#
Do remember to run the “copy running-config startup-config” command from enable
mode, if you want to save the changes you have made in the router.
How to View the Routing Table in Router01
After the network is converged after the initial configuration and Routing Information
Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the
routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0
The “R” character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows
that it is a directly connected network.
7
How to view the routing table in Router02
When the network is converged after the initial configuration and Routing Information
Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the
routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
R 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1
The “R” character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows
that it is a directly connected network.
How to View the Routing Table in Router03
When the network is converged after the initial configuration and Routing Information
Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the
routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
8
Gateway of last resort is not set
R 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
R 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
R 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The “R” character at the beginning of a line in routing table shows that it is a route
discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows
that it is a directly connected network.
Verify the Connectivity between Networks Using the Ping Command
To verify the Routing Information Protocol Version 2 (RIPv2) routes and the connectivity
between networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to
Host03 (IP address: 172.20.0.10/16).
C:>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms
The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Routing
Information Protocol Version 2 (RIPv2) is configured well in three routers and there is
network connectivity between different networks.
Reference from http://www.omnisecu.com/cisco-certified-network-associate-ccna/how-toconfigure-routing-information-protocol-rip.htm

9
3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale
original new Cisco networking equipments, including Cisco Catalyst switches, Cisco
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong

10

More Related Content

What's hot

What's hot (20)

RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
Routing information protocol
Routing information protocolRouting information protocol
Routing information protocol
 
Ripv2
Ripv2Ripv2
Ripv2
 
network convergence problem and solutions
network convergence  problem and solutionsnetwork convergence  problem and solutions
network convergence problem and solutions
 
Day 10 rip (2)
Day 10 rip (2)Day 10 rip (2)
Day 10 rip (2)
 
Rip protocol
Rip protocolRip protocol
Rip protocol
 
#RIPv1 vs #RIPv2
#RIPv1 vs #RIPv2#RIPv1 vs #RIPv2
#RIPv1 vs #RIPv2
 
RIP Overview
RIP OverviewRIP Overview
RIP Overview
 
RIP Loop Prevention
RIP Loop PreventionRIP Loop Prevention
RIP Loop Prevention
 
Routing Information Protocol (RIP)
Routing Information Protocol (RIP)Routing Information Protocol (RIP)
Routing Information Protocol (RIP)
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path First
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocol
 
IGRP and EIGRP
IGRP and EIGRPIGRP and EIGRP
IGRP and EIGRP
 
Ch13
Ch13Ch13
Ch13
 
Day 2 IP ROUTING
Day 2 IP ROUTINGDay 2 IP ROUTING
Day 2 IP ROUTING
 
RIPng
RIPngRIPng
RIPng
 
E routing final exam ccna 2 46
E routing final exam ccna 2 46E routing final exam ccna 2 46
E routing final exam ccna 2 46
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Examen final ccna2
Examen final ccna2Examen final ccna2
Examen final ccna2
 

Viewers also liked

Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information ProtocolMiftahul Khair N
 
Protocol data unit (pdu) a simulation
Protocol data unit (pdu) a simulationProtocol data unit (pdu) a simulation
Protocol data unit (pdu) a simulationAlexander Decker
 
Performance Analysis of Dynamic Routing Protocols using OPNET
Performance Analysis of Dynamic Routing Protocols using OPNETPerformance Analysis of Dynamic Routing Protocols using OPNET
Performance Analysis of Dynamic Routing Protocols using OPNETMuzahidul Islam
 
Networking Project(FINAL)
Networking Project(FINAL)Networking Project(FINAL)
Networking Project(FINAL)Priyojit Das
 
Creating a Simple, Accessible On/Off Switch
Creating a Simple, Accessible On/Off SwitchCreating a Simple, Accessible On/Off Switch
Creating a Simple, Accessible On/Off SwitchRuss Weakley
 
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)Abdelkhalik Mosa
 
Switch: How to Change Things When Change is Hard
Switch:  How to Change Things When Change is HardSwitch:  How to Change Things When Change is Hard
Switch: How to Change Things When Change is Hardslls01
 
CCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPCCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPVuz Dở Hơi
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRPDmitry Figol
 
Stitch, seam ppt
Stitch, seam pptStitch, seam ppt
Stitch, seam pptHaji Aman
 

Viewers also liked (18)

Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information Protocol
 
Protocol data unit (pdu) a simulation
Protocol data unit (pdu) a simulationProtocol data unit (pdu) a simulation
Protocol data unit (pdu) a simulation
 
Routing protocols
Routing protocolsRouting protocols
Routing protocols
 
Performance Analysis of Dynamic Routing Protocols using OPNET
Performance Analysis of Dynamic Routing Protocols using OPNETPerformance Analysis of Dynamic Routing Protocols using OPNET
Performance Analysis of Dynamic Routing Protocols using OPNET
 
ENRM 1001 newsletter, Group 9
ENRM 1001 newsletter, Group 9ENRM 1001 newsletter, Group 9
ENRM 1001 newsletter, Group 9
 
Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information Protocol
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
Ospf
 Ospf Ospf
Ospf
 
Networking Project(FINAL)
Networking Project(FINAL)Networking Project(FINAL)
Networking Project(FINAL)
 
Creating a Simple, Accessible On/Off Switch
Creating a Simple, Accessible On/Off SwitchCreating a Simple, Accessible On/Off Switch
Creating a Simple, Accessible On/Off Switch
 
Dynamic Routing RIP
Dynamic Routing RIPDynamic Routing RIP
Dynamic Routing RIP
 
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)
Routing Protocols and Concepts: Ch5 - Routing Information Protocol (RIP v1)
 
Switch: How to Change Things When Change is Hard
Switch:  How to Change Things When Change is HardSwitch:  How to Change Things When Change is Hard
Switch: How to Change Things When Change is Hard
 
CCNP Route EIGRP Overview
CCNP Route  EIGRP OverviewCCNP Route  EIGRP Overview
CCNP Route EIGRP Overview
 
CCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRPCCNAv5 - S3: Chapter 7 EIGRP
CCNAv5 - S3: Chapter 7 EIGRP
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRP
 
Stitch, seam ppt
Stitch, seam pptStitch, seam ppt
Stitch, seam ppt
 
PERFORMANCE EVALUATION OF RIP AND OSPF IN IPV6 USING OPNET 14.5 SIMULATOR
PERFORMANCE EVALUATION OF RIP AND OSPF IN IPV6 USING OPNET 14.5 SIMULATORPERFORMANCE EVALUATION OF RIP AND OSPF IN IPV6 USING OPNET 14.5 SIMULATOR
PERFORMANCE EVALUATION OF RIP AND OSPF IN IPV6 USING OPNET 14.5 SIMULATOR
 

Similar to Routing information protocol & rip configuration

How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)IT Tech
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config97148881557
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_configarjuntrk
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsEng. Emad Al-Atoum
 
Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5Garima Singh
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Netwax Lab
 
Acn Experiment No 6
Acn Experiment No 6Acn Experiment No 6
Acn Experiment No 6Garima Singh
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glanceVikas Raut
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 

Similar to Routing information protocol & rip configuration (20)

How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
Ccna command
Ccna commandCcna command
Ccna command
 
Cisco packet tracer ripv1
Cisco packet tracer   ripv1Cisco packet tracer   ripv1
Cisco packet tracer ripv1
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)
 
Acn Experiment No 6
Acn Experiment No 6Acn Experiment No 6
Acn Experiment No 6
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
1
11
1
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 

More from 3Anetwork com

Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers3Anetwork com
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series3Anetwork com
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches3Anetwork com
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business3Anetwork com
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router3Anetwork com
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs3Anetwork com
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program3Anetwork com
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration3Anetwork com
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity3Anetwork com
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet3Anetwork com
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview3Anetwork com
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick3Anetwork com
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet3Anetwork com
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x3Anetwork com
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers3Anetwork com
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules3Anetwork com
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example3Anetwork com
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality3Anetwork com
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)3Anetwork com
 

More from 3Anetwork com (20)

Cisco sfp modules
Cisco sfp modulesCisco sfp modules
Cisco sfp modules
 
Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)
 

Recently uploaded

Insurers' journeys to build a mastery in the IoT usage
Insurers' journeys to build a mastery in the IoT usageInsurers' journeys to build a mastery in the IoT usage
Insurers' journeys to build a mastery in the IoT usageMatteo Carbone
 
Dr. Admir Softic_ presentation_Green Club_ENG.pdf
Dr. Admir Softic_ presentation_Green Club_ENG.pdfDr. Admir Softic_ presentation_Green Club_ENG.pdf
Dr. Admir Softic_ presentation_Green Club_ENG.pdfAdmir Softic
 
Famous Olympic Siblings from the 21st Century
Famous Olympic Siblings from the 21st CenturyFamous Olympic Siblings from the 21st Century
Famous Olympic Siblings from the 21st Centuryrwgiffor
 
A DAY IN THE LIFE OF A SALESMAN / WOMAN
A DAY IN THE LIFE OF A  SALESMAN / WOMANA DAY IN THE LIFE OF A  SALESMAN / WOMAN
A DAY IN THE LIFE OF A SALESMAN / WOMANIlamathiKannappan
 
HONOR Veterans Event Keynote by Michael Hawkins
HONOR Veterans Event Keynote by Michael HawkinsHONOR Veterans Event Keynote by Michael Hawkins
HONOR Veterans Event Keynote by Michael HawkinsMichael W. Hawkins
 
The Coffee Bean & Tea Leaf(CBTL), Business strategy case study
The Coffee Bean & Tea Leaf(CBTL), Business strategy case studyThe Coffee Bean & Tea Leaf(CBTL), Business strategy case study
The Coffee Bean & Tea Leaf(CBTL), Business strategy case studyEthan lee
 
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...Dave Litwiller
 
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...Dipal Arora
 
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service Available
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service AvailableCall Girls Pune Just Call 9907093804 Top Class Call Girl Service Available
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service AvailableDipal Arora
 
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...Lviv Startup Club
 
Pharma Works Profile of Karan Communications
Pharma Works Profile of Karan CommunicationsPharma Works Profile of Karan Communications
Pharma Works Profile of Karan Communicationskarancommunications
 
Value Proposition canvas- Customer needs and pains
Value Proposition canvas- Customer needs and painsValue Proposition canvas- Customer needs and pains
Value Proposition canvas- Customer needs and painsP&CO
 
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...amitlee9823
 
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...amitlee9823
 
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...anilsa9823
 
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...rajveerescorts2022
 
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...lizamodels9
 
Monte Carlo simulation : Simulation using MCSM
Monte Carlo simulation : Simulation using MCSMMonte Carlo simulation : Simulation using MCSM
Monte Carlo simulation : Simulation using MCSMRavindra Nath Shukla
 

Recently uploaded (20)

Insurers' journeys to build a mastery in the IoT usage
Insurers' journeys to build a mastery in the IoT usageInsurers' journeys to build a mastery in the IoT usage
Insurers' journeys to build a mastery in the IoT usage
 
Dr. Admir Softic_ presentation_Green Club_ENG.pdf
Dr. Admir Softic_ presentation_Green Club_ENG.pdfDr. Admir Softic_ presentation_Green Club_ENG.pdf
Dr. Admir Softic_ presentation_Green Club_ENG.pdf
 
VVVIP Call Girls In Greater Kailash ➡️ Delhi ➡️ 9999965857 🚀 No Advance 24HRS...
VVVIP Call Girls In Greater Kailash ➡️ Delhi ➡️ 9999965857 🚀 No Advance 24HRS...VVVIP Call Girls In Greater Kailash ➡️ Delhi ➡️ 9999965857 🚀 No Advance 24HRS...
VVVIP Call Girls In Greater Kailash ➡️ Delhi ➡️ 9999965857 🚀 No Advance 24HRS...
 
Famous Olympic Siblings from the 21st Century
Famous Olympic Siblings from the 21st CenturyFamous Olympic Siblings from the 21st Century
Famous Olympic Siblings from the 21st Century
 
A DAY IN THE LIFE OF A SALESMAN / WOMAN
A DAY IN THE LIFE OF A  SALESMAN / WOMANA DAY IN THE LIFE OF A  SALESMAN / WOMAN
A DAY IN THE LIFE OF A SALESMAN / WOMAN
 
HONOR Veterans Event Keynote by Michael Hawkins
HONOR Veterans Event Keynote by Michael HawkinsHONOR Veterans Event Keynote by Michael Hawkins
HONOR Veterans Event Keynote by Michael Hawkins
 
The Coffee Bean & Tea Leaf(CBTL), Business strategy case study
The Coffee Bean & Tea Leaf(CBTL), Business strategy case studyThe Coffee Bean & Tea Leaf(CBTL), Business strategy case study
The Coffee Bean & Tea Leaf(CBTL), Business strategy case study
 
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...
Enhancing and Restoring Safety & Quality Cultures - Dave Litwiller - May 2024...
 
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...
Call Girls Navi Mumbai Just Call 9907093804 Top Class Call Girl Service Avail...
 
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service Available
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service AvailableCall Girls Pune Just Call 9907093804 Top Class Call Girl Service Available
Call Girls Pune Just Call 9907093804 Top Class Call Girl Service Available
 
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...
Yaroslav Rozhankivskyy: Три складові і три передумови максимальної продуктивн...
 
Pharma Works Profile of Karan Communications
Pharma Works Profile of Karan CommunicationsPharma Works Profile of Karan Communications
Pharma Works Profile of Karan Communications
 
Value Proposition canvas- Customer needs and pains
Value Proposition canvas- Customer needs and painsValue Proposition canvas- Customer needs and pains
Value Proposition canvas- Customer needs and pains
 
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...
Call Girls Jp Nagar Just Call 👗 7737669865 👗 Top Class Call Girl Service Bang...
 
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...
Call Girls Electronic City Just Call 👗 7737669865 👗 Top Class Call Girl Servi...
 
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...
Lucknow 💋 Escorts in Lucknow - 450+ Call Girl Cash Payment 8923113531 Neha Th...
 
unwanted pregnancy Kit [+918133066128] Abortion Pills IN Dubai UAE Abudhabi
unwanted pregnancy Kit [+918133066128] Abortion Pills IN Dubai UAE Abudhabiunwanted pregnancy Kit [+918133066128] Abortion Pills IN Dubai UAE Abudhabi
unwanted pregnancy Kit [+918133066128] Abortion Pills IN Dubai UAE Abudhabi
 
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...
👉Chandigarh Call Girls 👉9878799926👉Just Call👉Chandigarh Call Girl In Chandiga...
 
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...
Russian Call Girls In Gurgaon ❤️8448577510 ⊹Best Escorts Service In 24/7 Delh...
 
Monte Carlo simulation : Simulation using MCSM
Monte Carlo simulation : Simulation using MCSMMonte Carlo simulation : Simulation using MCSM
Monte Carlo simulation : Simulation using MCSM
 

Routing information protocol & rip configuration

  • 1. Routing Information Protocol & RIP Configuration Introduction to Routing Information Protocol (RIP) IP RIP (Routing Information Protocol) comes in two different versions: 1 and 2. Version 1 is a distance vector protocol (RFC 1058) and Version 2 is a hybrid protocol (RFCs 1721 and 1722). Routing Information Protocol Version 1 (RIPv1) RIPv1 uses local broadcasts to share routing information. These updates are periodic in nature, occurring, by default, every 30 seconds. To prevent packets from circling around a loop forever, both versions of RIP solve counting to infinity by placing a hop count limit of 15 hops on packets. Any packet that reaches the sixteenth hop will be dropped. RIPv1 is a classful protocol. RIP supports up to six equal-cost paths to a single destination. Equal-cost path are the paths where the metric is same (Hop count). Routing Information Protocol (RIPv2) RIPv2 is a distance vector protocol with routing enhancements built into it, and it is based on RIPV1. Therefore, it is commonly called a hybrid protocol. RIPv2 uses multicasts instead of broadcasts. RIPv2 supports triggered updates. When a change occurs, a RIPv2 router will immediately propagate its routing information to its connected neighbors. RIPv2 is a classless protocol and it supports variable-length subnet masking (VLSM). Both RIPv1 and RIPv2 uses hop count as the metric. Differences between RIPv1 and RIPv2 RIPv1 Supports only classful routing (Does not support VLSM). • No authentication. • RIPv1 uses Broadcast. RIPv2 •Supports classless routing (Supports VLSM). RIPv2 incorporates the addition of the network mask in the update to allow classless routing advertisements. • Authentication is available. 1
  • 2. • RIPv2 uses multi-cast instead of broadcast. Multicast communication reduces the burden on the network devices that do not need to listen to RIP updates. Routing Information Protocol (RIP) Configuration Routing Information Protocol (RIP) can be configured in a router using the following IOS commands. The “version 2″ IOS command specifies that we are using RIPv2. Router>enable Router#configure terminal Router(config)# router rip Router(config-router)# version 2 Router(config-router)# network network_id Routing Information Protocol (RIP) – Lab Practice The following diagram shows our lab setup. We have three routers, three switches and three hosts connected as below. The host names, IP addresses and the interfaces of the routers are shown in diagram. The IP addresses of the hosts are also shown in the diagram. Hostname and IP address configuration in Router01 2
  • 3. Connect to Router01 console and use the following IOS commands to configure host name as Router01. Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router01 Router01(config)# Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router01 and configure IP address as 172.16.0.1/16. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#interface fa0/0 Router01(config-if)#ip address 172.16.0.1 255.255.0.0 Router01(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/0 configuration mode on Router01 and configure IP addressas 172.17.0.1/16. You have to set a clock rate also using the “clock rate” command on S0/0 interface, since this is the DCE side. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#interface s0/0 Router01(config-if)#clock rate 64000 Router01(config-if)#ip address 172.17.0.1 255.255.0.0 Router01(config-if)#no shutdown Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. Hostname and IP address configuration in Router02 Connect to Router02 console and use the following IOS commands to configure host name as Router02. Router>enable Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router02 3
  • 4. Router02(config)# Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router02 and configure IP address as 172.18.0.1/16. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface fa0/0 Router02(config-if)#ip address 172.18.0.1 255.255.0.0 Router02(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/0 configuration mode on Router02 and configure IP addressas 172.17.0.2/16. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface s0/0 Router02(config-if)#ip address 172.17.0.2 255.255.0.0 Router02(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/1 configuration mode on Router02 and configure IP addressas 172.19.0.1/16. You have to set a clock rate also using the “clock rate” command on S0/1 interface, since this is the DCE side. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#interface s0/1 Router02(config-if)#clock rate 64000 Router02(config-if)#ip address 172.19.0.1 255.255.0.0 Router02(config-if)#no shutdown Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. Hostname and IP address configuration in Router03 Connect to Router03 console and use the following IOS commands to configure host name as Router03. Router>enable 4
  • 5. Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname Router03 Router03(config)# Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router03 and configure IP address as 172.20.0.1/16. Router03>enable Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#interface fa0/0 Router03(config-if)#ip address 172.20.0.1 255.255.0.0 Router03(config-if)#no shutdown Use the following IOS commands to open the serial interface S0/1 configuration mode on Router03 and configure IP addressas 172.19.0.2/16. Router03>enable Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#interface s0/1 Router03(config-if)#ip address 172.19.0.2 255.255.0.0 Router03(config-if)#no shutdown Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router01 Connect to Router01 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router01. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) configuration IOS commands. Using the IOS “network” command, as shown below, we specify only the directly connected networks of this router. Router01>enable Router01#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router01(config)#router rip Router01(config-router)#version 2 5
  • 6. Router01(config-router)#network 172.16.0.0 Router01(config-router)#network 172.17.0.0 Router01(config-router)#exit Router01(config)#exit Router01# Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router02 Connect to Router02 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router02. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) configurationIOS commands. Using the IOS “network” command, as shown below, we specify only the directly connected networks of this router. Router02>enable Router02#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router02(config)#router rip Router02(config-router)#version 2 Router02(config-router)#network 172.17.0.0 Router02(config-router)#network 172.18.0.0 Router02(config-router)#network 172.19.0.0 Router02(config-router)#exit Router02(config)#exit Router02# Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. Routing Information Protocol Version 2 (RIPv2) configuration in Router03 Connect to Router03 console and use the following IOS commands to configure Routing Information Protocol Version 2 (RIPv2) in Router03. Please refer the beginning of this lesson to view the Routing Information Protocol Version 2 (RIPv2) configurationIOS commands. Using the IOS “network” command, as shown below, we specify only the directly connected networks of this router. 6
  • 7. Router03>enable Router03#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Router03(config)#router rip Router03(config-router)#version 2 Router03(config-router)#network 172.19.0.0 Router03(config-router)#network 172.20.0.0 Router03(config-router)#exit Router03(config)#exit Router03# Do remember to run the “copy running-config startup-config” command from enable mode, if you want to save the changes you have made in the router. How to View the Routing Table in Router01 After the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the routing table in Router01, as shown below. Router01>enable Router01#show ip route Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area * – candidate default, U – per-user static route, o – ODR P – periodic downloaded static route Gateway of last resort is not set C 172.16.0.0/16 is directly connected, FastEthernet0/0 C 172.17.0.0/16 is directly connected, Serial0/0 R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0 R 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0 R 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0 The “R” character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows that it is a directly connected network. 7
  • 8. How to view the routing table in Router02 When the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the routing table in Router02, as shown below. Router02>enable Router02#show ip route Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area * – candidate default, U – per-user static route, o – ODR P – periodic downloaded static route Gateway of last resort is not set R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0 C 172.17.0.0/16 is directly connected, Serial0/0 C 172.18.0.0/16 is directly connected, FastEthernet0/0 C 172.19.0.0/16 is directly connected, Serial0/1 R 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1 The “R” character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows that it is a directly connected network. How to View the Routing Table in Router03 When the network is converged after the initial configuration and Routing Information Protocol Version 2 (RIPv2) configuration, we can use the “show ip route” to view the routing table in Router03, as shown below. Router03>enable Router03#show ip route Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2 E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area * – candidate default, U – per-user static route, o – ODR P – periodic downloaded static route 8
  • 9. Gateway of last resort is not set R 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1 R 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1 R 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1 C 172.19.0.0/16 is directly connected, Serial0/1 C 172.20.0.0/16 is directly connected, FastEthernet0/0 The “R” character at the beginning of a line in routing table shows that it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and “C” character shows that it is a directly connected network. Verify the Connectivity between Networks Using the Ping Command To verify the Routing Information Protocol Version 2 (RIPv2) routes and the connectivity between networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16). C:>ping 172.20.0.10 Pinging 172.20.0.10 with 32 bytes of data: Reply from 172.20.0.10: bytes=32 time=172ms TTL=125 Reply from 172.20.0.10: bytes=32 time=188ms TTL=125 Reply from 172.20.0.10: bytes=32 time=157ms TTL=125 Reply from 172.20.0.10: bytes=32 time=188ms TTL=125 Ping statistics for 172.20.0.10: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 157ms, Maximum = 188ms, Average = 176ms The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Routing Information Protocol Version 2 (RIPv2) is configured well in three routers and there is network connectivity between different networks. Reference from http://www.omnisecu.com/cisco-certified-network-associate-ccna/how-toconfigure-routing-information-protocol-rip.htm 9
  • 10. 3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale original new Cisco networking equipments, including Cisco Catalyst switches, Cisco routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 10