SlideShare una empresa de Scribd logo
1 de 10
Descargar para leer sin conexión
Eng. Mohammed Alani
                                                                    http://www.certificationist.com


 NAT (Network Address Translation) & PAT (Port Address Translation)




First let’s define NAT terms:
   •   Inside local address – The IP address assigned to a host on the inside network.
       The address is usually not an IP address assigned by the Internet Network
       Information Center (InterNIC) or service provider. This address is likely to be an
       RFC 1918 private address.
   •   Inside global address – A legitimate IP address assigned by the InterNIC or
       service provider that represents one or more inside local IP addresses to the
       outside world.
   •   Outside local address – The IP address of an outside host as it is known to the
       hosts on the inside network.
   •   Outside global address – The IP address assigned to a host on the outside
       network. The owner of the host assigns this address.




Now let’s remember the ranges of private addresses:
Eng. Mohammed Alani
                                                                      http://www.certificationist.com


NAT and PAT main features:
NAT translations can be used for a variety of purposes and can be either dynamically or
statically assigned. Static NAT is designed to allow one-to-one mapping of local and
global addresses. This is particularly useful for hosts which must have a consistent
address that is accessible from the Internet. These internal hosts may be enterprise servers
or networking devices.
Dynamic NAT is designed to map a private IP address to a public address. Any IP
address from a pool of public IP addresses is assigned to a network host. Overloading, or
Port Address Translation (PAT), maps multiple private IP addresses to a single public IP
address. Multiple addresses can be mapped to a single address because each private
address is tracked by a port number.
PAT uses unique source port numbers on the inside global IP address to distinguish
between translations. The port number is encoded in 16 bits. The total number of internal
addresses that can be translated to one external address could theoretically be as high as
65,536 per IP address. Realistically, the number of ports that can be assigned a single IP
address is around 4000. PAT will attempt to preserve the original source port. If this
source port is already used, PAT will assign the first available port number starting from
the beginning of the appropriate port group 0-511, 512-1023, or 1024-65535. When there
are no more ports available and there is more than one external IP address configured,
PAT moves to the next IP address to try to allocate the original source port again. This
process continues until it runs out of available ports and external IP addresses.
Note: Cisco IOS NAT does NOT support the following traffic types:
Routing table updates, DNS zone transfers, BOOTP, Talk and ntalk protocols, and
SNMP.
Eng. Mohammed Alani
                                                                  http://www.certificationist.com




Configuring NAT and PAT

Static Translation: configure a static NAT between the private IP 10.6.1.2 & the public
171.69.68.10
Configuration steps:
1. Establish static translation between an inside local add. & an inside global add.
Router(config)#ip nat inside source static <inside local add.> < inside global add.>
2. Specify the inside interface.
Eng. Mohammed Alani
                                                                      http://www.certificationist.com


Router(config)#int <type & no.>
Router(config-if)#ip nat inside
3. Specify the outside interface
Router(config)#int <type & no.>
Router(config-if)#ip nat outside

An example is the following:




Router(config)#ip nat inside source static 10.6.1.2 171.69.68.10
Router(config)#int e0
Router(config-if)#ip nat inside
Router(config-if)#int s0
Router(config-if)#ip nat outside

Dynamic Translation:
To configure dynamic inside source address translation an access list must permit only
those addresses that are to be translated. Remember that there is an implicit “deny all” at
the end of each access list. An access list that is too permissive can lead to unpredictable
results. Cisco advises against configuring access lists referenced by NAT commands with
the permit any command. Using permit any can result in NAT consuming too many
router resources, which can cause network problems.
Configuration steps:
   1. Define a pool of global addresses to be allocated as needed
      Router(config)#ip nat pool <name> <start-IP> <end-IP> netmask <netmask>
   2. Define the Access list
      Router(config)#access-list <number> permit <IPs> <wildcard>
   3. Establish dynamic source translation, specifying the access list defined in the
      prior step.
      Router(config)#ip nat inside sourse list <ACL number> pool <name>
   4. Specify the inside interface.
      Router(config)#int <type & no.>
      Router(config-if)#ip nat inside
   5. Specify the outside interface
      Router(config)#int <type & no.>
      Router(config-if)#ip nat outside
Eng. Mohammed Alani
                                                                    http://www.certificationist.com




Note: NAT will not translate any host that is not permitted for translation by the
access list.

Overloading:
Overloading is configured in two ways depending on how many public IP addresses have
been allocated. An ISP can allocate a network only one public IP address, and this is
typically assigned to the outside interface which connects to the ISP.
Configuration steps:
   1. Define a standard Access list
      Router(config)#access-list <number> permit <IPs> <wildcard>
   2. Establish dynamic source translation, specifying the access list defined in the
      prior step.
      Router(config)#ip nat inside sourse list <ACL number> interface <type & no>
                       overload
   3. Specify the inside interface.
      Router(config)#int <type & no.>
      Router(config-if)#ip nat inside
   4. Specify the outside interface
      Router(config)#int <type & no.>
      Router(config-if)#ip nat outside
Eng. Mohammed Alani
                                                               http://www.certificationist.com


Another way of configuring overload is if the ISP has given one or more public IP
addresses for use as a NAT pool. This pool can be overloaded.
   1. Define a standard Access list
      Router(config)#access-list <number> permit <IPs> <wildcard>
   2. Spacify the global address as a pool to be used for overloading.
      Router(config)#ip nat pool <name> <start-IP> <end-IP> netmask <netmask>
   3. Establish overload translation.
      Router(config)#ip nat inside sourse list <ACL number> pool <name> overload
   4. Specify the inside interface.
      Router(config)#int <type & no.>
      Router(config-if)#ip nat inside
   5. Specify the outside interface
      Router(config)#int <type & no.>
      Router(config-if)#ip nat outside




Troubleshooting NAT and PAT configuration:
   • Router#show ip nat translation
   • Router#show ip nat statistics
   • Router#show run
   • Router#debug ip nat
   • Router#debug ip nat detailed
Eng. Mohammed Alani
                                                                     http://www.certificationist.com




How to Change the Dynamic NAT Configuration:
Sometimes you receive these messages when you change the Network Address
Translation (NAT) configuration:
   •   Dynamic mapping in use, cannot remove
   •   %Pool out pool in use, cannot destroy
The following will demonstrate how to change the NAT configuration if you receive
these messages on the console.
Dynamic NAT creates active translation entries in a table when a packet crosses from an
IP NAT inside interface to an IP NAT outside interface, or vice versa. This dynamic
NAT entry can be seen using the show ip nat translation command. Cisco IOS®
software checks for any existing active NAT translations in the translations table when
either of the following existing dynamic NAT configurations is removed:
   •   no ip nat pool name
   •   no ip nat {inside | outside}source {list {access−list−number | name} pool name
       [overload] | static local−ip global−ip}


If a translation entry matches, then the %Dynamic Mapping in Use, Cannot remove
message or the %Pool out pool in use, cannot destroy message are respectively echoed on
the console.
The reason you receive these error messages is because you are trying to change part of a
NAT configuration that is responsible for creating dynamic translations that still exist in
the translation table. In order to change the NAT configuration in this situation, you need
to clear the table of translations that are being used before the change is accepted.
Eng. Mohammed Alani
                                                                        http://www.certificationist.com


Sometimes this is not easy because the router configured with NAT may be continuously
receiving packets that create translations in the table; this can happen so quickly that you
don't have time to change the configuration.
Using the clear ip nat translation Command:
This solution involves clearing the IP NAT translations using the clear ip nat
translation command, and then replacing the NAT configuration quickly, before any
new NAT entries are populated into the translation table due to active NAT traffic. To do
this, create a script with the configuration commands written in a text format. For
example:
Router#clear ip nat translation *
Router(config)#config terminal
Router(config)#no ip nat pool old pool name
Router(config)#ip nat pool new pool ……….
Once you have the script, cut and paste the script into the router enable mode (Router#).
Note: This may take more than one try since it is still possible that the router will create a
translation after the translation has been cleared.


Disabling NAT on the Router:
This solution involves disabling NAT on the router so that it cannot create any more
NAT translations. Do this by removing the ip nat inside or ip nat outside commands on
the interfaces. Then clear the translation table and change the configuration.
Follow these steps to use this solution:
   •   Use the no ip nat {inside | outside} command to disable future translations from
       taking place.
   •   Use the clear ip nat translation command to clear IP NAT translations.
   •   Change the NAT configuration.
   •   Restore the NAT {inside | outside} arguments with the ip nat {inside | outside}
       configuration command.
Eng. Mohammed Alani
                                                                   http://www.certificationist.com


                                     An Example




The ISP will give the company the public IP range (199.99.9.33…..39/27) for static
allocation. & the range (199.99.9.40……62/27) for dynamic allocation.
*Configure each router with basic configuration.
ISP(config)# ip route 199.99.9.32 255.255.255.224 200.2.2.18
ISP(config)#int loopback 1
ISP(config-if)#ip address 172.16.1.5 255.255.255.255
Gateway(config)# ip route 0.0.0.0 0.0.0.0 200.2.2.17
Gateway(config)#ip nat pool public_access 199.99.9.40 199.99.9.62 netmask
255.255.255.224 *S.M. could be 255.255.255.255 just as taken from ISP
Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255
Gateway(config)#ip nat inside source list 1 pool public_access overload [PAT]
Gateway(config)#int e0
Gateway(config-if)#ip nat inside
Gateway(config)#int s0
Gateway(config-if)#ip nat outside

From host A: ping 172.16.1.5 Reply
From host B: ping 172.16.1.5 Reply

Gateway#sh ip nat translation
Gateway#sh ip nat statistic
Gateway#sh run
Gateway#debug ip nat

For static NAT: Gateway(config)#ip nat inside source static 10.10.10.11 199.99.9.33

From ISP: ping 10.10.10.11 Request timed out
From ISP: ping 199.99.9.33 Reply
From ISP: ping 199.99.9.40 Request timed out
Eng. Mohammed Alani
                                                                       http://www.certificationist.com


Notes:
   1. Suppose you have only 1 public IP which is the address of interface S0:

   Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255
   Gateway(config)#ip nat inside source list 1 interface s0 overload
   Gateway(config)#int e0
   Gateway(config-if)#ip nat inside
   Gateway(config)#int s0
   Gateway(config-if)#ip nat outside

   2. Suppose that you have 1 registered IP (199.99.9.33) & you need to configure it
      with PAT:

       Gateway(config)#ip nat pool public_access 199.99.9.33 199.99.9.33 netmask
                       255.255.255.252
               *S.M. could be 255.255.255.255 just as taken from ISP
       Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255
       Gateway(config)#ip nat inside source list 1 pool public_access overload
       Gateway(config)#int e0
       Gateway(config-if)#ip nat inside
       Gateway(config)#int s0
       Gateway(config-if)#ip nat outside

Más contenido relacionado

La actualidad más candente

CCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan RoutingCCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan RoutingVuz Dở Hơi
 
VLAN Trunking Protocol
VLAN Trunking ProtocolVLAN Trunking Protocol
VLAN Trunking ProtocolNetwax Lab
 
Ccna ppt1
Ccna ppt1Ccna ppt1
Ccna ppt1AIRTEL
 
Access control list [1]
Access control list [1]Access control list [1]
Access control list [1]Summit Bisht
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPTAIRTEL
 
Introduction to router
Introduction to routerIntroduction to router
Introduction to routerFarhan Galib
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTNishant Goel
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorialIT Tech
 
Basics of IP Addressing
Basics of IP AddressingBasics of IP Addressing
Basics of IP AddressingKushal Sheth
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1VISHNU N
 
Routing Information Protocol (RIP)
Routing Information Protocol(RIP)Routing Information Protocol(RIP)
Routing Information Protocol (RIP)waqasahmad1995
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructurePrince Gautam
 
EtherChannel PAgP and LACP modes
EtherChannel PAgP and LACP modesEtherChannel PAgP and LACP modes
EtherChannel PAgP and LACP modesNetProtocol Xpert
 

La actualidad más candente (20)

CCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan RoutingCCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan Routing
 
Subnetting
SubnettingSubnetting
Subnetting
 
VLAN Trunking Protocol
VLAN Trunking ProtocolVLAN Trunking Protocol
VLAN Trunking Protocol
 
Ccna ppt1
Ccna ppt1Ccna ppt1
Ccna ppt1
 
Nat pat
Nat patNat pat
Nat pat
 
Access control list [1]
Access control list [1]Access control list [1]
Access control list [1]
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
Introduction to router
Introduction to routerIntroduction to router
Introduction to router
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPT
 
Eigrp.ppt
Eigrp.pptEigrp.ppt
Eigrp.ppt
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
 
Basics of IP Addressing
Basics of IP AddressingBasics of IP Addressing
Basics of IP Addressing
 
Ospf.ppt
Ospf.pptOspf.ppt
Ospf.ppt
 
Ospf
OspfOspf
Ospf
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1
 
Rip ospf and bgp
Rip ospf and bgpRip ospf and bgp
Rip ospf and bgp
 
Ipv4 ppt
Ipv4 pptIpv4 ppt
Ipv4 ppt
 
Routing Information Protocol (RIP)
Routing Information Protocol(RIP)Routing Information Protocol(RIP)
Routing Information Protocol (RIP)
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
EtherChannel PAgP and LACP modes
EtherChannel PAgP and LACP modesEtherChannel PAgP and LACP modes
EtherChannel PAgP and LACP modes
 

Destacado

Ccn unit-2- data link layer by prof.suresha v
Ccn unit-2- data link layer by prof.suresha vCcn unit-2- data link layer by prof.suresha v
Ccn unit-2- data link layer by prof.suresha vSURESHA V
 
Ccna 3 chapter 1 v4.0 answers 2011
Ccna 3 chapter 1 v4.0 answers 2011Ccna 3 chapter 1 v4.0 answers 2011
Ccna 3 chapter 1 v4.0 answers 2011Dân Chơi
 
CCNA ppt Day 7
CCNA ppt Day 7CCNA ppt Day 7
CCNA ppt Day 7VISHNU N
 
ppt on 6 weeks summer training
ppt on 6 weeks summer training ppt on 6 weeks summer training
ppt on 6 weeks summer training Pulkit Mahajan
 
Ccn unit1-Prof .suresha v
Ccn unit1-Prof .suresha vCcn unit1-Prof .suresha v
Ccn unit1-Prof .suresha vSURESHA V
 
What is Content centric networking
What is Content centric networkingWhat is Content centric networking
What is Content centric networkingpraison
 
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01Duane Bodle
 
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...thesakshi12
 
CCNA Security 010-configuring cisco asa
CCNA Security 010-configuring cisco asaCCNA Security 010-configuring cisco asa
CCNA Security 010-configuring cisco asaAhmed Habib
 
CCNA Security 07-Securing the local area network
CCNA Security 07-Securing the local area networkCCNA Security 07-Securing the local area network
CCNA Security 07-Securing the local area networkAhmed Habib
 
CCNA Security 05- securing the management plane
CCNA Security 05- securing the management planeCCNA Security 05- securing the management plane
CCNA Security 05- securing the management planeAhmed Habib
 
Network Security - Layer 2
Network Security - Layer 2Network Security - Layer 2
Network Security - Layer 2samis
 
ASA Firewall Interview- Questions & Answers
ASA Firewall Interview- Questions & AnswersASA Firewall Interview- Questions & Answers
ASA Firewall Interview- Questions & AnswersNetProtocol Xpert
 
Ccn unit1 for 7th SEM EC by Prof. suresha V
Ccn unit1 for 7th SEM EC by Prof. suresha VCcn unit1 for 7th SEM EC by Prof. suresha V
Ccn unit1 for 7th SEM EC by Prof. suresha VSURESHA V
 
CCNAv5 - S2: Chapter 9 Access Control Lists
CCNAv5 - S2: Chapter 9 Access Control ListsCCNAv5 - S2: Chapter 9 Access Control Lists
CCNAv5 - S2: Chapter 9 Access Control ListsVuz Dở Hơi
 

Destacado (20)

Ccn unit-2- data link layer by prof.suresha v
Ccn unit-2- data link layer by prof.suresha vCcn unit-2- data link layer by prof.suresha v
Ccn unit-2- data link layer by prof.suresha v
 
CCNA 2
CCNA 2 CCNA 2
CCNA 2
 
Ccna 3 chapter 1 v4.0 answers 2011
Ccna 3 chapter 1 v4.0 answers 2011Ccna 3 chapter 1 v4.0 answers 2011
Ccna 3 chapter 1 v4.0 answers 2011
 
CCNA ppt Day 7
CCNA ppt Day 7CCNA ppt Day 7
CCNA ppt Day 7
 
ppt on 6 weeks summer training
ppt on 6 weeks summer training ppt on 6 weeks summer training
ppt on 6 weeks summer training
 
Ccn unit1-Prof .suresha v
Ccn unit1-Prof .suresha vCcn unit1-Prof .suresha v
Ccn unit1-Prof .suresha v
 
CCNA part 7 acl
CCNA part 7 aclCCNA part 7 acl
CCNA part 7 acl
 
What is Content centric networking
What is Content centric networkingWhat is Content centric networking
What is Content centric networking
 
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01
Cisco ASA Firewall Interview Question "aka Stump-the-Chump" Question # 01
 
Chapter10ccna
Chapter10ccnaChapter10ccna
Chapter10ccna
 
ccna project
ccna projectccna project
ccna project
 
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
 
CCNA Security 010-configuring cisco asa
CCNA Security 010-configuring cisco asaCCNA Security 010-configuring cisco asa
CCNA Security 010-configuring cisco asa
 
CCNA Security 07-Securing the local area network
CCNA Security 07-Securing the local area networkCCNA Security 07-Securing the local area network
CCNA Security 07-Securing the local area network
 
CCNA Security 05- securing the management plane
CCNA Security 05- securing the management planeCCNA Security 05- securing the management plane
CCNA Security 05- securing the management plane
 
Network Security - Layer 2
Network Security - Layer 2Network Security - Layer 2
Network Security - Layer 2
 
ASA Firewall Interview- Questions & Answers
ASA Firewall Interview- Questions & AnswersASA Firewall Interview- Questions & Answers
ASA Firewall Interview- Questions & Answers
 
Ccn unit1 for 7th SEM EC by Prof. suresha V
Ccn unit1 for 7th SEM EC by Prof. suresha VCcn unit1 for 7th SEM EC by Prof. suresha V
Ccn unit1 for 7th SEM EC by Prof. suresha V
 
Cisco ASA Firewalls
Cisco ASA FirewallsCisco ASA Firewalls
Cisco ASA Firewalls
 
CCNAv5 - S2: Chapter 9 Access Control Lists
CCNAv5 - S2: Chapter 9 Access Control ListsCCNAv5 - S2: Chapter 9 Access Control Lists
CCNAv5 - S2: Chapter 9 Access Control Lists
 

Similar a NAT Ccna

NAT and PAT
NAT and PATNAT and PAT
NAT and PATMuuluu
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address TranslationEng. Emad Al-Atoum
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxGeorgeThoreJr
 
Packet Tracer: Nat protocol
Packet Tracer: Nat protocolPacket Tracer: Nat protocol
Packet Tracer: Nat protocolRafat Khandaker
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9Waqas Ahmed Nawaz
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
Basic ASA Configuration, NAT in ASA Firewall
Basic ASA Configuration,NAT in ASA FirewallBasic ASA Configuration,NAT in ASA Firewall
Basic ASA Configuration, NAT in ASA Firewall NetProtocol Xpert
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfBuntha Chhay
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity3Anetwork com
 
Network address translations
Network address translations Network address translations
Network address translations Shahzad shareef
 

Similar a NAT Ccna (20)

NAT and PAT
NAT and PATNAT and PAT
NAT and PAT
 
Nat 03
Nat 03Nat 03
Nat 03
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address Translation
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptx
 
Nat 07
Nat 07Nat 07
Nat 07
 
Day 17 nat and pat
Day 17 nat and patDay 17 nat and pat
Day 17 nat and pat
 
Packet Tracer: Nat protocol
Packet Tracer: Nat protocolPacket Tracer: Nat protocol
Packet Tracer: Nat protocol
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
 
Day 17.1 nat pat (2)
Day 17.1 nat pat  (2)Day 17.1 nat pat  (2)
Day 17.1 nat pat (2)
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Day 17.1 nat pat
Day 17.1 nat pat Day 17.1 nat pat
Day 17.1 nat pat
 
Nat cisco
Nat ciscoNat cisco
Nat cisco
 
Basic ASA Configuration, NAT in ASA Firewall
Basic ASA Configuration,NAT in ASA FirewallBasic ASA Configuration,NAT in ASA Firewall
Basic ASA Configuration, NAT in ASA Firewall
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdf
 
NAT_Final
NAT_FinalNAT_Final
NAT_Final
 
Nat
NatNat
Nat
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
Network address translations
Network address translations Network address translations
Network address translations
 

Último

social pharmacy d-pharm 1st year by Pragati K. Mahajan
social pharmacy d-pharm 1st year by Pragati K. Mahajansocial pharmacy d-pharm 1st year by Pragati K. Mahajan
social pharmacy d-pharm 1st year by Pragati K. Mahajanpragatimahajan3
 
Paris 2024 Olympic Geographies - an activity
Paris 2024 Olympic Geographies - an activityParis 2024 Olympic Geographies - an activity
Paris 2024 Olympic Geographies - an activityGeoBlogs
 
Sanyam Choudhary Chemistry practical.pdf
Sanyam Choudhary Chemistry practical.pdfSanyam Choudhary Chemistry practical.pdf
Sanyam Choudhary Chemistry practical.pdfsanyamsingh5019
 
Call Girls in Dwarka Mor Delhi Contact Us 9654467111
Call Girls in Dwarka Mor Delhi Contact Us 9654467111Call Girls in Dwarka Mor Delhi Contact Us 9654467111
Call Girls in Dwarka Mor Delhi Contact Us 9654467111Sapana Sha
 
Student login on Anyboli platform.helpin
Student login on Anyboli platform.helpinStudent login on Anyboli platform.helpin
Student login on Anyboli platform.helpinRaunakKeshri1
 
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in DelhiRussian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhikauryashika82
 
APM Welcome, APM North West Network Conference, Synergies Across Sectors
APM Welcome, APM North West Network Conference, Synergies Across SectorsAPM Welcome, APM North West Network Conference, Synergies Across Sectors
APM Welcome, APM North West Network Conference, Synergies Across SectorsAssociation for Project Management
 
The basics of sentences session 2pptx copy.pptx
The basics of sentences session 2pptx copy.pptxThe basics of sentences session 2pptx copy.pptx
The basics of sentences session 2pptx copy.pptxheathfieldcps1
 
The Most Excellent Way | 1 Corinthians 13
The Most Excellent Way | 1 Corinthians 13The Most Excellent Way | 1 Corinthians 13
The Most Excellent Way | 1 Corinthians 13Steve Thomason
 
Measures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and ModeMeasures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and ModeThiyagu K
 
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...Sapna Thakur
 
Web & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfWeb & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfJayanti Pande
 
9548086042 for call girls in Indira Nagar with room service
9548086042  for call girls in Indira Nagar  with room service9548086042  for call girls in Indira Nagar  with room service
9548086042 for call girls in Indira Nagar with room servicediscovermytutordmt
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdfQucHHunhnh
 
Arihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfArihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfchloefrazer622
 
Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104misteraugie
 
Introduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsIntroduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsTechSoup
 
Activity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdfActivity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdfciinovamais
 

Último (20)

social pharmacy d-pharm 1st year by Pragati K. Mahajan
social pharmacy d-pharm 1st year by Pragati K. Mahajansocial pharmacy d-pharm 1st year by Pragati K. Mahajan
social pharmacy d-pharm 1st year by Pragati K. Mahajan
 
Paris 2024 Olympic Geographies - an activity
Paris 2024 Olympic Geographies - an activityParis 2024 Olympic Geographies - an activity
Paris 2024 Olympic Geographies - an activity
 
Sanyam Choudhary Chemistry practical.pdf
Sanyam Choudhary Chemistry practical.pdfSanyam Choudhary Chemistry practical.pdf
Sanyam Choudhary Chemistry practical.pdf
 
Call Girls in Dwarka Mor Delhi Contact Us 9654467111
Call Girls in Dwarka Mor Delhi Contact Us 9654467111Call Girls in Dwarka Mor Delhi Contact Us 9654467111
Call Girls in Dwarka Mor Delhi Contact Us 9654467111
 
Student login on Anyboli platform.helpin
Student login on Anyboli platform.helpinStudent login on Anyboli platform.helpin
Student login on Anyboli platform.helpin
 
Advance Mobile Application Development class 07
Advance Mobile Application Development class 07Advance Mobile Application Development class 07
Advance Mobile Application Development class 07
 
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in DelhiRussian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
Russian Escort Service in Delhi 11k Hotel Foreigner Russian Call Girls in Delhi
 
Mattingly "AI & Prompt Design: Structured Data, Assistants, & RAG"
Mattingly "AI & Prompt Design: Structured Data, Assistants, & RAG"Mattingly "AI & Prompt Design: Structured Data, Assistants, & RAG"
Mattingly "AI & Prompt Design: Structured Data, Assistants, & RAG"
 
APM Welcome, APM North West Network Conference, Synergies Across Sectors
APM Welcome, APM North West Network Conference, Synergies Across SectorsAPM Welcome, APM North West Network Conference, Synergies Across Sectors
APM Welcome, APM North West Network Conference, Synergies Across Sectors
 
The basics of sentences session 2pptx copy.pptx
The basics of sentences session 2pptx copy.pptxThe basics of sentences session 2pptx copy.pptx
The basics of sentences session 2pptx copy.pptx
 
The Most Excellent Way | 1 Corinthians 13
The Most Excellent Way | 1 Corinthians 13The Most Excellent Way | 1 Corinthians 13
The Most Excellent Way | 1 Corinthians 13
 
Measures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and ModeMeasures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and Mode
 
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...
BAG TECHNIQUE Bag technique-a tool making use of public health bag through wh...
 
Web & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdfWeb & Social Media Analytics Previous Year Question Paper.pdf
Web & Social Media Analytics Previous Year Question Paper.pdf
 
9548086042 for call girls in Indira Nagar with room service
9548086042  for call girls in Indira Nagar  with room service9548086042  for call girls in Indira Nagar  with room service
9548086042 for call girls in Indira Nagar with room service
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdf
 
Arihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdfArihant handbook biology for class 11 .pdf
Arihant handbook biology for class 11 .pdf
 
Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104Nutritional Needs Presentation - HLTH 104
Nutritional Needs Presentation - HLTH 104
 
Introduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsIntroduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The Basics
 
Activity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdfActivity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdf
 

NAT Ccna

  • 1. Eng. Mohammed Alani http://www.certificationist.com NAT (Network Address Translation) & PAT (Port Address Translation) First let’s define NAT terms: • Inside local address – The IP address assigned to a host on the inside network. The address is usually not an IP address assigned by the Internet Network Information Center (InterNIC) or service provider. This address is likely to be an RFC 1918 private address. • Inside global address – A legitimate IP address assigned by the InterNIC or service provider that represents one or more inside local IP addresses to the outside world. • Outside local address – The IP address of an outside host as it is known to the hosts on the inside network. • Outside global address – The IP address assigned to a host on the outside network. The owner of the host assigns this address. Now let’s remember the ranges of private addresses:
  • 2. Eng. Mohammed Alani http://www.certificationist.com NAT and PAT main features: NAT translations can be used for a variety of purposes and can be either dynamically or statically assigned. Static NAT is designed to allow one-to-one mapping of local and global addresses. This is particularly useful for hosts which must have a consistent address that is accessible from the Internet. These internal hosts may be enterprise servers or networking devices. Dynamic NAT is designed to map a private IP address to a public address. Any IP address from a pool of public IP addresses is assigned to a network host. Overloading, or Port Address Translation (PAT), maps multiple private IP addresses to a single public IP address. Multiple addresses can be mapped to a single address because each private address is tracked by a port number. PAT uses unique source port numbers on the inside global IP address to distinguish between translations. The port number is encoded in 16 bits. The total number of internal addresses that can be translated to one external address could theoretically be as high as 65,536 per IP address. Realistically, the number of ports that can be assigned a single IP address is around 4000. PAT will attempt to preserve the original source port. If this source port is already used, PAT will assign the first available port number starting from the beginning of the appropriate port group 0-511, 512-1023, or 1024-65535. When there are no more ports available and there is more than one external IP address configured, PAT moves to the next IP address to try to allocate the original source port again. This process continues until it runs out of available ports and external IP addresses. Note: Cisco IOS NAT does NOT support the following traffic types: Routing table updates, DNS zone transfers, BOOTP, Talk and ntalk protocols, and SNMP.
  • 3. Eng. Mohammed Alani http://www.certificationist.com Configuring NAT and PAT Static Translation: configure a static NAT between the private IP 10.6.1.2 & the public 171.69.68.10 Configuration steps: 1. Establish static translation between an inside local add. & an inside global add. Router(config)#ip nat inside source static <inside local add.> < inside global add.> 2. Specify the inside interface.
  • 4. Eng. Mohammed Alani http://www.certificationist.com Router(config)#int <type & no.> Router(config-if)#ip nat inside 3. Specify the outside interface Router(config)#int <type & no.> Router(config-if)#ip nat outside An example is the following: Router(config)#ip nat inside source static 10.6.1.2 171.69.68.10 Router(config)#int e0 Router(config-if)#ip nat inside Router(config-if)#int s0 Router(config-if)#ip nat outside Dynamic Translation: To configure dynamic inside source address translation an access list must permit only those addresses that are to be translated. Remember that there is an implicit “deny all” at the end of each access list. An access list that is too permissive can lead to unpredictable results. Cisco advises against configuring access lists referenced by NAT commands with the permit any command. Using permit any can result in NAT consuming too many router resources, which can cause network problems. Configuration steps: 1. Define a pool of global addresses to be allocated as needed Router(config)#ip nat pool <name> <start-IP> <end-IP> netmask <netmask> 2. Define the Access list Router(config)#access-list <number> permit <IPs> <wildcard> 3. Establish dynamic source translation, specifying the access list defined in the prior step. Router(config)#ip nat inside sourse list <ACL number> pool <name> 4. Specify the inside interface. Router(config)#int <type & no.> Router(config-if)#ip nat inside 5. Specify the outside interface Router(config)#int <type & no.> Router(config-if)#ip nat outside
  • 5. Eng. Mohammed Alani http://www.certificationist.com Note: NAT will not translate any host that is not permitted for translation by the access list. Overloading: Overloading is configured in two ways depending on how many public IP addresses have been allocated. An ISP can allocate a network only one public IP address, and this is typically assigned to the outside interface which connects to the ISP. Configuration steps: 1. Define a standard Access list Router(config)#access-list <number> permit <IPs> <wildcard> 2. Establish dynamic source translation, specifying the access list defined in the prior step. Router(config)#ip nat inside sourse list <ACL number> interface <type & no> overload 3. Specify the inside interface. Router(config)#int <type & no.> Router(config-if)#ip nat inside 4. Specify the outside interface Router(config)#int <type & no.> Router(config-if)#ip nat outside
  • 6. Eng. Mohammed Alani http://www.certificationist.com Another way of configuring overload is if the ISP has given one or more public IP addresses for use as a NAT pool. This pool can be overloaded. 1. Define a standard Access list Router(config)#access-list <number> permit <IPs> <wildcard> 2. Spacify the global address as a pool to be used for overloading. Router(config)#ip nat pool <name> <start-IP> <end-IP> netmask <netmask> 3. Establish overload translation. Router(config)#ip nat inside sourse list <ACL number> pool <name> overload 4. Specify the inside interface. Router(config)#int <type & no.> Router(config-if)#ip nat inside 5. Specify the outside interface Router(config)#int <type & no.> Router(config-if)#ip nat outside Troubleshooting NAT and PAT configuration: • Router#show ip nat translation • Router#show ip nat statistics • Router#show run • Router#debug ip nat • Router#debug ip nat detailed
  • 7. Eng. Mohammed Alani http://www.certificationist.com How to Change the Dynamic NAT Configuration: Sometimes you receive these messages when you change the Network Address Translation (NAT) configuration: • Dynamic mapping in use, cannot remove • %Pool out pool in use, cannot destroy The following will demonstrate how to change the NAT configuration if you receive these messages on the console. Dynamic NAT creates active translation entries in a table when a packet crosses from an IP NAT inside interface to an IP NAT outside interface, or vice versa. This dynamic NAT entry can be seen using the show ip nat translation command. Cisco IOS® software checks for any existing active NAT translations in the translations table when either of the following existing dynamic NAT configurations is removed: • no ip nat pool name • no ip nat {inside | outside}source {list {access−list−number | name} pool name [overload] | static local−ip global−ip} If a translation entry matches, then the %Dynamic Mapping in Use, Cannot remove message or the %Pool out pool in use, cannot destroy message are respectively echoed on the console. The reason you receive these error messages is because you are trying to change part of a NAT configuration that is responsible for creating dynamic translations that still exist in the translation table. In order to change the NAT configuration in this situation, you need to clear the table of translations that are being used before the change is accepted.
  • 8. Eng. Mohammed Alani http://www.certificationist.com Sometimes this is not easy because the router configured with NAT may be continuously receiving packets that create translations in the table; this can happen so quickly that you don't have time to change the configuration. Using the clear ip nat translation Command: This solution involves clearing the IP NAT translations using the clear ip nat translation command, and then replacing the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. To do this, create a script with the configuration commands written in a text format. For example: Router#clear ip nat translation * Router(config)#config terminal Router(config)#no ip nat pool old pool name Router(config)#ip nat pool new pool ………. Once you have the script, cut and paste the script into the router enable mode (Router#). Note: This may take more than one try since it is still possible that the router will create a translation after the translation has been cleared. Disabling NAT on the Router: This solution involves disabling NAT on the router so that it cannot create any more NAT translations. Do this by removing the ip nat inside or ip nat outside commands on the interfaces. Then clear the translation table and change the configuration. Follow these steps to use this solution: • Use the no ip nat {inside | outside} command to disable future translations from taking place. • Use the clear ip nat translation command to clear IP NAT translations. • Change the NAT configuration. • Restore the NAT {inside | outside} arguments with the ip nat {inside | outside} configuration command.
  • 9. Eng. Mohammed Alani http://www.certificationist.com An Example The ISP will give the company the public IP range (199.99.9.33…..39/27) for static allocation. & the range (199.99.9.40……62/27) for dynamic allocation. *Configure each router with basic configuration. ISP(config)# ip route 199.99.9.32 255.255.255.224 200.2.2.18 ISP(config)#int loopback 1 ISP(config-if)#ip address 172.16.1.5 255.255.255.255 Gateway(config)# ip route 0.0.0.0 0.0.0.0 200.2.2.17 Gateway(config)#ip nat pool public_access 199.99.9.40 199.99.9.62 netmask 255.255.255.224 *S.M. could be 255.255.255.255 just as taken from ISP Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255 Gateway(config)#ip nat inside source list 1 pool public_access overload [PAT] Gateway(config)#int e0 Gateway(config-if)#ip nat inside Gateway(config)#int s0 Gateway(config-if)#ip nat outside From host A: ping 172.16.1.5 Reply From host B: ping 172.16.1.5 Reply Gateway#sh ip nat translation Gateway#sh ip nat statistic Gateway#sh run Gateway#debug ip nat For static NAT: Gateway(config)#ip nat inside source static 10.10.10.11 199.99.9.33 From ISP: ping 10.10.10.11 Request timed out From ISP: ping 199.99.9.33 Reply From ISP: ping 199.99.9.40 Request timed out
  • 10. Eng. Mohammed Alani http://www.certificationist.com Notes: 1. Suppose you have only 1 public IP which is the address of interface S0: Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255 Gateway(config)#ip nat inside source list 1 interface s0 overload Gateway(config)#int e0 Gateway(config-if)#ip nat inside Gateway(config)#int s0 Gateway(config-if)#ip nat outside 2. Suppose that you have 1 registered IP (199.99.9.33) & you need to configure it with PAT: Gateway(config)#ip nat pool public_access 199.99.9.33 199.99.9.33 netmask 255.255.255.252 *S.M. could be 255.255.255.255 just as taken from ISP Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255 Gateway(config)#ip nat inside source list 1 pool public_access overload Gateway(config)#int e0 Gateway(config-if)#ip nat inside Gateway(config)#int s0 Gateway(config-if)#ip nat outside