MARIA FERNANDA ORDEÑEZ BARRIOS <br />ANGIE PAOLA MURILO BORDA<br />GRADO<br />10²<br />NOMBRE<br />
DOCENTE<br />JOSE MANUEL HERNANDES<br />INTRODUCCION A LA INGENIERIA DE SISTEMAS<br />
<ul><li>Buscar el rey de copas en un mazo de naipes. Sólo puede mirar una carta por vez.
De una sola tirada de 5 dados, informar si se ha formado generala, tomando de a un dado por vez y comparando de a dos.
De un mazo de cartas españolas se desean formar cuatro pilas, una para cada palo, teniendo en cuenta que solo se puede mir...
Cambiar la rueda de un automóvil
Escribe un programa que calcule el área de un círculo de cualquier radio.
Escribe un programa que lea una cantidad depositada en un banco y que calcule la cantidad final después de aplicarle un 20...
Un maestro desea saber que porcentaje de hombres y que porcentaje de mujeres hay en un grupo de estudiantes.
Leer un libro.</li></ul>INDICE<br />
<ul><li>HAGA UN ALGORITMO QUE DADA UNA  VARIABLE   CUYO VALOR ES LEIDO  DESDE   TECLADO   IMPRIMA  POR PANTALLA  SI EL NUM...
HAGA UN ALGORITMO QUE DADA UNA  VARIABLE   CUYO VALOR ES LEIDO  DESDE   TECLADO   IMPRIMA  POR PANTALLA  SI EL NUMERO ES O...
HAGA  UN  ALGORITMO  QUE  TRAS  LEER  UN  CERACTER DESDE  TECLADO  QUE  IMPRIMA  POR  PANTALLA SI  LA  LETRA  ES  MINUSCUL...
Hacer un pseudocodigo que imprima los numeros del 1 al 100.
Hacer un aloritmoque imprima los numeros del 100 al 0, en orden decreciente.
Hacer un algorimoque imprima los numeros pares entre 0 y 100.
Hacer un programa que imprima la suma de los 100 primeros numeros.</li></ul> <br />
<ul><li>Algoritmo CARTAS
 Var
Próxima SlideShare
Cargando en…5
×

Presentacion mafe

578 visualizaciones

Publicado el

0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
578
En SlideShare
0
De insertados
0
Número de insertados
1
Acciones
Compartido
0
Descargas
1
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Presentacion mafe

  1. 1. MARIA FERNANDA ORDEÑEZ BARRIOS <br />ANGIE PAOLA MURILO BORDA<br />GRADO<br />10²<br />NOMBRE<br />
  2. 2. DOCENTE<br />JOSE MANUEL HERNANDES<br />INTRODUCCION A LA INGENIERIA DE SISTEMAS<br />
  3. 3. <ul><li>Buscar el rey de copas en un mazo de naipes. Sólo puede mirar una carta por vez.
  4. 4. De una sola tirada de 5 dados, informar si se ha formado generala, tomando de a un dado por vez y comparando de a dos.
  5. 5. De un mazo de cartas españolas se desean formar cuatro pilas, una para cada palo, teniendo en cuenta que solo se puede mirar de una carta por vez.
  6. 6. Cambiar la rueda de un automóvil
  7. 7. Escribe un programa que calcule el área de un círculo de cualquier radio.
  8. 8. Escribe un programa que lea una cantidad depositada en un banco y que calcule la cantidad final después de aplicarle un 20% de interés.
  9. 9. Un maestro desea saber que porcentaje de hombres y que porcentaje de mujeres hay en un grupo de estudiantes.
  10. 10. Leer un libro.</li></ul>INDICE<br />
  11. 11. <ul><li>HAGA UN ALGORITMO QUE DADA UNA VARIABLE CUYO VALOR ES LEIDO DESDE TECLADO IMPRIMA POR PANTALLA SI EL NUMERO ES O NO ES MAYOR QUE 0.
  12. 12. HAGA UN ALGORITMO QUE DADA UNA VARIABLE CUYO VALOR ES LEIDO DESDE TECLADO IMPRIMA POR PANTALLA SI EL NUMERO ES O NO ES MAYOR QUE 0. Y SI EL NUMERO ES PAR O ES IMPAR.
  13. 13. HAGA UN ALGORITMO QUE TRAS LEER UN CERACTER DESDE TECLADO QUE IMPRIMA POR PANTALLA SI LA LETRA ES MINUSCULA O MAYUSCULA. AMPLIE EL ALGORITMO INDICANDO SI EL CARÁCTER ES UN DIGITO NUMERICO
  14. 14. Hacer un pseudocodigo que imprima los numeros del 1 al 100.
  15. 15. Hacer un aloritmoque imprima los numeros del 100 al 0, en orden decreciente.
  16. 16. Hacer un algorimoque imprima los numeros pares entre 0 y 100.
  17. 17. Hacer un programa que imprima la suma de los 100 primeros numeros.</li></ul> <br />
  18. 18.
  19. 19. <ul><li>Algoritmo CARTAS
  20. 20. Var
  21. 21. tomar mazo de cartas
  22. 22. repetir
  23. 23. cambiar carta
  24. 24. hasta que encontrar rey de copas
  25. 25. fin </li></ul>Buscar el rey de copas en un mazo de naipes. Sólo puede mirar una carta por vez. <br />
  26. 26. De una sola tirada de 5 dados, informar si se ha formado generala, tomando de a un dado por vez y comparando de a dos. <br /><ul><li>Algoritmo GENERALA
  27. 27. var: A B C D E :entero
  28. 28. comienzo
  29. 29. leer A B
  30. 30. si (a=b) entonces
  31. 31. leer c
  32. 32. si (c=b) entonces
  33. 33. leer d
  34. 34. si (d=c) entonces
  35. 35. leer e
  36. 36. si (e=d) entonces
  37. 37. escribir GENERALA
  38. 38. sino
  39. 39. escribir NO GENERALA
  40. 40. Fin_si
  41. 41. fin </li></li></ul><li>De un mazo de cartas españolas se desean formar cuatro pilas, una para cada palo, teniendo en cuenta que solo se puede mirar de una carta por vez.<br /><ul><li>Algoritmo CARTAS
  42. 42. var: CARTA, P1, P2, P3, P4: entero P(PILA)
  43. 43. comienzo
  44. 44. leer CARTA
  45. 45. repetir
  46. 46. si CARTA=E entonces
  47. 47. carta en P1
  48. 48. si CARTA=B entonces
  49. 49. carta en P2
  50. 50. si CARTA=C entonces
  51. 51. carta en P3
  52. 52. sino
  53. 53. carta en p4
  54. 54. fin_si
  55. 55. hasta que (¿No mas cartas?)
  56. 56. fin </li></li></ul><li>Cambiar la rueda de un automóvil <br /><ul><li>4.sacar rueda
  57. 57. 5.colocar rueda nueva
  58. 58. 6.repetir
  59. 59. colocar herramienta sobre tuerca
  60. 60. ‘6.1 repetir
  61. 61. girar herramienta sentido horario
  62. 62. hasta que (tuerca ajustada)
  63. 63. hasta que (todas las tuercas ajustadas)
  64. 64. 7.repetir
  65. 65. accionar gato
  66. 66. Hasta que (auto llegue al piso)
  67. 67. fin
  68. 68. Algoritmo AUTOMOVIL
  69. 69. Var
  70. 70. situar gato en el lugar adecuado
  71. 71. repetir
  72. 72. accionar gato
  73. 73. hasta que (auto alcanza altura adecuada)
  74. 74. 3.repetir
  75. 75. colocar herramienta sobre tuerca
  76. 76. 3.2 repetir
  77. 77. girar herramienta en sentido anti horario
  78. 78. hasta que (tuerca floja)
  79. 79. hasta que (todas las tuercas sueltas </li></li></ul><li>Escribe un programa que calcule el área de un círculo de cualquier radio.<br /><ul><li>Algoritmo area_circulo
  80. 80. var
  81. 81. radio,area: real;
  82. 82. inicio
  83. 83. escriba ( “por favor ingrese el radio” );
  84. 84. lea ( radio );
  85. 85. area= pi * radio * radio
  86. 86. escriba ( “ el resultado es, ” ), area ;
  87. 87. fin</li></li></ul><li>Escribe un programa que lea una cantidad depositada en un banco y que calcule la cantidad final después de aplicarle un 20% de interés.<br /><ul><li>Algoritmo cantidad_depositada
  88. 88. var
  89. 89. dinero, v_final: real
  90. 90. inicio
  91. 91. escriba ( “ por favor ingrese la cantidad ”);
  92. 92. lea ( dinero );
  93. 93. vfinal= dinero * 20/100
  94. 94. escriba ( “ el valor final es, ” ), vfinal;
  95. 95. fin</li></li></ul><li>Un maestro desea saber que porcentaje de hombres y que porcentaje de mujeres hay en un grupo de estudiantes.<br /><ul><li>Algoritmo sexo_clase
  96. 96. var
  97. 97. h, m, k : entero
  98. 98. Genero: string ;
  99. 99. inicio ;
  100. 100. K = 0, M = 0 ; H = 0
  101. 101. si genero = ( “ hombre ” ) ;
  102. 102. K = K + 1 ;
  103. 103. H = K + 1 ;
  104. 104. si no
  105. 105. K = K + 1
  106. 106. M = M +1
  107. 107. fin si ;
  108. 108. escriba ( “ el total de hombres es ”) ; h;
  109. 109. escriba ( “ el total de mujeres es ”); M;
  110. 110. escriba ( “ el total de estudiantes”); k;
  111. 111. fin</li></li></ul><li><ul><li>algoritmo mayor que 0
  112. 112. var
  113. 113. entero: n
  114. 114. inicio
  115. 115. escribe (“escribe un numero”)
  116. 116. leer n
  117. 117. si (n > o) entonses
  118. 118. escribe (“ el numero es mayor que o”)
  119. 119. sino
  120. 120. escribe (“el numero es mayor que o”)
  121. 121. fin_si
  122. 122. fin</li></ul>HAGA UN ALGORITMO QUE DADA UNA VARIABLE CUYO VALOR ES LEIDO DESDE TECLADO IMPRIMA POR PANTALLA SI EL NUMERO ES O NO ES MAYOR QUE 0. <br />
  123. 123. <ul><li>algoritmo mayor que o par
  124. 124. var
  125. 125. entero n
  126. 126. inicio
  127. 127. escribe (“escribe un numero”)
  128. 128. leer n
  129. 129. si ( n > o ) entonses
  130. 130. escribe (“ el numero es mayor que o”)
  131. 131. sino
  132. 132. fin_si
  133. 133. si ( resto de (n2) = o ) entonses
  134. 134. escribe ( “ y esnumero par “)
  135. 135. sino
  136. 136. escribe (“ y esnumeroimpar”)
  137. 137. fin_si
  138. 138. fin</li></ul>HAGA UN ALGORITMO QUE DADA UNA VARIABLE CUYO VALOR ES LEIDO DESDE TECLADO IMPRIMA POR PANTALLA SI EL NUMERO ES O NO ES MAYOR QUE 0. Y SI EL NUMERO ES PAR O ES IMPAR<br />
  139. 139. HAGA UN ALGORITMO QUE TRAS LEER UN CERACTER DESDE TECLADO QUE IMPRIMA POR PANTALLA SI LA LETRA ES MINUSCULA O MAYUSCULA. AMPLIE EL ALGORITMO INDICANDO SI EL CARÁCTER ES UN DIGITO NUMERICO <br /><ul><li>ALGORITMO MINUSCULA MAYUSCULA
  140. 140. VAR
  141. 141. ENTERO CAR
  142. 142. INICIO
  143. 143. ESCRIBE (“ESCRIBE UNA LETRA”)
  144. 144. LEER CAR
  145. 145. SI (“CAR<=97) O (CER <= 122) ENTONSES</li></li></ul><li><ul><li>ALGORITMO:
  146. 146.  Borrar_pantalla( )
  147. 147. MIENTRAS c < 101 HACER
  148. 148.  ESCRIBIR c
  149. 149.  c <- c + 1
  150. 150.  FINMIENTRAS
  151. 151. fin</li></ul>Hacer un algoritmo que imprima los numeros del 1 al 100.<br />
  152. 152. <ul><li>algoritmo:
  153. 153. borrar_pantalla( )
  154. 154. mientras c <= 0 hacer
  155. 155. escribir c
  156. 156. c <- c - 1
  157. 157. finmientras
  158. 158. fin</li></ul>Hacer un pseudocodigo que imprima los numeros del 100 al 0, en ordendecreciente.<br />
  159. 159. <ul><li>ALGORITMO:
  160. 160.  Borrar_pantalla( )
  161. 161. MIENTRAS c < 101 HACER
  162. 162. ESCRIBIR c
  163. 163. c <- c + 2
  164. 164. FINMIENTRAS
  165. 165. FIN</li></ul>Hacer un algorimoqueimprima los numeros pares entre 0 y 100. <br />
  166. 166. <ul><li>ALGORITMO:
  167. 167.    Borrar_pantalla( )
  168. 168.    MIENTRAS c <= 100 HACER
  169. 169.       suma <- suma + c
  170. 170.       c <- c + 1
  171. 171.    FINMIENTRAS
  172. 172.    ESCRIBIR "La suma de los 100 primeros n£meros es: "
  173. 173.    ESCRIBIR suma
  174. 174. FINPROGRAMA</li></ul>Hacer un algoritmo que imprima la suma de los 100 primeros numeros.<br />
  175. 175. GRACIAS.<br />

×