Pontificia Universidad Católica de Valparaíso
                                         Facultad de Ingeniería
            ...
Pontificia Universidad Católica de Valparaíso
                                           Facultad de Ingeniería
          ...
Pontificia Universidad Católica de Valparaíso
                                         Facultad de Ingeniería
            ...
Próxima SlideShare
Cargando en…5
×

Pauta Control1

757 visualizaciones

Publicado el

0 comentarios
1 recomendación
Estadísticas
Notas
  • Sé el primero en comentar

Sin descargas
Visualizaciones
Visualizaciones totales
757
En SlideShare
0
De insertados
0
Número de insertados
2
Acciones
Compartido
0
Descargas
23
Comentarios
0
Recomendaciones
1
Insertados 0
No insertados

No hay notas en la diapositiva.

Pauta Control1

  1. 1. Pontificia Universidad Católica de Valparaíso Facultad de Ingeniería Escuela de Ingeniería Informática PAUTA Control Diagnostico – Informática 1 (INF 140) Asignatura: INF 140 - Informática 1 Primer Semestre - 2009 Semestre: Profesores: Pamela Hermosilla Monckton pamela.hermosilla@ucv.cl E-mail: Daniel Barraza Rodríguez dbarrazar@msn.com E-mail: Ayudante: Nombre: ______________________________________________ Fecha ___________________________ Parte 1: Identificar datos (20 pts) Instrucciones: Debe identificar correctamente los datos de entrada, salida y los tipos de datos. Corrigiendo si hay errores. Algoritmo info_1 Var entero: mayor, numerador, denominador, i INICIO i<-2 Escribir (quot;Ingrese el numeradorquot;) Leer (numerador) Escribir (quot;Ingrese el denominadorquot;) Leer (denominador) Si (numerador<=denominador) entonces Mayor<-denominador //Fin_si Este fin si no debería ir, ya que existe un si_no Si_no Mayor <-numerador //Fin_si_no El fin_si_no NO EXISTE Fin_si //falta un Fin_si Repetir Si (numerador mod i=0 ^ denominador mod i=0) entonces Numerador <- numerador/i Denominador<- denominador/i Fin_si// Este fin_si no debería ir ya que existe un si_no Si_no i<-i+1 Fin_si Hasta_que(i >mayor) Escribir (quot; quot;, numerador) Escribir (quot;/quot;) Escribir (quot; quot;, denominador) FIN Datos de entrada: Numerador, denominador. Datos de salida: Numerador y denominador simplificados al máximo. Tipos de datos: Todos los datos con valores enteros. Cada error da 1 pt. Identificación de los datos de entrada 4 Pts. Identificación de los datos de salida 4 Pts. Identificación de los datos de salida 3 Pts © Escuela de Ingeniería Informática - Pontificia Universidad Católica de Valparaíso
  2. 2. Pontificia Universidad Católica de Valparaíso Facultad de Ingeniería Escuela de Ingeniería Informática Parte 2: Desarrollo de algoritmos.(40 pts) Instrucciones Generales 1. Indicar cualquier suposición que exista en el desarrollo de los problemas. Recordar que estos supuestos no deben cambiar la orientación de ellos. 2. Responder en forma ordenada y con letra legible. Los desarrollos que no cumplan con esta condición no serán considerados en la corrección. 3. Los algoritmos deben implementarse en pseudolenguaje y de forma completa. 4. Además, se debe incluir la estrategia utilizada para enfrentar el desarrollo del problema (Análisis). Análisis: 5 puntos. Desarrollo del algoritmo: 15 puntos. 1. Los números de Fibonacci son una secuencia de números con múltiples usos (descripción de estructuras de plantas, muestras estadísticas, etc.). Originalmente, se idearon para modelar el crecimiento de una colonia de conejos. La secuencia es la siguiente: 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144... El tercer elemento de la secuencia es el resultado de la suma del primer y el segundo elemento. El cuarto elemento es la suma del segundo y el tercer elemento, etc. Se les a encomendado a los alumnos de Inf -140 que desarrollen un programa en pseudocódigo para calcular el enésimo termino. Desarrollo: Asumo que los valores que se ingresan en la variable numero son positivos y mayores que 0. Algoritmo Fibonacci Var entero: X, Y, suma, numero, i INICIO X<-1 Y<-1 Escribir (“Ingrese el nº de la sucesión que desea ver”) Leer (numero) Si (numero=1) entonces Escribir (“El numero de la sucesión es 1”) Si _no si(numero=2) entonces Escribir (“El numero de la sucesión es 1”) Si_no Desde (3<-1 hasta numero) hacer Suma<-X+Y X<-Y Y<-suma Fin_desde Escribir (“El numero de la sucesión es:”suma) Fin_si Fin_si FIN © Escuela de Ingeniería Informática - Pontificia Universidad Católica de Valparaíso
  3. 3. Pontificia Universidad Católica de Valparaíso Facultad de Ingeniería Escuela de Ingeniería Informática 2. Diseñar el algoritmo correspondiente a un programa que pida por teclado dos números enteros y muestre su suma, resta, multiplicación, división y el resto (módulo) de la división. Si la operación no es conmutativa, también se mostrará el resultado invirtiendo los operadores. Desarrollo: Asumo que ninguno de los 2 números es 0. Algoritmo calculos Var entero: num1, num2, suma, resta, división, multiplicación, modulo. INICIO Escribir (“Ingrese el nº1”) Leer (num1) Escribir (“Ingrese el nº2”) Leer (num2) Suma<-num1+num2 Multiplicación<-num1*num2 Si (num1 <> num2) entonces Escribir (“Los numero no son conmutativos”) Resta<-num1-num2 Escribir (“La resta numero 1 – numero 2 vale,”resta) Resta<-num2-num1 Escribir (“La resta numero 2 – numero 1 vale,”resta) División <-num1/num2 Escribir (“La división numero 1 / numero 2 vale,”división) División <-num2/num1 Escribir (“La división numero 2 / numero 1vale,”división) Modulo <-num1 MOD num2 Escribir (“El modulo entre numero 1 y numero 2 vale,”modulo) Modulo <-num2 MOD num1 Escribir (“El modulo entre numero 2 y numero 1 vale,”modulo) Si_no Resta<-num1-num2 Escribir (“La resta numero 1 – numero 2 vale,”resta) División <-num1/num2 Escribir (“La división numero 1 / numero 2 vale,”división) Modulo <-num1 MOD num2 Escribir (“El modulo entre numero 1 y numero 2 vale,”modulo) Fin_si Escribir (“La multiplicación entre numero 1 y numero 2 vale,”multiplicación) Escribir (“La suma entre numero 1 y numero 2 vale,”suma) FIN © Escuela de Ingeniería Informática - Pontificia Universidad Católica de Valparaíso

×