Pauta_Guia_1(1)
**************************************************
1)
Algoritmo Perimetro_de_circunferencia
cons     PI = ...
Pauta_Guia_1(1)
8)
Algoritmo Minimo_y_maximo
var      real: actual, minimo, maximo
inicio
         escribir( quot;Ingrese ...
Pauta_Guia_1(1)
                   prop_desc = 1
         sino
                   si( kilos_sem >= 4 ^ kilos_sem < 7 ) ent...
Pauta_Guia_1(1)
                             escribir( i, “ es divisor de “, num )
                   fin_si
        fin_d...
Pauta_Guia_1(1)
             hasta_que( mod_check <> 0 )
             cuenta_num <- cuenta_num + 1
             suma <- su...
Próxima SlideShare
Cargando en…5
×

Pauta Guia 1(1) Bloc De Notas

1.372 visualizaciones

Publicado el

Publicado en: Tecnología
0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
1.372
En SlideShare
0
De insertados
0
Número de insertados
3
Acciones
Compartido
0
Descargas
37
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Pauta Guia 1(1) Bloc De Notas

  1. 1. Pauta_Guia_1(1) ************************************************** 1) Algoritmo Perimetro_de_circunferencia cons PI = 3.141516 var real: radio, resultado inicio leer( radio ) resultado <- 2 * PI * radio escribir( quot;El perímetro de la circunferencia es: quot;, resultado ) fin ************************************************** 2) Algoritmo Perimetro_Area_de_circunferencia cons PI = 3.141516 var real: radio, perimetro, area inicio leer( radio ) perimetro <- 2 * PI * radio area <- PI * radio * radio escribir( quot;El perímetro de la circunferencia es: quot;, perimetro ) escribir( quot;El área de la circunferencia es: quot;, area ) fin ************************************************** 5) Algoritmo Resultado_funcion var real: x, resultado inicio leer( x ) resultado <- x * x + x - 5 escribir( quot;Resultado de la función: quot;, resultado ) si( resultado < 0 ) entonces Escribir( quot;El resultado obtenido es NEGATIVOquot; ) sino Escribir( quot;El resultado obtenido es POSITIVOquot; ) fin_si fin ************************************************** 6) Algoritmo Convertir_Celsius var real: celsius, resultado caracter: opcion inicio escribir( quot;Ingrese la temperatura en grados Celsiusquot; ) leer( celsius ) escribir( quot;Ingrese 'K' para convertir a grados Kelvin, u otro caracter para convertir a Fahrenheitquot; ) leer( opcion ) si( opcion <> 'K' ) entonces resultado <- celsius * 9/5 + 32 sino resultado <- celsius + 273.15 fin_si escribir( quot;El resultado de la conversión es: quot;, resultado ) fin ************************************************** Página 1
  2. 2. Pauta_Guia_1(1) 8) Algoritmo Minimo_y_maximo var real: actual, minimo, maximo inicio escribir( quot;Ingrese 1er valorquot; ) leer( actual ) minimo <- actual maximo <- actual escribir( quot;Ingrese 2do valorquot; ) leer( actual ) si( actual < minimo ) entonces minimo <- actual fin_si si( actual > maximo ) entonces maximo <- actual fin_si escribir( quot;Ingrese 3er valorquot; ) leer( actual ) si( actual < minimo ) entonces minimo <- actual fin_si si( actual > maximo ) entonces maximo <- actual fin_si escribir( quot;El valor mínimo ingresado es: quot;, minimo ) escribir( quot;El valor máximo ingresado es: quot;, máximo ) fin ************************************************** 9) Algoritmo Aplicar_IVA var real: mult_IVA entero: precio_base, precio_final caracter: tipo_prod inicio escribir( quot;Ingrese el tipo de productoquot; ) leer( tipo_prod ) escribir( quot;Ingrese el precio del productoquot; ) leer( precio_base ) mult_IVA <- 1.0 segun_sea tipo_prod hacer 'B': mult_IVA <- 1.15 'C': mult_IVA <- 1.12 fin_si precio_final <- precio_base * mult_IVA escribir( quot;El precio con IVA del producto es: quot;, precio_final ) fin ************************************************** 10) Algoritmo Oferta_panecillo cons precio_kilo = 1180 var entero: kilos_sem, precio_final real: prop_desc inicio escribir( quot;Ingrese la cantidad de kilos de pan comprados en la semanaquot; ) leer( kilos_sem ) kilos_sem <- kilos_sem + 1 si( kilos_sem < 4 ) entonces Página 2
  3. 3. Pauta_Guia_1(1) prop_desc = 1 sino si( kilos_sem >= 4 ^ kilos_sem < 7 ) entonces prop_desc = 0.95 sino si( kilos_sem >= 7 ^ kilos_sem < 10 ) entonces prop_desc = 0.9 sino si( kilos_sem >= 10 ^ kilos_sem < 14 ) entonces prop_desc = 0.85 sino si( kilos_sem >= 14 ) entonces prop_desc = 0.8 fin_si fin_si fin_si fin_si fin_si precio_final <- precio_kilo * prop_desc escribir( quot;El precio final de la compra es: quot;, precio_final ) fin ************************************************** 13) Algoritmo Asignar_valores_a_funcion var entero: x, res_func caracter: opcion inicio repetir escribir( “Ingrese un valor entre 1 y 15 para evaluar en la función: “ ) leer( x) si( x>= 1 ^ x<= 15 ) entonces res_func <- 2 * x * x – x + 10 si( ( res_func MOD 2 ) = 0 ) entonces escribir( “El resultado es “, res_func ) fin_si sino escribir( “El número ingresado debe estar entre 1 y 15” ) fin_si escribir( “Ingrese ‘s’ para evaluar otro número o ingrese otro carácter para salir: “ ) leer( opcion ) hasta_que( opcion <> ‘s’ ) fin ************************************************** 15) Algoritmo Divisores_numero var entero: num, i inicio escribir( “Ingrese el número cuyos divisores desea conocer: “ ) leer( num ) desde i <- 1 hasta num hacer si( ( num MOD i ) = 0 ) entonces Página 3
  4. 4. Pauta_Guia_1(1) escribir( i, “ es divisor de “, num ) fin_si fin_desde fin ************************************************** 18) Algoritmo Numeros_primos var entero: num, i, j logico: es_primo inicio repetir escribir( “Ingrese el límite superior (mayor que 1) de los números primos que desea conocer: “ ) leer( num ) si( num <= 1 ) entonces escribir( “El número ingresado debe ser mayor a 1” ) fin_si hasta_que( num > 1 ) i <- 2 mientras( i <= num ) hacer es_primo <- V j <- 2 mientras( j < i ^ es_primo ) hacer si( ( i MOD j ) = 0 ) entonces es_primo <- F fin_si j <- j + 1 fin_mientras si( es_primo ) escribir( i, “ es primo” ) fin_si i <- i + 1 fin_mientras fin ************************************************** 21) Algoritmo Sumas_parciales_1 var entero: num_actual, mod_check, suma, cuenta_num logico: detener inicio suma <- 0 cuenta_num <- 0 detener <- F repetir repetir escribir( “Ingrese próximo número a sumar: “ ) leer( num_actual ) mod_check = num_actual MOD 10 si( mod_check = 0 ) entonces escribir( “No debe ingresar números múltiplos de 10” ) fin_si Página 4
  5. 5. Pauta_Guia_1(1) hasta_que( mod_check <> 0 ) cuenta_num <- cuenta_num + 1 suma <- suma + num_actual mod_check = suma MOD 10 si( mod_check = 0 ) entonces detener <- V fin_si hasta_que( detener ) escribir( “La suma de los números ingresados es: “, suma ) escribir( “La cantidad de números ingresados es: “, cuenta_num ) fin Página 5

×