SlideShare una empresa de Scribd logo
1 de 6
Descargar para leer sin conexión
Anuj Kumar
                                            ciscobulls@gmail.com

             CCNP SWITCH
        PORTABLE STUDY GUIDE
                     &
         PRACTICE WORK BOOK


ANUJ KUMAR




             email:- ciscobulls@gmail.com
                anuj_dev007@yahoo.com
                  networkbulls.com
Anuj Kumar
                                                                                               ciscobulls@gmail.com

                                           REDUNDANCY PROTOCOLS

Cisco IOS offers feature to provide a redundant default gateway to end devices. The following are the default
gateway features supported by Cisco IOS and switches.

Hot Standby Routing Protocol (HSRP)
Virtual Router Redundancy Protocol (VRRP)
Gateway Load Balancing Protocol (GLBP)


                                       HSRP (Hot Standby Routing Protocol)

Feature:-
It is Cisco proprietary protocol.
It uses UDP Port no 1985
It sends hello message on multicast address 224.0.0.2
It sends out hello message every 3 sec (hold timer 10 sec)
Priority by default 100
It supports two types of authentication.
It supports tracking.

HSRP States: -
Active State: - in this active state, the router is send packets that are sent to virtual MAC and IP address of the
HSRP group. The active router also sends periodic hello message.

Standby: - in this state, the HSRP router is the next active router and it send periodic hello message. There must
be at least one standby router in the HSRP group.

Note: - A router does not hear any higher priority that router assume itself, so promote itself standby router.
A router does not hear an active router, so promote itself active router.
When the preempt option is not configure, the first router to initialize HSRP becomes the active router.

                           Configuration of HSRP on Switch
Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt

Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Anuj Kumar
                                                                                               ciscobulls@gmail.com


                                              Load Balancing of HSRP

While a router is actively forwarding traffic for one HSRP group, it can be in the standby or listen state for another
group.

Router A & Router B should be members of group 1 & Group 2.
Like as: -
     Router A:
            Active forwarding router for group 1
            Standby router for group 2.
     Router B:
            Active forwarding router for group 2
            Standby router for group 1.
Example:
Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt
Switch1(config)#interface vlan 20
Switch1(config-if)#ip address 192.168.102.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.102.1
Switch1(config-if)#standby priority 200
Switch1(config-if)#standby 1 preempt


Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Switch2(config)#interface vlan 20
Switch2(config-if)#ip address 192.168.102.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.102.1
Switch2(config-if)#standby priority 150
Switch2(config-if)#standby 1 preempt

Timers:-
    Both the hellotime and the holdtime parameters are configurable.
        Switch(config-if)#standby group-number timers hellotime holdtime
    Hellotime
            Default = 3 seconds
            Value varies from 1 to 255.
    Holdtime
            Default = 10 seconds
            Value varies from 1 to 255.
Anuj Kumar
                                                                                              ciscobulls@gmail.com

     To reinstate the default standby timer values, enter the following command:
      Switch(config-if)#no standby group-number timers

                                       Configuring HSRP Interface Tracking

The f0/0 interfaces on router A tracks the S0/0 interface. If the link between the S0/0 interface and Core fails, the
router automatically decrements its priority (10) on that interface and stops transmitting hello messages out
interface f0/0. Router B assumes the active router role when no hello messages are detected for the specific
holdtime period.

Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt
Switch1(config-if)#standby 1 track serial0/0(self interface name)

Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Switch2(config-if)#standby 1 track serial0/0 (self interface name)




                                                      Practical
Anuj Kumar
                                                             ciscobulls@gmail.com

Router(config)#host CORE
CORE(config)#int f0/0
CORE(config-if)#ip address 192.168.102.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)int s0/0
CORE(config-if)#ip address 10.1.1.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)#int s0/1
CORE(config-if)#ip address 11.1.1.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)#router ei 100
CORE(config-router)#network 192.168.102.0
CORE(config-router)#network 10.1.1.0 0.0.0.255
CORE(config-router)#network 11.1.1.0 0.0.0.255
CORE(config-router)#no auto-summary

SW1(config)#ho SW1
SW1(config)#int s0/0
SW1(config-if)#ip address 10.1.1.2 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)# int f0/0
SW1(config-if)# ip address 192.168.101.2 255.255.255.0
SW1(config-if)# no shutdown
SW1(config-if)# router eigrp 100
SW1(config-router)# network 192.168.101.0
SW1(config-router)# network 10.1.1.0 0.0.0.255
SW1(config-router)# no auto-summary
SW1(config-router)# exi
SW1(config)# int f0/0
SW1(config-if)# standby 1 ip 192.168.101.1
*Mar 1 00:23:07.895: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state
Standby -> Active
SW1(config-if)#standby 1 priority 150
SW1(config-if)#standby 1 preempt
SW1(config-if)#standby 1 track serial 0/0




SW2(config)#ho SW2
SW2(config)#int f0/0
SW2(config-if)#ip address 192.168.101.3 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#int s0/0
SW2(config-if)#ip address 11.1.1.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#router ei 100
SW2(config-router)#network 192.168.101.0
SW2(config-router)#network 11.1.1.0 0.0.0.255
SW2(config-router)#no auto-summary
Anuj Kumar
                                                              ciscobulls@gmail.com

SW2(config-router)#int f0/0
SW2(config-if)#standby 1 ip 192.168.101.1
SW2(config-if)#standby 1 priority 200
SW2(config-if)#standby 1 preempt
*Mar 1 00:34:31.431: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state
Standby -> Active
SW2(config-if)#standby 1 track serial 0/0


Verifying
SW1#sh standby
FastEthernet0/0 - Group 1
  State is Standby
    4 state changes, last state change 00:43:18
  Virtual IP address is 192.168.101.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.000 secs
  Preemption enabled
  Active router is 192.168.101.3, priority 190 (expires in 6.912 sec)
  Standby router is local
  Priority 150 (configured 150)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)
SW2#sh standby
FastEthernet0/0 - Group 1
  State is Active
    2 state changes, last state change 00:44:28
  Virtual IP address is 192.168.101.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.296 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.101.2, priority 150 (expires in 8.436 sec)
  Priority 190 (configured 200)
    Track interface Serial0/0 state Down decrement 10
  Group name is "hsrp-Fa0/0-1" (default)
Thank you for giving me your precious time.
Anuj Kumar

Más contenido relacionado

La actualidad más candente

Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network securityThanawan Tuamyim
 
The bryant advantage 150 commands
The bryant advantage 150 commandsThe bryant advantage 150 commands
The bryant advantage 150 commandsAreej Khasawneh
 
Juniper JNCIA – Juniper Floating Static Route Configuration
Juniper JNCIA – Juniper Floating Static Route ConfigurationJuniper JNCIA – Juniper Floating Static Route Configuration
Juniper JNCIA – Juniper Floating Static Route ConfigurationHamed Moghaddam
 
CCNP Lab Guide CCIE University
CCNP Lab Guide CCIE UniversityCCNP Lab Guide CCIE University
CCNP Lab Guide CCIE UniversitySalachudin Emir
 
Ccnp3 lab 3_5_en (hacer)
Ccnp3 lab 3_5_en (hacer)Ccnp3 lab 3_5_en (hacer)
Ccnp3 lab 3_5_en (hacer)Omar Herrera
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands OverviewMuhammed Niyas
 
Juniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationJuniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationHamed Moghaddam
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configurationHamed Moghaddam
 

La actualidad más candente (19)

Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
 
The bryant advantage 150 commands
The bryant advantage 150 commandsThe bryant advantage 150 commands
The bryant advantage 150 commands
 
Juniper JNCIA – Juniper Floating Static Route Configuration
Juniper JNCIA – Juniper Floating Static Route ConfigurationJuniper JNCIA – Juniper Floating Static Route Configuration
Juniper JNCIA – Juniper Floating Static Route Configuration
 
Router commands
Router commandsRouter commands
Router commands
 
Cisco CCNA- DHCP Server
Cisco CCNA-  DHCP ServerCisco CCNA-  DHCP Server
Cisco CCNA- DHCP Server
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
CCNP Lab Guide CCIE University
CCNP Lab Guide CCIE UniversityCCNP Lab Guide CCIE University
CCNP Lab Guide CCIE University
 
Ccnp3 lab 3_5_en (hacer)
Ccnp3 lab 3_5_en (hacer)Ccnp3 lab 3_5_en (hacer)
Ccnp3 lab 3_5_en (hacer)
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
 
Juniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationJuniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route Configuration
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
1cospf
1cospf1cospf
1cospf
 
Practice Lab CSC
Practice Lab CSCPractice Lab CSC
Practice Lab CSC
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configuration
 

Similar a Hsrp

cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2MAFANTIRI SELLO
 
Hot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) usingHot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) usingShubhiGupta94
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsEng. Emad Al-Atoum
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRPKishore Kumar
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 MinutesCCNAResources
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame RelayTharindu Sankalpa
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentAngel Clavel
 
Packet Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPPacket Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPRafat Khandaker
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
Aula04 - configuração da topologia ppp - resolvido
Aula04 -  configuração da topologia ppp - resolvidoAula04 -  configuração da topologia ppp - resolvido
Aula04 - configuração da topologia ppp - resolvidoCarlos Veiga
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config97148881557
 

Similar a Hsrp (20)

cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Labmannual
LabmannualLabmannual
Labmannual
 
Hot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) usingHot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) using
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commands   Ccna commands
Ccna commands
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
 
Packet Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPPacket Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRP
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Aula04 - configuração da topologia ppp - resolvido
Aula04 -  configuração da topologia ppp - resolvidoAula04 -  configuração da topologia ppp - resolvido
Aula04 - configuração da topologia ppp - resolvido
 
1
11
1
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 

Más de Anuj Kumar

Más de Anuj Kumar (6)

Osi model
Osi modelOsi model
Osi model
 
VLAN
VLANVLAN
VLAN
 
Private vlan
Private vlanPrivate vlan
Private vlan
 
Port aggregation
Port aggregationPort aggregation
Port aggregation
 
Port aggregation
Port aggregationPort aggregation
Port aggregation
 
Hsrp
HsrpHsrp
Hsrp
 

Último

Fostering Friendships - Enhancing Social Bonds in the Classroom
Fostering Friendships - Enhancing Social Bonds  in the ClassroomFostering Friendships - Enhancing Social Bonds  in the Classroom
Fostering Friendships - Enhancing Social Bonds in the ClassroomPooky Knightsmith
 
Key note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdfKey note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdfAdmir Softic
 
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptxMaritesTamaniVerdade
 
Introduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsIntroduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsTechSoup
 
FSB Advising Checklist - Orientation 2024
FSB Advising Checklist - Orientation 2024FSB Advising Checklist - Orientation 2024
FSB Advising Checklist - Orientation 2024Elizabeth Walsh
 
ICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptxICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptxAreebaZafar22
 
Dyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptxDyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptxcallscotland1987
 
Single or Multiple melodic lines structure
Single or Multiple melodic lines structureSingle or Multiple melodic lines structure
Single or Multiple melodic lines structuredhanjurrannsibayan2
 
This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.christianmathematics
 
Mixin Classes in Odoo 17 How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17  How to Extend Models Using Mixin ClassesMixin Classes in Odoo 17  How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17 How to Extend Models Using Mixin ClassesCeline George
 
General Principles of Intellectual Property: Concepts of Intellectual Proper...
General Principles of Intellectual Property: Concepts of Intellectual  Proper...General Principles of Intellectual Property: Concepts of Intellectual  Proper...
General Principles of Intellectual Property: Concepts of Intellectual Proper...Poonam Aher Patil
 
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfUGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfNirmal Dwivedi
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdfQucHHunhnh
 
SOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning PresentationSOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning Presentationcamerronhm
 
Understanding Accommodations and Modifications
Understanding  Accommodations and ModificationsUnderstanding  Accommodations and Modifications
Understanding Accommodations and ModificationsMJDuyan
 
How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17Celine George
 
Unit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptxUnit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptxVishalSingh1417
 
ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701bronxfugly43
 
Holdier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfHoldier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfagholdier
 

Último (20)

Fostering Friendships - Enhancing Social Bonds in the Classroom
Fostering Friendships - Enhancing Social Bonds  in the ClassroomFostering Friendships - Enhancing Social Bonds  in the Classroom
Fostering Friendships - Enhancing Social Bonds in the Classroom
 
Key note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdfKey note speaker Neum_Admir Softic_ENG.pdf
Key note speaker Neum_Admir Softic_ENG.pdf
 
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
2024-NATIONAL-LEARNING-CAMP-AND-OTHER.pptx
 
Introduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsIntroduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The Basics
 
FSB Advising Checklist - Orientation 2024
FSB Advising Checklist - Orientation 2024FSB Advising Checklist - Orientation 2024
FSB Advising Checklist - Orientation 2024
 
ICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptxICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptx
 
Dyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptxDyslexia AI Workshop for Slideshare.pptx
Dyslexia AI Workshop for Slideshare.pptx
 
Single or Multiple melodic lines structure
Single or Multiple melodic lines structureSingle or Multiple melodic lines structure
Single or Multiple melodic lines structure
 
This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.This PowerPoint helps students to consider the concept of infinity.
This PowerPoint helps students to consider the concept of infinity.
 
Spatium Project Simulation student brief
Spatium Project Simulation student briefSpatium Project Simulation student brief
Spatium Project Simulation student brief
 
Mixin Classes in Odoo 17 How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17  How to Extend Models Using Mixin ClassesMixin Classes in Odoo 17  How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17 How to Extend Models Using Mixin Classes
 
General Principles of Intellectual Property: Concepts of Intellectual Proper...
General Principles of Intellectual Property: Concepts of Intellectual  Proper...General Principles of Intellectual Property: Concepts of Intellectual  Proper...
General Principles of Intellectual Property: Concepts of Intellectual Proper...
 
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdfUGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
UGC NET Paper 1 Mathematical Reasoning & Aptitude.pdf
 
1029 - Danh muc Sach Giao Khoa 10 . pdf
1029 -  Danh muc Sach Giao Khoa 10 . pdf1029 -  Danh muc Sach Giao Khoa 10 . pdf
1029 - Danh muc Sach Giao Khoa 10 . pdf
 
SOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning PresentationSOC 101 Demonstration of Learning Presentation
SOC 101 Demonstration of Learning Presentation
 
Understanding Accommodations and Modifications
Understanding  Accommodations and ModificationsUnderstanding  Accommodations and Modifications
Understanding Accommodations and Modifications
 
How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17How to Create and Manage Wizard in Odoo 17
How to Create and Manage Wizard in Odoo 17
 
Unit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptxUnit-IV; Professional Sales Representative (PSR).pptx
Unit-IV; Professional Sales Representative (PSR).pptx
 
ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701
 
Holdier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdfHoldier Curriculum Vitae (April 2024).pdf
Holdier Curriculum Vitae (April 2024).pdf
 

Hsrp

  • 1. Anuj Kumar ciscobulls@gmail.com CCNP SWITCH PORTABLE STUDY GUIDE & PRACTICE WORK BOOK ANUJ KUMAR email:- ciscobulls@gmail.com anuj_dev007@yahoo.com networkbulls.com
  • 2. Anuj Kumar ciscobulls@gmail.com REDUNDANCY PROTOCOLS Cisco IOS offers feature to provide a redundant default gateway to end devices. The following are the default gateway features supported by Cisco IOS and switches. Hot Standby Routing Protocol (HSRP) Virtual Router Redundancy Protocol (VRRP) Gateway Load Balancing Protocol (GLBP) HSRP (Hot Standby Routing Protocol) Feature:- It is Cisco proprietary protocol. It uses UDP Port no 1985 It sends hello message on multicast address 224.0.0.2 It sends out hello message every 3 sec (hold timer 10 sec) Priority by default 100 It supports two types of authentication. It supports tracking. HSRP States: - Active State: - in this active state, the router is send packets that are sent to virtual MAC and IP address of the HSRP group. The active router also sends periodic hello message. Standby: - in this state, the HSRP router is the next active router and it send periodic hello message. There must be at least one standby router in the HSRP group. Note: - A router does not hear any higher priority that router assume itself, so promote itself standby router. A router does not hear an active router, so promote itself active router. When the preempt option is not configure, the first router to initialize HSRP becomes the active router. Configuration of HSRP on Switch Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt
  • 3. Anuj Kumar ciscobulls@gmail.com Load Balancing of HSRP While a router is actively forwarding traffic for one HSRP group, it can be in the standby or listen state for another group. Router A & Router B should be members of group 1 & Group 2. Like as: -  Router A:  Active forwarding router for group 1  Standby router for group 2.  Router B:  Active forwarding router for group 2  Standby router for group 1. Example: Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch1(config)#interface vlan 20 Switch1(config-if)#ip address 192.168.102.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.102.1 Switch1(config-if)#standby priority 200 Switch1(config-if)#standby 1 preempt Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt Switch2(config)#interface vlan 20 Switch2(config-if)#ip address 192.168.102.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.102.1 Switch2(config-if)#standby priority 150 Switch2(config-if)#standby 1 preempt Timers:-  Both the hellotime and the holdtime parameters are configurable. Switch(config-if)#standby group-number timers hellotime holdtime  Hellotime  Default = 3 seconds  Value varies from 1 to 255.  Holdtime  Default = 10 seconds  Value varies from 1 to 255.
  • 4. Anuj Kumar ciscobulls@gmail.com  To reinstate the default standby timer values, enter the following command: Switch(config-if)#no standby group-number timers Configuring HSRP Interface Tracking The f0/0 interfaces on router A tracks the S0/0 interface. If the link between the S0/0 interface and Core fails, the router automatically decrements its priority (10) on that interface and stops transmitting hello messages out interface f0/0. Router B assumes the active router role when no hello messages are detected for the specific holdtime period. Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch1(config-if)#standby 1 track serial0/0(self interface name) Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt Switch2(config-if)#standby 1 track serial0/0 (self interface name) Practical
  • 5. Anuj Kumar ciscobulls@gmail.com Router(config)#host CORE CORE(config)#int f0/0 CORE(config-if)#ip address 192.168.102.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)int s0/0 CORE(config-if)#ip address 10.1.1.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)#int s0/1 CORE(config-if)#ip address 11.1.1.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)#router ei 100 CORE(config-router)#network 192.168.102.0 CORE(config-router)#network 10.1.1.0 0.0.0.255 CORE(config-router)#network 11.1.1.0 0.0.0.255 CORE(config-router)#no auto-summary SW1(config)#ho SW1 SW1(config)#int s0/0 SW1(config-if)#ip address 10.1.1.2 255.255.255.0 SW1(config-if)#no shutdown SW1(config-if)# int f0/0 SW1(config-if)# ip address 192.168.101.2 255.255.255.0 SW1(config-if)# no shutdown SW1(config-if)# router eigrp 100 SW1(config-router)# network 192.168.101.0 SW1(config-router)# network 10.1.1.0 0.0.0.255 SW1(config-router)# no auto-summary SW1(config-router)# exi SW1(config)# int f0/0 SW1(config-if)# standby 1 ip 192.168.101.1 *Mar 1 00:23:07.895: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active SW1(config-if)#standby 1 priority 150 SW1(config-if)#standby 1 preempt SW1(config-if)#standby 1 track serial 0/0 SW2(config)#ho SW2 SW2(config)#int f0/0 SW2(config-if)#ip address 192.168.101.3 255.255.255.0 SW2(config-if)#no shutdown SW2(config-if)#int s0/0 SW2(config-if)#ip address 11.1.1.2 255.255.255.0 SW2(config-if)#no shutdown SW2(config-if)#router ei 100 SW2(config-router)#network 192.168.101.0 SW2(config-router)#network 11.1.1.0 0.0.0.255 SW2(config-router)#no auto-summary
  • 6. Anuj Kumar ciscobulls@gmail.com SW2(config-router)#int f0/0 SW2(config-if)#standby 1 ip 192.168.101.1 SW2(config-if)#standby 1 priority 200 SW2(config-if)#standby 1 preempt *Mar 1 00:34:31.431: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active SW2(config-if)#standby 1 track serial 0/0 Verifying SW1#sh standby FastEthernet0/0 - Group 1 State is Standby 4 state changes, last state change 00:43:18 Virtual IP address is 192.168.101.1 Active virtual MAC address is 0000.0c07.ac01 Local virtual MAC address is 0000.0c07.ac01 (v1 default) Hello time 3 sec, hold time 10 sec Next hello sent in 0.000 secs Preemption enabled Active router is 192.168.101.3, priority 190 (expires in 6.912 sec) Standby router is local Priority 150 (configured 150) Track interface Serial0/0 state Up decrement 10 Group name is "hsrp-Fa0/0-1" (default) SW2#sh standby FastEthernet0/0 - Group 1 State is Active 2 state changes, last state change 00:44:28 Virtual IP address is 192.168.101.1 Active virtual MAC address is 0000.0c07.ac01 Local virtual MAC address is 0000.0c07.ac01 (v1 default) Hello time 3 sec, hold time 10 sec Next hello sent in 1.296 secs Preemption enabled Active router is local Standby router is 192.168.101.2, priority 150 (expires in 8.436 sec) Priority 190 (configured 200) Track interface Serial0/0 state Down decrement 10 Group name is "hsrp-Fa0/0-1" (default) Thank you for giving me your precious time. Anuj Kumar