PRÁCTICA 2: EJERCICIO C leer número de l 1 al 10 y que escriba el    número con letra.                               Pseu...
PRÁCTICA 3: EJERCICIO B    Dado como dato el sueldo de un trabajador, aplicar el    15% de aumento si su sueldo es inferio...
PRACTICA 3 EJERCICIO E    Dados 3 números decir cuál es el mayor.   Algoritmo   Entrada:                                ...
PRACTICA 3 EJERCICIO F     En un determinado comercio se realiza un descuento dependiendo del precio de cada producto. Si ...
PRACTICA 4 EJERCICIO B    Programa que pida 5 números y calcule su suma y promedio enviando los resultados    a pantalla. ...
PRACTICA 4 EJERCICIO c Programa que pida    una palabra. La clave de salida es 0.   Algoritmo                            ...
Preudocodigos & algoritmos (ciclos sino)
Próxima SlideShare
Cargando en…5
×

Preudocodigos & algoritmos (ciclos sino)

548 visualizaciones

Publicado el

Publicado en: Educación
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Preudocodigos & algoritmos (ciclos sino)

  1. 1. PRÁCTICA 2: EJERCICIO C leer número de l 1 al 10 y que escriba el número con letra.  Pseudocodigo SI NO INICIO SI (num=7) ENTONCES ALGORITMO: ESCRIBIR (“Escriba su número”) ESCRIBIR (“siete”) LEER (num) SI NO Entrada: Num: variable real SI (num=1) ENTONCES SI (num=8) ENTONCES para guardar el numero ESCRIBIR (“uno”) ESCRIBIR (“ocho”) SI NO SI NO Proceso: utilizar el SI, SI SI (num=2) ENTONCES SI (num=9) ENTONCES NO y “ESCRIBIR” para ESCRIBIR (“dos”) ESCRIBIR (“nueve”) escribir los numeros con SI NO SI NO letra ESCRIBIR (“diez”) SI (num=3) ENTONCES FIN SI ESCRIBIR (“tres”) Salida: Desplegar los FIN SI SI NO numeros con letra SI (num=4) ENTONCES FIN SI FIN SI ESCRIBIR (“cuatro”) FIN SI SI NO FIN SI SI (num=5) ENTONCES FIN SI ESCRIBIR (“cinco”) FIN SI SINO FIN SI SI (num=6) ENTONCES FIN SI ESCRIBIR (“seis”) FIN
  2. 2. PRÁCTICA 3: EJERCICIO B Dado como dato el sueldo de un trabajador, aplicar el 15% de aumento si su sueldo es inferior a $1000. Imprimir el nuevo sueldo delo trabajador. Algoritmo Entrada: sueldo: variable real para  Pseudocodigo guardar el sueldo inicial INICIO Aumento: variable real para guardar aumento ESCRIBIR (“Cual es tu sueldo?”) Nvosueldo: variable real para LEER (sueldo) guardar el nuevo sueldo SI (sueldo < 1000) ENTONCES Proceso: si el sueldo es menor aumento← (sueldo*15)/100 a 1000, obtenemos el 15% del nvosueldo (aumento+sueldo) sueldo inicial. IMPRIMIR (nvosueldo) Salida:Imprimir el nuevo sueldo ya con el aumento FIN SI FIN
  3. 3. PRACTICA 3 EJERCICIO E Dados 3 números decir cuál es el mayor. Algoritmo Entrada:  Pseudocodigo ESCRIBIR (“Dame tres numeros“) Variable real NUM 1: para numero 1 LEER (num1, num2, num3) Variable real NUM 2: para numero 2 Si (num1>num2) ENTONCES Variable real NUM 3: para numero 3 mayor ← num1 SINO Proceso: utilizar el SI mayor ← NUM2 ENTONCES SINO para FIN SI comparar ambos numeros SI (mayor>num3) Entonces Salida:Imprimir cual numero Escribir (“Tu numero mayor es:“), mayor; Sino es mayor Escribir (“Tu numero mayor es:", num3; FinSi FinProceso
  4. 4. PRACTICA 3 EJERCICIO F En un determinado comercio se realiza un descuento dependiendo del precio de cada producto. Si el precio es inferior a $600, no se hace descuento; si es mayor o igual a $600 y menor que $900 se hace un 5% de descuento, y si es mayor o igual a $900 se hace un 10% de descuento. Realizar el diagrama que lee el precio de un producto y nos calcula y escribe su precio final. Algoritmo  PseudocodigoEntrada: INICIO ESCRIBIR ("Cual es el precio de su producto“?)>variable real precio: para precio inicial LEER (precio)> Variable real desc: para descuento SI (precio<600) ENTONCES>Variable Prefinal: para precio final ESCRIBIR (PRECIO)> Desc2: descuento para el 10% de descuento SI NO> Prefinal2: precio final 2 para el 10% de SI (precio<900) ENTONCES descuento desc← (precio*5)/100Proceso: si el precio es mayor o = a prefinal ← precio-desc) 600 y menos que 900 sacamos el ESCRIBIR (prefinal) 5% de descuento, y si es mayor o = hacemos un 10% de descuento SI NO desc2 ←(precio*10)/100Salida: imprimir el precio final 1, o 2,despendiendo del descuento y prefinal2 ←(precio-desc2) cantidad IMPRIMIR (prefinal2) FIN SI FIN SI FIN SI
  5. 5. PRACTICA 4 EJERCICIO B Programa que pida 5 números y calcule su suma y promedio enviando los resultados a pantalla. (Para)  Pseudocodigo Algoritmo {suma: suma Cont: contador Entrada: Prom: promedioVariable real SUMA: para la suma Num: numero}Variable real CONTADOR: para el contador INICIOVariable real PROM: para el promedio Suma←0Variable real NUM: para el numero prom ←0 Proceso: num←0 Inicializar el contador hasta el cont ←0 5, sumar los numeros, y para MIENTRAS (cont<5) sacar el prosmedio lo dividimos ESCRIBIR (cont) entre 4 cont ←cont+1 ESCRIBIR (“introduce 5 numeros”) Salida: LEER (num) Desplegar la suma y promedio Suma ← (suma+num) de los numeros introducidos FIN MIENTRAS prom ←(suma/4) ESCRIBIR (“Suma:“), suma; ESCRIBIR (“Promedio:”), prom; FIN
  6. 6. PRACTICA 4 EJERCICIO c Programa que pida una palabra. La clave de salida es 0. Algoritmo  Pseudocodigo Entrada: INICIOVariable real CONTADOR: para el contador Num ← 0Variable real NUM: para el numero Cont ← 0 Proceso: inicializar contando hasta el 10 MIENTRAS (cont<10) Salida: no va a desplegar nada MIENTRAS (cont<10) ESCRIBIR (cont) cont ←(cont+1) ESCRIBIR (“Ingresa un numero”) LEER (num) FIN MIENTRAS FIN

×