Se ha denunciado esta presentación.
Utilizamos tu perfil de LinkedIn y tus datos de actividad para personalizar los anuncios y mostrarte publicidad más relevante. Puedes cambiar tus preferencias de publicidad en cualquier momento.

Απλή και σύνθετη δομή επιλογής

1.974 visualizaciones

Publicado el

Διαφάνειες για την διδασκαλία της απλής και σύνθετης δομής επιλογής. Το εκπαιδευτικό υλικό δημιουργήθηκε για να υποστηρίξει το δεύτερο φύλλο εργασίας διδακτικού σεναρίου στο μάθημα Αρχές Προγραμματισμού της Β' Τάξης του νέου Επαγγελματικού Λυκείου.

Publicado en: Educación
  • Sé el primero en comentar

Απλή και σύνθετη δομή επιλογής

  1. 1. Δομή Επιλογής NAI Έφυγε το λιοντάρι ; ΟΧΙ ΠΕΡΙΜΕΝΩ ΚΑΤΕΒΑΙΝΩ
  2. 2. Δομή Επιλογής  Χρησιμοποιείται σε προβλήματα όπου χρειάζεται να ληφθούν κάποιες αποφάσεις με βάση κάποια δεδομένα κριτήρια.  Περιλαμβάνει τον έλεγχο κάποιας συνθήκης με δύο δυνατές τιμές (αληθής, ψευδής) και στη συνέχεια την εκτέλεση εντολής ή εντολών ανάλογα με την τιμή της συνθήκης.  Τη συναντάμε σε τρεις μορφές  Απλή  Σύνθετη  Πολλαπλή
  3. 3. Απλή Επιλογή Σύνταξη: ΑΝ <Συνθήκη> ΤΟΤΕ Εντολή ή Εντολές ΤΕΛΟΣ_ΑΝ Ή ΑΝ <Συνθήκη> ΤΟΤΕ Εντολή Συνθήκη Λειτουργία: Ελέγχεται η τιμή της συνθήκης και αν αυτή ισχύει -είναι αληθής- τότε εκτελούνται οι εντολές ή η εντολή στο τμήμα του ΤΟΤΕ μέχρι το ΤΕΛΟΣ_ΑΝ Αν η συνθήκη δεν ισχύει -είναι ψευδής- η εκτέλεση του προγράμματος συνεχίζεται με την εντολή που ακολουθεί τη δήλωση ΤΕΛΟΣ_ΑΝ Εντολή ή Εντολές
  4. 4. Απλή Επιλογή – Παράδειγμα 1 Πρόταση: Αν βρέχει θα πάρω μαζί μου την ομπρέλα Αν <βρέχει> τότε παίρνω_ ομπρέλα Τέλος_Αν βρέχει ΝΑΙ Παίρνω την ομπρέλα
  5. 5. Απλή Επιλογή – Παράδειγμα 2 Να γραφεί αλγόριθμος που θα εκτυπώνει την απόλυτη τιμή ενός αριθμού που θα δίνει ο χρήστης. Αλγόριθμος ΑπλήΕπιλογή1 Διάβασε a Αν a < 0 τότε a  a*(-1) Τέλος_Αν Εκτύπωσε a Τέλος ΑπλήΕπιλογή1
  6. 6. Σύνθετη Επιλογή Σύνταξη: ΑΝ <Συνθήκη> ΤΟΤΕ Εντολή1 ή Εντολές1 ΑΛΛΙΩΣ Εντολή2 ή Εντολές2 ΤΕΛΟΣ_ΑΝ Λειτουργία: Ελέγχεται η τιμή της συνθήκης και αν αυτή ισχύει (είναι αληθής), τότε εκτελούνται οι εντολές στο τμήμα του ΤΟΤΕ (μέχρι το ΑΛΛΙΩΣ). Αν η συνθήκη είναι ψευδής , εκτελούνται οι εντολές στο τμήμα του ΑΛΛΙΩΣ (μέχρι το ΤΕΛΟΣ_ΑΝ). Σε κάθε περίπτωση λοιπόν εκτελείται μόνο το ένα τμήμα εντολών και η εκτέλεση του προγράμματος συνεχίζεται με την εντολή που ακολουθεί τη δήλωση ΤΕΛΟΣ_ΑΝ ΟΧΙ NAI Συνθήκη Εντολή1 ή Εντολές1 Εντολή2 ή Εντολές2
  7. 7. Σύνθετη Επιλογή – Παράδειγμα1 Πρόταση: Αν ο καιρός είναι καλός θα ρίξω παραγάδι αλλιώς θα ψαρέψω με το καλάμι. Αν < ο καιρός είναι καλός> ΤΟΤΕ θα_ρίξω_παραγάδι ΑΛΛΙΩΣ θα_ψαρέψω_με_ καλάμι Τέλος_Αν ο καιρός είναι καλός; ΟΧΙ NAI θα_ρίξω_παραγάδι θα_ψαρέψω_με_ καλάμι
  8. 8. Σύνθετη Επιλογή- Παράδειγμα2 Να διαβασθούν δύο αριθμοί και σε περίπτωση που ο πρώτος αριθμός είναι μικρότερος του δεύτερου, να υπολογισθεί και να εκτυπωθεί το άθροισμά τους, διαφορετικά να υπολογισθεί και να εκτυπωθεί η διαφορά τους. Αλγόριθμος Συνθ2 Διάβασε a, b Αν a < b τότε c  a + b αλλιώς c  a - b τέλος_αν Εκτύπωσε c Τέλος Συνθ2 ΑΡΧΗ ΔΙΑΒΑΣΕ a,b ΟΧΙ NAI a<b ca - b ca + b ΔΙΑΒΑΣΕ a,b ΑΡΧΗ
  9. 9. Καλή συνέχεια στις δραστηριότητες!

×