SlideShare una empresa de Scribd logo
Estructuras básicas: conceptos básicos de programación
Nicolas Arce Duque
Valeria Ayala Londoño
Nicole Baldeón Herrera
Juan David Sánchez
Dana Michelle Solarte
Grado: 10-5
Área: Tecnología e Informática
Docente: Guillermo Mondragón Castro
Año Lectivo: 2024
Tabla de contenido
Portada________________________________________________________________1
Tabla de contenido_______________________________________________________2
¿Qué es una constante? _________________________________________________________3
¿Qué es una variable? __________________________________________________________3
¿Qué es un acumulador? ________________________________________________________4
¿Qué es un contador? ___________________________________________________________5
¿Qué es un identificador? ________________________________________________________7
¿Qué es PSeInt? _______________________________________________________________8
Fundamentos de programación PSeInt______________________________________________8
Estructura repetitiva: Mientras____________________________________________________9
Estructuras repetitivas: Repetir - Hasta Que_________________________________________11
Estructuras repetitivas: Para_____________________________________________________12
Mapa conceptual______________________________________________________________14
Conclusiones_________________________________________________________________15
Blogs: ______________________________________________________________________16
Evidencias: __________________________________________________________________16
Referencias:__________________________________________________________________17
¿Qué es una constante?
En programación, una constante es un valor que no puede ser alterado durante la
ejecución de un programa; solo se puede leer y no modificar. Una constante se refiere a una
sección de memoria principal del ordenador de longitud fija, donde el programa guarda valores
que no cambian.
Por ejemplo: El valor de PI = 3,1416.
¿Qué es una variable?
Una variable es un elemento de datos con nombre cuyo valor puede cambiar durante el
curso de la ejecución de un programa.
Una variable en programación es una forma simple de almacenamiento que representa
una zona de memoria donde se guarda un elemento de datos.
¿Qué es un acumulador?
En PSeInt, los acumuladores son variables que se emplean para almacenar y acumular
valores a medida que un programa se ejecuta. En el contexto de la programación, especialmente
en bucles o estructuras repetitivas, los acumuladores son fundamentales para realizar operaciones
como sumas, promedios, conteos y otras tareas que requieren llevar un registro en tiempo real de
ciertos valores.
Por ejemplo, si estás desarrollando un programa que requiere sumar una serie de números
ingresados por el usuario, podrías utilizar un acumulador para ir almacenando la suma parcial en
cada iteración del bucle, lo que te permitiría obtener el resultado final al finalizar el proceso.
Los acumuladores son una herramienta poderosa en programación ya que permiten
realizar cálculos complejos y procesos repetitivos de manera eficiente y organizada.
Ejemplo:
¿Qué es un contador?
Un contador es una variable entera que utilizamos para contar la cantidad de veces que se
repite una acción o un fragmento de código. Su función principal es llevar un registro numérico
de eventos. Sus aspectos claves son:
La Inicialización:
-Al crear un contador, lo inicializamos con un valor específico (generalmente o).
-Por ejemplo, si deseamos contar los números pares entre 5 números ingresados,
podríamos declarar un contador llamado cont y asignarle el valor inicial de 0.
El Incremento:
-Cada vez que ocurre el suceso que estamos contando, incrementamos el contador
sumándole 1.
- En PSeInt, esto de logra mediante la operación cont <- cont + 1.
Ejemplo de Contador en PSeInt:
Suponiendo que tenemos que contar los números pares entre 5 números ingresados por
un usuario. El ejemplo de cómo podría implementarlo en PSeInt es el siguiente:
Proceso ContarPares
Definir var, cont, num como Entero
cont <- 0
Para var <- 1 Hasta 5 Hacer
Escribir Sin Saltar "Dime un número:"
Leer num
Si num % 2 = 0 Entonces
cont <- cont + 1
FinSi
FinPara
Escribir "Has introducido ", cont, " números pares."
FinProceso
En el ejemplo anterior, cont es nuestro contador. Cada vez que se ingresa un número par,
se incrementa cont. Al final, mostramos la cantidad total de números pares ingresados.
Aplicaciones Prácticas:
Loa contadores son útiles en situaciones como:
Contar elementos en una lista.
Realizar seguimiento de iteraciones en bucles.
Registrar eventos en un programa.
En pocas palabras, los contadores nos ayudan a controlar y cuantificar procesos dentro de
nuestros programas.
Imágen relacionada:
¿Qué es un identificador?
Un identificador es una serie de letras y números que se utiliza para representar: El
nombre de un objeto o variable. Un nombre de categoría, diseño o unión. Un nombre de tipo
enumerado
Un identificador se utiliza para representar o designar algo en un programa, como el
nombre de una variable, constante, función, etc. Es como el apelativo que le asignas a ciertos
elementos de tu programa para que sean más sencillos de recordar y emplear. Por ejemplo,
podrías llamar "nombreUsuario" a la variable que almacena el nombre de un usuario en tu
programa. Los identificadores son útiles para hacer que el código sea más comprensible y para
referirse a diferentes partes del programa de manera más clara.
algunos ejemplos de identificadores podrían ser:
- nombreUsuario
- saldoCuenta
- edadPersona
- calcularPromedio
- MAX_INT (convención para constantes en mayúsculas)
¿Qué es PSeInt?
PSeInt (Pseudocodigo Intérprete) es una herramienta educativa diseñada para ayudar a
los estudiantes a dar sus primeros pasos en la programación. Se basa en el uso de pseudocódigo,
un lenguaje de programación simplificado y escrito en lenguaje natural, que facilita la
comprensión de los conceptos básicos de la programación sin la complejidad de la sintaxis de los
lenguajes de programación formales.
Fundamentos de programación PSeInt
La secuencia de instrucciones ejecutada por una instrucción Segun depende del valor de
una variable numérica.
Esta instrucción permite ejecutar opcionalmente varias acciones posibles, dependiendo
del valor almacenado en una variable de tipo numérico. Al ejecutarse, se evalúa el contenido de
la variable y se ejecuta la secuencia de instrucciones asociada con dicho valor.
Cada opción está formada por uno o más números separados por comas, dos puntos y una
secuencia de instrucciones. Si una opción incluye varios números, la secuencia de instrucciones
asociada se debe ejecutar cuando el valor de la variable es uno de esos números.
Opcionalmente, se puede agregar una opción final, denominada De Otro Modo, cuya
secuencia de instrucciones asociada se ejecutará sólo si el valor almacenado en la variable no
coincide con ninguna de las opciones anteriores.
Al finalizar se continúa la ejecución secuencia con la siguiente instrucción detrás del
FinSegun.
Ejemplo:
Segun <variable> Hacer
<número1>: <instrucciones>
<número2>,<número3>: <instrucciones>
<...>
[De Otro Modo: <instrucciones>]
FinSegun
Estructura repetitiva: Mientras
La instrucción Mientras ejecuta una secuencia de instrucciones mientras una condición
sea verdadera.
Mientras <condición> Hacer
<instrucciones>
FinMientras
Al ejecutarse esta instrucción, la condición es evaluada. Si la condición resulta verdadera,
se ejecuta una vez la secuencia de instrucciones que forman el cuerpo del ciclo. Al finalizar la
ejecución del cuerpo del ciclo se vuelve a evaluar la condición y, si es verdadera, la ejecución se
repite. Estos pasos se repiten mientras la condición sea verdadera.
Se puede dar la circunstancia que las instrucciones del bucle no se ejecuten nunca, si al
evaluar por primera vez la condición resulta ser falsa.
Si la condición siempre es verdadera, al ejecutar esta instrucción se produce un ciclo
infinito. A fin de evitarlo, las instrucciones del cuerpo del ciclo deben contener alguna
instrucción que modifique la o las variables involucradas en la condición, de modo que ésta sea
falsificada en algún momento y así finalice la ejecución del ciclo.
Ejemplo:
Crea un programa que pida al usuario una contraseña, de forma repetitiva mientras que
no introduzca “asdasd”. Cuando finalmente escriba la contraseña correcta, se le dirá
“Bienvenido” y terminará el programa.
Proceso login
Definir secreto, clave como cadena;
secreto <- "asdasd";
Escribir "Dime la clave:";
Leer clave;
Mientras clave<>secreto Hacer
Escribir "Clave incorrecta!!!";
Escribir "Dime la clave:";
Leer clave;
FinMientras
Escribir "Bienvenido!!!";
Escribir "Programa terminado";
FinProceso
Estructuras repetitivas: Repetir - Hasta Que
La instrucción Repetir-Hasta Que ejecuta una secuencia de instrucciones hasta que la
condición sea verdadera.
Repetir
<instrucciones>
Hasta Que <condición>
Al ejecutarse esta instrucción, la secuencia de instrucciones que forma el cuerpo del ciclo
se ejecuta una vez y luego se evalúa la condición. Si la condición es falsa, el cuerpo del ciclo se
ejecuta nuevamente y se vuelve a evaluar la condición. Esto se repite hasta que la condición sea
verdadera.
Note que, dado que la condición se evalúa al final, las instrucciones del cuerpo del ciclo
serán ejecutadas al menos una vez.
Además, a fin de evitar ciclos infinitos, el cuerpo del ciclo debe contener alguna
instrucción que modifique la o las variables involucradas en la condición de modo que en algún
momento la condición sea verdadera y se finalice la ejecución del ciclo.
Ejemplo:
Crea un programa que pida al usuario una contraseña, de forma repetitiva mientras que
no introduzca “asdasd”. Cuando finalmente escriba la contraseña correcta, se le dirá
“Bienvenido” y terminará el programa.
Proceso login
Definir secreto, clave como cadena;
secreto <- "asdasd";
Repetir
Escribir "Dime la clave:";
Leer clave;
Si clave<>secreto Entonces
Escribir "Clave incorrecta!!!";
FinSi
Hasta Que clave=secreto
Escribir "Bienvenido!!!";
Escribir "Programa terminado";
FinProceso
Estructuras repetitivas: Para
La instrucción Para ejecuta una secuencia de instrucciones un número determinado de
veces.
Para <variable> <- <inicial> Hasta <final> [Con Paso <paso>] Hacer
<instrucciones>
FinPara
Al ingresar al bloque, la variable <variable> recibe el valor <inicial> y se ejecuta la
secuencia de instrucciones que forma el cuerpo del ciclo.
Luego se incrementa la variable <variable> en <paso> unidades y se evalúa si el valor
almacenado en <variable> superó al valor <final>.
Si esto es falso se repite hasta que <variable> supere a <final>.
Si se omite la cláusula Con Paso <paso>, la variable <variable> se incrementará en 1.
Ejemplo
Escribir en pantalla del 1 al 10.
Proceso Contar
Definir var como Entero;
Para var<-1 Hasta 10 Hacer
Escribir Sin Saltar var," ";
FinPara
FinProceso
Escribir en pantalla de 10 al 1.
Proceso ContarDescesdente
Definir var como Entero;
Para var<-10 Hasta 1 Con Paso -1 Hacer
Escribir Sin Saltar var," ";
FinPara
FinProceso
Escribir los número pares desde el 2 al 10.
Proceso ContarPares
Definir var como Entero;
Para var<-2 Hasta 10 Con Paso 2 Hacer
Escribir Sin Saltar var," ";
FinPara
FinProceso
Mapa conceptual
Conclusiones
PSeInt es una herramienta educativa diseñada para facilitar la comprensión de los
conceptos básicos de la programación mediante el uso de pseudocódigo. Este enfoque permite a
los estudiantes y principiantes planificar y diseñar algoritmos de manera intuitiva, utilizando un
lenguaje informal y cercano al lenguaje humano. Al eliminar la complejidad de la sintaxis
específica de un lenguaje de programación, PSeInt ayuda a enfocarse en la lógica y la estructura
de los algoritmos, lo cual es crucial para construir una base sólida en programación
La declaración de variables en PSeInt es un proceso fundamental que implica reservar un
espacio de memoria para almacenar datos de un tipo específico. Los nombres de las variables
deben seguir ciertas reglas, como comenzar con una letra y evitar espacios y caracteres
especiales. PSeInt soporta varios tipos de datos, como enteros, reales, cadenas y lógicos, lo que
permite a los programadores manipular diferentes tipos de información según sus necesidades.
Este enfoque estructurado en la declaración de variables facilita la organización y el manejo de
datos dentro de un programa.
Blogs:
Nicole Baldeon: https://nicoletecnologia200.blogspot.com/?m=
Nicolas Arce: https://tecnonicko.blogspot.com/
Juan David Sánchez: https://tecnoconjuandax.blogspot.com/
Valeria Ayala: https://tecnologiaconayalita.blogspot.com
Dana Michelle Solarte: https://technochellegogogogo.blogspot.com/
Evidencias:
Referencias:
https://es.wikipedia.org/wiki/Constante_(inform%C3%A1tica)z
https://www.ibm.com/docs/es/tcamfma/6.3.0?topic=tesl-constants-variables-
4#:~:text=Una%20variable%20es%20un%20elemento,y%20el%20signo%20de%20subrayado
https://www.lifeder.com/variable-programacion/
https://www.uacj.mx/CGTI/CDTE/JPM/Documents/IIT/fund_programacion/U4-
1.html#:~:text=Un%20acumulador%20es%20una%20variable,valores%20contenidos%20en%20
otras%20variables.
https://ejemplosweb.de/contadores-y-acumuladores-en-pseint-definicion-que-es-
diferencias-significado-usos/
https://intef.es/observatorio_tecno/pseint-programando-en-
pseudocodigo/#:~:text=PSeInt%20es%20la%20abreviatura%20de,una%20%20sintaxis%20%20f
lexible%20e%20%20incluso
https://plataforma.josedomingo.org/pledin/cursos/programacion/curso/u17/

Más contenido relacionado

Similar a Conceptos básicos de programación 10-5.pdf

Trabajo Tecnología P#2 10-6. eliana valencia
Trabajo Tecnología P#2 10-6. eliana valenciaTrabajo Tecnología P#2 10-6. eliana valencia
Trabajo Tecnología P#2 10-6. eliana valencia
ElianaValencia28
 
Informe de pseint
Informe de pseintInforme de pseint
Informe de pseint
gabysabogal1
 
Tecnologia trabajo
Tecnologia trabajoTecnologia trabajo
Tecnologia trabajo
Arnold Riascos
 
trabajo de tecnologia_segundo_periodo_10-4.docx
trabajo de tecnologia_segundo_periodo_10-4.docxtrabajo de tecnologia_segundo_periodo_10-4.docx
trabajo de tecnologia_segundo_periodo_10-4.docx
Franksamuel11
 
Estructuras básicas
Estructuras básicasEstructuras básicas
Estructuras básicas
valentinaceballosval
 
Estructuras básicas: Conceptos básicos de programación.pdf
Estructuras básicas: Conceptos básicos de programación.pdfEstructuras básicas: Conceptos básicos de programación.pdf
Estructuras básicas: Conceptos básicos de programación.pdf
AeiouAeiou5
 
Conceptos básicos de programación.pdf12e
Conceptos básicos de programación.pdf12eConceptos básicos de programación.pdf12e
Conceptos básicos de programación.pdf12e
NataliaJaramilloR
 
Actividad Conceptos básicos de programación.pdf
Actividad Conceptos básicos de programación.pdfActividad Conceptos básicos de programación.pdf
Actividad Conceptos básicos de programación.pdf
NajwaNimri1
 
Estructuras repetitivas-dayana-y-ana
Estructuras repetitivas-dayana-y-anaEstructuras repetitivas-dayana-y-ana
Estructuras repetitivas-dayana-y-ana
Dayana Hernandez
 
Conceptos básicos de programación pseint
Conceptos básicos de programación pseintConceptos básicos de programación pseint
Conceptos básicos de programación pseint
GabrielaArangoErazo
 
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
ngel943143
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Emanuelminotta
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Emanuelminotta
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Emanuelminotta
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
DeyaniraCuero
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
ByLauraVelasco
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
isabellapiedrahita5
 
Pseint terminado
Pseint terminadoPseint terminado
Pseint terminado
juligames555
 
Tecnología Periodo 2.pdf
Tecnología Periodo 2.pdfTecnología Periodo 2.pdf
Tecnología Periodo 2.pdf
JuanDavidGarcesCasta
 
Pseint
Pseint Pseint
Pseint
juligames555
 

Similar a Conceptos básicos de programación 10-5.pdf (20)

Trabajo Tecnología P#2 10-6. eliana valencia
Trabajo Tecnología P#2 10-6. eliana valenciaTrabajo Tecnología P#2 10-6. eliana valencia
Trabajo Tecnología P#2 10-6. eliana valencia
 
Informe de pseint
Informe de pseintInforme de pseint
Informe de pseint
 
Tecnologia trabajo
Tecnologia trabajoTecnologia trabajo
Tecnologia trabajo
 
trabajo de tecnologia_segundo_periodo_10-4.docx
trabajo de tecnologia_segundo_periodo_10-4.docxtrabajo de tecnologia_segundo_periodo_10-4.docx
trabajo de tecnologia_segundo_periodo_10-4.docx
 
Estructuras básicas
Estructuras básicasEstructuras básicas
Estructuras básicas
 
Estructuras básicas: Conceptos básicos de programación.pdf
Estructuras básicas: Conceptos básicos de programación.pdfEstructuras básicas: Conceptos básicos de programación.pdf
Estructuras básicas: Conceptos básicos de programación.pdf
 
Conceptos básicos de programación.pdf12e
Conceptos básicos de programación.pdf12eConceptos básicos de programación.pdf12e
Conceptos básicos de programación.pdf12e
 
Actividad Conceptos básicos de programación.pdf
Actividad Conceptos básicos de programación.pdfActividad Conceptos básicos de programación.pdf
Actividad Conceptos básicos de programación.pdf
 
Estructuras repetitivas-dayana-y-ana
Estructuras repetitivas-dayana-y-anaEstructuras repetitivas-dayana-y-ana
Estructuras repetitivas-dayana-y-ana
 
Conceptos básicos de programación pseint
Conceptos básicos de programación pseintConceptos básicos de programación pseint
Conceptos básicos de programación pseint
 
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
Conceptos básicos de programación 10-6 - Gabriela Arango, Ángel Cárdenas, Ale...
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdfEstructuras básicas. Conceptos básicos de programación. 10-3.pdf
Estructuras básicas. Conceptos básicos de programación. 10-3.pdf
 
Pseint terminado
Pseint terminadoPseint terminado
Pseint terminado
 
Tecnología Periodo 2.pdf
Tecnología Periodo 2.pdfTecnología Periodo 2.pdf
Tecnología Periodo 2.pdf
 
Pseint
Pseint Pseint
Pseint
 

Último

MATERIAL BASE D A T O S .docx
MATERIAL BASE    D A T O S              .docxMATERIAL BASE    D A T O S              .docx
MATERIAL BASE D A T O S .docx
CarlosAndresLoaizaRe
 
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
bellomiguelangel68
 
El uso de las TIC en la vida cotidiana.pptx
El uso de las TIC en la vida cotidiana.pptxEl uso de las TIC en la vida cotidiana.pptx
El uso de las TIC en la vida cotidiana.pptx
Katia Reyes
 
_Manejo de Riesgos en el Laboratorio.pdf
_Manejo de Riesgos en el Laboratorio.pdf_Manejo de Riesgos en el Laboratorio.pdf
_Manejo de Riesgos en el Laboratorio.pdf
correodetareas
 
Generaciones de Computadoras .
Generaciones de Computadoras                 .Generaciones de Computadoras                 .
Generaciones de Computadoras .
gregory760891
 
Informe_mc_bombas_Warman_001-WEIR vulco.pdf
Informe_mc_bombas_Warman_001-WEIR vulco.pdfInforme_mc_bombas_Warman_001-WEIR vulco.pdf
Informe_mc_bombas_Warman_001-WEIR vulco.pdf
Rubén Cortes Zavala
 
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptxDiapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
GnesisOrtegaDeLen
 
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdfInforme de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
KEVINYOICIAQUINOSORI
 
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdfPRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
MARCOMARCAVILLACA1
 
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
241578066
 
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISIONCAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
JairoDarioCalleGarci1
 
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
MenaOlortinYherlyEli
 
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
sunwndniel
 
Catalogo-Voxtech- accesorios radios RF.pdf
Catalogo-Voxtech- accesorios radios RF.pdfCatalogo-Voxtech- accesorios radios RF.pdf
Catalogo-Voxtech- accesorios radios RF.pdf
walter729637
 
11. Legislación Aplicada a la Informática.pdf
11. Legislación Aplicada a la Informática.pdf11. Legislación Aplicada a la Informática.pdf
11. Legislación Aplicada a la Informática.pdf
PanchoChangue
 
Transporte a través del tiempo en el perú.pdf
Transporte a través del tiempo en el perú.pdfTransporte a través del tiempo en el perú.pdf
Transporte a través del tiempo en el perú.pdf
milagrosAlbanPacherr
 
bomba-koomey -Todo sobre sus istema y conexiones
bomba-koomey -Todo sobre sus istema y conexionesbomba-koomey -Todo sobre sus istema y conexiones
bomba-koomey -Todo sobre sus istema y conexiones
JessAdrinGonzlezCade
 
Conceptos y definiciones de Antenas y propagación
Conceptos y definiciones de Antenas y propagaciónConceptos y definiciones de Antenas y propagación
Conceptos y definiciones de Antenas y propagación
edgarcalle8
 
aplicaciones de sistema de informacion geografico
aplicaciones de sistema de informacion geograficoaplicaciones de sistema de informacion geografico
aplicaciones de sistema de informacion geografico
cyberquiximies
 
Evolución, características, aplicación, ventajas y desventajas de las TIC
Evolución, características, aplicación, ventajas y desventajas de las TICEvolución, características, aplicación, ventajas y desventajas de las TIC
Evolución, características, aplicación, ventajas y desventajas de las TIC
Henry W. Zavala
 

Último (20)

MATERIAL BASE D A T O S .docx
MATERIAL BASE    D A T O S              .docxMATERIAL BASE    D A T O S              .docx
MATERIAL BASE D A T O S .docx
 
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
2 FIBRA OPTICA COMO MEDIO DE RED DE ACCESO.pptx
 
El uso de las TIC en la vida cotidiana.pptx
El uso de las TIC en la vida cotidiana.pptxEl uso de las TIC en la vida cotidiana.pptx
El uso de las TIC en la vida cotidiana.pptx
 
_Manejo de Riesgos en el Laboratorio.pdf
_Manejo de Riesgos en el Laboratorio.pdf_Manejo de Riesgos en el Laboratorio.pdf
_Manejo de Riesgos en el Laboratorio.pdf
 
Generaciones de Computadoras .
Generaciones de Computadoras                 .Generaciones de Computadoras                 .
Generaciones de Computadoras .
 
Informe_mc_bombas_Warman_001-WEIR vulco.pdf
Informe_mc_bombas_Warman_001-WEIR vulco.pdfInforme_mc_bombas_Warman_001-WEIR vulco.pdf
Informe_mc_bombas_Warman_001-WEIR vulco.pdf
 
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptxDiapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
Diapositiva sobre Tecnologia de la Información y Telecomunicaciones.pptx
 
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdfInforme de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
Informe de electroforesis del ADN MEDIANTE EL MinION Mk1C.pdf
 
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdfPRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
PRESENTACION_TRANSFRENIA DE EMBRIONES _2019_MANAZO.pdf
 
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
"El uso de las TIC en la vida cotidiana". SantanaMartinez_Alejandra
 
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISIONCAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
CAMARAS DE SEGURIDAD Y CIRCUITO CERRADO DE TELEVISION
 
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
TESisssssssss de yhnnjuuhjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjjj...
 
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
Reconocimiento del Secuenciador de nanoporos (Nanopore sequencing) MinIon Mk1...
 
Catalogo-Voxtech- accesorios radios RF.pdf
Catalogo-Voxtech- accesorios radios RF.pdfCatalogo-Voxtech- accesorios radios RF.pdf
Catalogo-Voxtech- accesorios radios RF.pdf
 
11. Legislación Aplicada a la Informática.pdf
11. Legislación Aplicada a la Informática.pdf11. Legislación Aplicada a la Informática.pdf
11. Legislación Aplicada a la Informática.pdf
 
Transporte a través del tiempo en el perú.pdf
Transporte a través del tiempo en el perú.pdfTransporte a través del tiempo en el perú.pdf
Transporte a través del tiempo en el perú.pdf
 
bomba-koomey -Todo sobre sus istema y conexiones
bomba-koomey -Todo sobre sus istema y conexionesbomba-koomey -Todo sobre sus istema y conexiones
bomba-koomey -Todo sobre sus istema y conexiones
 
Conceptos y definiciones de Antenas y propagación
Conceptos y definiciones de Antenas y propagaciónConceptos y definiciones de Antenas y propagación
Conceptos y definiciones de Antenas y propagación
 
aplicaciones de sistema de informacion geografico
aplicaciones de sistema de informacion geograficoaplicaciones de sistema de informacion geografico
aplicaciones de sistema de informacion geografico
 
Evolución, características, aplicación, ventajas y desventajas de las TIC
Evolución, características, aplicación, ventajas y desventajas de las TICEvolución, características, aplicación, ventajas y desventajas de las TIC
Evolución, características, aplicación, ventajas y desventajas de las TIC
 

Conceptos básicos de programación 10-5.pdf

  • 1. Estructuras básicas: conceptos básicos de programación Nicolas Arce Duque Valeria Ayala Londoño Nicole Baldeón Herrera Juan David Sánchez Dana Michelle Solarte Grado: 10-5 Área: Tecnología e Informática Docente: Guillermo Mondragón Castro Año Lectivo: 2024
  • 2. Tabla de contenido Portada________________________________________________________________1 Tabla de contenido_______________________________________________________2 ¿Qué es una constante? _________________________________________________________3 ¿Qué es una variable? __________________________________________________________3 ¿Qué es un acumulador? ________________________________________________________4 ¿Qué es un contador? ___________________________________________________________5 ¿Qué es un identificador? ________________________________________________________7 ¿Qué es PSeInt? _______________________________________________________________8 Fundamentos de programación PSeInt______________________________________________8 Estructura repetitiva: Mientras____________________________________________________9 Estructuras repetitivas: Repetir - Hasta Que_________________________________________11 Estructuras repetitivas: Para_____________________________________________________12 Mapa conceptual______________________________________________________________14 Conclusiones_________________________________________________________________15 Blogs: ______________________________________________________________________16 Evidencias: __________________________________________________________________16 Referencias:__________________________________________________________________17
  • 3. ¿Qué es una constante? En programación, una constante es un valor que no puede ser alterado durante la ejecución de un programa; solo se puede leer y no modificar. Una constante se refiere a una sección de memoria principal del ordenador de longitud fija, donde el programa guarda valores que no cambian. Por ejemplo: El valor de PI = 3,1416. ¿Qué es una variable? Una variable es un elemento de datos con nombre cuyo valor puede cambiar durante el curso de la ejecución de un programa. Una variable en programación es una forma simple de almacenamiento que representa una zona de memoria donde se guarda un elemento de datos.
  • 4. ¿Qué es un acumulador? En PSeInt, los acumuladores son variables que se emplean para almacenar y acumular valores a medida que un programa se ejecuta. En el contexto de la programación, especialmente en bucles o estructuras repetitivas, los acumuladores son fundamentales para realizar operaciones como sumas, promedios, conteos y otras tareas que requieren llevar un registro en tiempo real de ciertos valores. Por ejemplo, si estás desarrollando un programa que requiere sumar una serie de números ingresados por el usuario, podrías utilizar un acumulador para ir almacenando la suma parcial en cada iteración del bucle, lo que te permitiría obtener el resultado final al finalizar el proceso. Los acumuladores son una herramienta poderosa en programación ya que permiten realizar cálculos complejos y procesos repetitivos de manera eficiente y organizada.
  • 5. Ejemplo: ¿Qué es un contador? Un contador es una variable entera que utilizamos para contar la cantidad de veces que se repite una acción o un fragmento de código. Su función principal es llevar un registro numérico de eventos. Sus aspectos claves son: La Inicialización: -Al crear un contador, lo inicializamos con un valor específico (generalmente o). -Por ejemplo, si deseamos contar los números pares entre 5 números ingresados, podríamos declarar un contador llamado cont y asignarle el valor inicial de 0. El Incremento: -Cada vez que ocurre el suceso que estamos contando, incrementamos el contador sumándole 1. - En PSeInt, esto de logra mediante la operación cont <- cont + 1. Ejemplo de Contador en PSeInt: Suponiendo que tenemos que contar los números pares entre 5 números ingresados por un usuario. El ejemplo de cómo podría implementarlo en PSeInt es el siguiente:
  • 6. Proceso ContarPares Definir var, cont, num como Entero cont <- 0 Para var <- 1 Hasta 5 Hacer Escribir Sin Saltar "Dime un número:" Leer num Si num % 2 = 0 Entonces cont <- cont + 1 FinSi FinPara Escribir "Has introducido ", cont, " números pares." FinProceso En el ejemplo anterior, cont es nuestro contador. Cada vez que se ingresa un número par, se incrementa cont. Al final, mostramos la cantidad total de números pares ingresados. Aplicaciones Prácticas: Loa contadores son útiles en situaciones como: Contar elementos en una lista. Realizar seguimiento de iteraciones en bucles. Registrar eventos en un programa. En pocas palabras, los contadores nos ayudan a controlar y cuantificar procesos dentro de nuestros programas.
  • 7. Imágen relacionada: ¿Qué es un identificador? Un identificador es una serie de letras y números que se utiliza para representar: El nombre de un objeto o variable. Un nombre de categoría, diseño o unión. Un nombre de tipo enumerado Un identificador se utiliza para representar o designar algo en un programa, como el nombre de una variable, constante, función, etc. Es como el apelativo que le asignas a ciertos elementos de tu programa para que sean más sencillos de recordar y emplear. Por ejemplo, podrías llamar "nombreUsuario" a la variable que almacena el nombre de un usuario en tu programa. Los identificadores son útiles para hacer que el código sea más comprensible y para referirse a diferentes partes del programa de manera más clara. algunos ejemplos de identificadores podrían ser: - nombreUsuario - saldoCuenta - edadPersona
  • 8. - calcularPromedio - MAX_INT (convención para constantes en mayúsculas) ¿Qué es PSeInt? PSeInt (Pseudocodigo Intérprete) es una herramienta educativa diseñada para ayudar a los estudiantes a dar sus primeros pasos en la programación. Se basa en el uso de pseudocódigo, un lenguaje de programación simplificado y escrito en lenguaje natural, que facilita la comprensión de los conceptos básicos de la programación sin la complejidad de la sintaxis de los lenguajes de programación formales. Fundamentos de programación PSeInt La secuencia de instrucciones ejecutada por una instrucción Segun depende del valor de una variable numérica.
  • 9. Esta instrucción permite ejecutar opcionalmente varias acciones posibles, dependiendo del valor almacenado en una variable de tipo numérico. Al ejecutarse, se evalúa el contenido de la variable y se ejecuta la secuencia de instrucciones asociada con dicho valor. Cada opción está formada por uno o más números separados por comas, dos puntos y una secuencia de instrucciones. Si una opción incluye varios números, la secuencia de instrucciones asociada se debe ejecutar cuando el valor de la variable es uno de esos números. Opcionalmente, se puede agregar una opción final, denominada De Otro Modo, cuya secuencia de instrucciones asociada se ejecutará sólo si el valor almacenado en la variable no coincide con ninguna de las opciones anteriores. Al finalizar se continúa la ejecución secuencia con la siguiente instrucción detrás del FinSegun. Ejemplo: Segun <variable> Hacer <número1>: <instrucciones> <número2>,<número3>: <instrucciones> <...> [De Otro Modo: <instrucciones>] FinSegun Estructura repetitiva: Mientras La instrucción Mientras ejecuta una secuencia de instrucciones mientras una condición sea verdadera. Mientras <condición> Hacer
  • 10. <instrucciones> FinMientras Al ejecutarse esta instrucción, la condición es evaluada. Si la condición resulta verdadera, se ejecuta una vez la secuencia de instrucciones que forman el cuerpo del ciclo. Al finalizar la ejecución del cuerpo del ciclo se vuelve a evaluar la condición y, si es verdadera, la ejecución se repite. Estos pasos se repiten mientras la condición sea verdadera. Se puede dar la circunstancia que las instrucciones del bucle no se ejecuten nunca, si al evaluar por primera vez la condición resulta ser falsa. Si la condición siempre es verdadera, al ejecutar esta instrucción se produce un ciclo infinito. A fin de evitarlo, las instrucciones del cuerpo del ciclo deben contener alguna instrucción que modifique la o las variables involucradas en la condición, de modo que ésta sea falsificada en algún momento y así finalice la ejecución del ciclo. Ejemplo: Crea un programa que pida al usuario una contraseña, de forma repetitiva mientras que no introduzca “asdasd”. Cuando finalmente escriba la contraseña correcta, se le dirá “Bienvenido” y terminará el programa. Proceso login Definir secreto, clave como cadena; secreto <- "asdasd"; Escribir "Dime la clave:"; Leer clave; Mientras clave<>secreto Hacer
  • 11. Escribir "Clave incorrecta!!!"; Escribir "Dime la clave:"; Leer clave; FinMientras Escribir "Bienvenido!!!"; Escribir "Programa terminado"; FinProceso Estructuras repetitivas: Repetir - Hasta Que La instrucción Repetir-Hasta Que ejecuta una secuencia de instrucciones hasta que la condición sea verdadera. Repetir <instrucciones> Hasta Que <condición> Al ejecutarse esta instrucción, la secuencia de instrucciones que forma el cuerpo del ciclo se ejecuta una vez y luego se evalúa la condición. Si la condición es falsa, el cuerpo del ciclo se ejecuta nuevamente y se vuelve a evaluar la condición. Esto se repite hasta que la condición sea verdadera. Note que, dado que la condición se evalúa al final, las instrucciones del cuerpo del ciclo serán ejecutadas al menos una vez. Además, a fin de evitar ciclos infinitos, el cuerpo del ciclo debe contener alguna instrucción que modifique la o las variables involucradas en la condición de modo que en algún momento la condición sea verdadera y se finalice la ejecución del ciclo.
  • 12. Ejemplo: Crea un programa que pida al usuario una contraseña, de forma repetitiva mientras que no introduzca “asdasd”. Cuando finalmente escriba la contraseña correcta, se le dirá “Bienvenido” y terminará el programa. Proceso login Definir secreto, clave como cadena; secreto <- "asdasd"; Repetir Escribir "Dime la clave:"; Leer clave; Si clave<>secreto Entonces Escribir "Clave incorrecta!!!"; FinSi Hasta Que clave=secreto Escribir "Bienvenido!!!"; Escribir "Programa terminado"; FinProceso Estructuras repetitivas: Para La instrucción Para ejecuta una secuencia de instrucciones un número determinado de veces. Para <variable> <- <inicial> Hasta <final> [Con Paso <paso>] Hacer
  • 13. <instrucciones> FinPara Al ingresar al bloque, la variable <variable> recibe el valor <inicial> y se ejecuta la secuencia de instrucciones que forma el cuerpo del ciclo. Luego se incrementa la variable <variable> en <paso> unidades y se evalúa si el valor almacenado en <variable> superó al valor <final>. Si esto es falso se repite hasta que <variable> supere a <final>. Si se omite la cláusula Con Paso <paso>, la variable <variable> se incrementará en 1. Ejemplo Escribir en pantalla del 1 al 10. Proceso Contar Definir var como Entero; Para var<-1 Hasta 10 Hacer Escribir Sin Saltar var," "; FinPara FinProceso Escribir en pantalla de 10 al 1. Proceso ContarDescesdente Definir var como Entero; Para var<-10 Hasta 1 Con Paso -1 Hacer Escribir Sin Saltar var," ";
  • 14. FinPara FinProceso Escribir los número pares desde el 2 al 10. Proceso ContarPares Definir var como Entero; Para var<-2 Hasta 10 Con Paso 2 Hacer Escribir Sin Saltar var," "; FinPara FinProceso Mapa conceptual
  • 15. Conclusiones PSeInt es una herramienta educativa diseñada para facilitar la comprensión de los conceptos básicos de la programación mediante el uso de pseudocódigo. Este enfoque permite a los estudiantes y principiantes planificar y diseñar algoritmos de manera intuitiva, utilizando un lenguaje informal y cercano al lenguaje humano. Al eliminar la complejidad de la sintaxis específica de un lenguaje de programación, PSeInt ayuda a enfocarse en la lógica y la estructura de los algoritmos, lo cual es crucial para construir una base sólida en programación La declaración de variables en PSeInt es un proceso fundamental que implica reservar un espacio de memoria para almacenar datos de un tipo específico. Los nombres de las variables deben seguir ciertas reglas, como comenzar con una letra y evitar espacios y caracteres especiales. PSeInt soporta varios tipos de datos, como enteros, reales, cadenas y lógicos, lo que permite a los programadores manipular diferentes tipos de información según sus necesidades. Este enfoque estructurado en la declaración de variables facilita la organización y el manejo de datos dentro de un programa.
  • 16. Blogs: Nicole Baldeon: https://nicoletecnologia200.blogspot.com/?m= Nicolas Arce: https://tecnonicko.blogspot.com/ Juan David Sánchez: https://tecnoconjuandax.blogspot.com/ Valeria Ayala: https://tecnologiaconayalita.blogspot.com Dana Michelle Solarte: https://technochellegogogogo.blogspot.com/ Evidencias: