SlideShare una empresa de Scribd logo
DEBER DE PROGRAMACION
INTEGRANTES:
INTI CORDOVA
JOSUE CADENA
EJERCICIO:1
Proceso suma
Escribir "ingrese valor A y B";
Leer A;
Leer B;
C<-(A+B)/3;
Escribir "su valor es:",C;
FinProceso
EJERCICIO:2
Proceso numero_entero
Escribir "ingrese numero entero";
Leer numero;
cuadrado<-numero*numero;
cubo<-numero*numero*numero;
Escribir "el resultado del cuadrado es:",cuadrado;
Escribir "el resultado del cubo es:", cubo;
FinProceso
EJERCICIO:3
Proceso valor_numerico
Escribir "ingrese valor numerico";
Leer valr;
Si valr>1 y valr<100 Entonces
Escribir "positivo";
Sino
Si valr>-100 y valr<-1 Entonces
Escribir "negativo";
Sino
Si valr=0 Entonces
Escribir " 0 ";
FinSi
FinSi
FinSi
FinProceso
EJERCICIO:4
Proceso vehiculo
Escribir "ingrese precio del vehiculo";
Leer precio;
ganancia<-precio /0.12
impuesto<-precio/0.6
Escribir "la ganancia del vendedor es:",ganancia,".....","el iumpuesto es
de:",impuesto;
costo<-ganacia+impuesto
Escribir "el costo final del automovil es :",costo;
FinProceso
EJERCICIO:5
Proceso CALIFICACION
Escribir "INGRESE NOTAS";
Escribir "N1";
Leer N1;
Escribir "N2";
Leer N2;
Escribir "N3";
Leer N3;
suma<-(N1+N2+N3)/3;
Escribir "PROMEDIO ES:",suma;
FinProceso
EJERCICIO:6
Proceso promedio_mayor
Dimension alumno[2];
Dimension nota1[2];
Dimension nota2[2];
Dimension nota3[2];
Dimension promedio[2];
i<-0
Para i<-1 Hasta 2 Con Paso 1 Hacer
Escribir "ingrese alumno",i;
Leer alumno[i];
Repetir
Escribir "ingrese nota1";
Leer nota1[i];
Hasta Que nota1[i]>=1 y nota1[i]<=10
Repetir
Escribir "ingrese nota2";
Leer nota2[i];
Hasta Que nota2[i]>=1 y nota2[i]<=10
Repetir
Escribir "ingrese nota3";
Leer nota3[i];
Hasta Que nota3[i]>=1 y nota3[i]<=10
promedio[i]<-(nota1[i]+nota2[i]+nota3[i])/3;
FinPara
Para i<-1 Hasta 2 Con Paso 1 Hacer
Escribir "alumno",i," ",alumno[i];
Si promedio[i]>=9 Entonces
Escribir "el promedio es mayor ",i,": ",promedio[i];
Sino
Si promedio[i]<=9 Entonces
Escribir "el promedio es menor",i,": ",promedio[i];
Sino
Escribir "otro";
FinSi
FinSi
FinPara
FinProceso
EJERCICIO:7
Proceso calificacion
dimension Alumno[2]
dimension nota1[2]
dimension nota2[2]
Dimension nota3[2];
dimension promedio[2]
i<-0;
Para i<-1 Hasta 2 Con Paso 1 Hacer
Escribir "ingrese alumno",i;
Leer alumno[i];
Repetir
Escribir "ingrese nota1",i;
Leer nota1[i];
Hasta Que nota1[i]>=1 y nota1[i]<=10
Repetir
Escribir "ingrese nota2",i;
Leer nota2[i];
Hasta Que nota2[i]>=1 y nota2[i]<=10
Repetir
Escribir "ingrese nota3";
Leer nota3[i];
Hasta Que nota3[i]>=1 y nota3[i]<=10
promedio[i]<-(nota1[i]+nota2[i]+nota3[i])/3;
FinPara
Para i<-1 Hasta 2 Con Paso 1 Hacer
Escribir "alumno",i," ",alumno[i];
Escribir "el promedio es",i," ",promedio[i];
FinPara
FinProceso
EJERCICIO:8
Proceso numero
Escribir "ingrese numeros";
Leer num1;
Leer num2;
Si num1>num2 Entonces
Escribir " mayor es num1";
Sino
Si num2>num1 Entonces
Escribir "el mayor es num2";
Sino
Escribir " son iguales";
FinSi
FinSi
FinProceso

Más contenido relacionado

La actualidad más candente

7
77
6produc
6produc6produc
Wuiller mendez 18863086
Wuiller mendez 18863086Wuiller mendez 18863086
Wuiller mendez 18863086
wuiller mendez diaz
 
Tarea con switch case
Tarea con switch  caseTarea con switch  case
Tarea con switch case
MELISSA MORNEO
 
Ejercicios Practicos VB6 1a parte
Ejercicios Practicos VB6 1a parteEjercicios Practicos VB6 1a parte
Ejercicios Practicos VB6 1a parte
UVM
 
Algoritmos
AlgoritmosAlgoritmos
Cuadernillo de ejercicios
Cuadernillo de ejerciciosCuadernillo de ejercicios
Cuadernillo de ejercicios
karlaga2017
 
Deber de algoritmo.
Deber de algoritmo.Deber de algoritmo.
Deber de algoritmo.
Jeskin Javier Farfán Calazán
 
Ejercicio resuelto de competencia perfecta (función de oferta)
Ejercicio resuelto de competencia perfecta (función de oferta)Ejercicio resuelto de competencia perfecta (función de oferta)
Ejercicio resuelto de competencia perfecta (función de oferta)
Juan Carlos Aguado Franco
 

La actualidad más candente (9)

7
77
7
 
6produc
6produc6produc
6produc
 
Wuiller mendez 18863086
Wuiller mendez 18863086Wuiller mendez 18863086
Wuiller mendez 18863086
 
Tarea con switch case
Tarea con switch  caseTarea con switch  case
Tarea con switch case
 
Ejercicios Practicos VB6 1a parte
Ejercicios Practicos VB6 1a parteEjercicios Practicos VB6 1a parte
Ejercicios Practicos VB6 1a parte
 
Algoritmos
AlgoritmosAlgoritmos
Algoritmos
 
Cuadernillo de ejercicios
Cuadernillo de ejerciciosCuadernillo de ejercicios
Cuadernillo de ejercicios
 
Deber de algoritmo.
Deber de algoritmo.Deber de algoritmo.
Deber de algoritmo.
 
Ejercicio resuelto de competencia perfecta (función de oferta)
Ejercicio resuelto de competencia perfecta (función de oferta)Ejercicio resuelto de competencia perfecta (función de oferta)
Ejercicio resuelto de competencia perfecta (función de oferta)
 

Destacado

Основы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
Основы теории графов 01: напоминание определений, теорема Форда—ФалкерсонаОсновы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
Основы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
Alex Dainiak
 
Blitz 31 3-2014 "behov for gearskifte"
Blitz 31 3-2014 "behov for gearskifte"Blitz 31 3-2014 "behov for gearskifte"
Blitz 31 3-2014 "behov for gearskifte"
Frederik Funder Pedersen
 
Google apps教育版
Google apps教育版Google apps教育版
Google apps教育版
嘉義網路行銷部落
 
Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"
Frederik Funder Pedersen
 
Основы теории графов 09: раскраски планарных графов, совершенные графы
Основы теории графов 09: раскраски планарных графов, совершенные графыОсновы теории графов 09: раскраски планарных графов, совершенные графы
Основы теории графов 09: раскраски планарных графов, совершенные графы
Alex Dainiak
 
Seo搜尋行銷簡報
Seo搜尋行銷簡報Seo搜尋行銷簡報
Seo搜尋行銷簡報
嘉義網路行銷部落
 
Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"
Frederik Funder Pedersen
 

Destacado (7)

Основы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
Основы теории графов 01: напоминание определений, теорема Форда—ФалкерсонаОсновы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
Основы теории графов 01: напоминание определений, теорема Форда—Фалкерсона
 
Blitz 31 3-2014 "behov for gearskifte"
Blitz 31 3-2014 "behov for gearskifte"Blitz 31 3-2014 "behov for gearskifte"
Blitz 31 3-2014 "behov for gearskifte"
 
Google apps教育版
Google apps教育版Google apps教育版
Google apps教育版
 
Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"
 
Основы теории графов 09: раскраски планарных графов, совершенные графы
Основы теории графов 09: раскраски планарных графов, совершенные графыОсновы теории графов 09: раскраски планарных графов, совершенные графы
Основы теории графов 09: раскраски планарных графов, совершенные графы
 
Seo搜尋行銷簡報
Seo搜尋行銷簡報Seo搜尋行銷簡報
Seo搜尋行銷簡報
 
Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"Blitz 31 3-2014 "Behov for gearskifte"
Blitz 31 3-2014 "Behov for gearskifte"
 

Similar a Deber de progrmcion

Ejercicios propuestos ejemplos de diagrama de flujo y algoritmos
Ejercicios propuestos ejemplos de diagrama de flujo y algoritmosEjercicios propuestos ejemplos de diagrama de flujo y algoritmos
Ejercicios propuestos ejemplos de diagrama de flujo y algoritmos
fabiocelis
 
Estructuras de control
Estructuras de control Estructuras de control
Estructuras de control
addaza0
 
Clase y asignación
Clase y asignaciónClase y asignación
Clase y asignación
Krisna M. B. Ready S.
 
Ejercicios de arreglo
Ejercicios de arregloEjercicios de arreglo
Ejercicios de arreglo
Jose Manuel Lopez Castillo
 
Ejercicios pseint
Ejercicios pseintEjercicios pseint
Ejercicios pseint
Omar Landaeta
 
Diseño de algoritmos usando pseint
Diseño de algoritmos usando pseintDiseño de algoritmos usando pseint
Diseño de algoritmos usando pseint
Daniel Zavala
 
Algoritmos
AlgoritmosAlgoritmos
Algoritmos
janiergomez
 
Taller ejemplos de diagrama de flujo y algoritmos
Taller ejemplos de diagrama de flujo y algoritmosTaller ejemplos de diagrama de flujo y algoritmos
Taller ejemplos de diagrama de flujo y algoritmos
Oscar Rico Florez
 
Algoritmos
AlgoritmosAlgoritmos
Algoritmos
yenvasquez1
 
Taller de algoritmos n paula
Taller de algoritmos n paulaTaller de algoritmos n paula
Taller de algoritmos n paula
Yessika Castañeda
 
EJERCICIOS DE ALGORITMOS
EJERCICIOS DE ALGORITMOSEJERCICIOS DE ALGORITMOS
EJERCICIOS DE ALGORITMOS
1002pc3
 
Taller de algoritmos
Taller de algoritmosTaller de algoritmos
Taller de algoritmos
10-02
 
Taller de algoritmos
Taller de algoritmosTaller de algoritmos
Taller de algoritmos
10-02
 
Deber 01
Deber 01Deber 01
Deber 01
Hernán Cortés
 
FUNDAMENTOS DE PROGRAMACIÓN
FUNDAMENTOS DE PROGRAMACIÓNFUNDAMENTOS DE PROGRAMACIÓN
FUNDAMENTOS DE PROGRAMACIÓN
hernan_c
 
Ejercicios pseint omar web technology
Ejercicios pseint omar web technologyEjercicios pseint omar web technology
Ejercicios pseint omar web technology
Omar Landaeta
 
Ejercicios pseint omar web technology
Ejercicios pseint omar web technologyEjercicios pseint omar web technology
Ejercicios pseint omar web technology
Omar Landaeta
 
Alavaj
AlavajAlavaj
Alavaj
alavajo
 
Ejercicios pseudocodigo pse_int_regf
Ejercicios pseudocodigo pse_int_regfEjercicios pseudocodigo pse_int_regf
Ejercicios pseudocodigo pse_int_regf
Michael Corvent
 
Ejercicios pseudocodigo pse_int_rpc
Ejercicios pseudocodigo pse_int_rpcEjercicios pseudocodigo pse_int_rpc
Ejercicios pseudocodigo pse_int_rpc
Mario Padilla Mgp
 

Similar a Deber de progrmcion (20)

Ejercicios propuestos ejemplos de diagrama de flujo y algoritmos
Ejercicios propuestos ejemplos de diagrama de flujo y algoritmosEjercicios propuestos ejemplos de diagrama de flujo y algoritmos
Ejercicios propuestos ejemplos de diagrama de flujo y algoritmos
 
Estructuras de control
Estructuras de control Estructuras de control
Estructuras de control
 
Clase y asignación
Clase y asignaciónClase y asignación
Clase y asignación
 
Ejercicios de arreglo
Ejercicios de arregloEjercicios de arreglo
Ejercicios de arreglo
 
Ejercicios pseint
Ejercicios pseintEjercicios pseint
Ejercicios pseint
 
Diseño de algoritmos usando pseint
Diseño de algoritmos usando pseintDiseño de algoritmos usando pseint
Diseño de algoritmos usando pseint
 
Algoritmos
AlgoritmosAlgoritmos
Algoritmos
 
Taller ejemplos de diagrama de flujo y algoritmos
Taller ejemplos de diagrama de flujo y algoritmosTaller ejemplos de diagrama de flujo y algoritmos
Taller ejemplos de diagrama de flujo y algoritmos
 
Algoritmos
AlgoritmosAlgoritmos
Algoritmos
 
Taller de algoritmos n paula
Taller de algoritmos n paulaTaller de algoritmos n paula
Taller de algoritmos n paula
 
EJERCICIOS DE ALGORITMOS
EJERCICIOS DE ALGORITMOSEJERCICIOS DE ALGORITMOS
EJERCICIOS DE ALGORITMOS
 
Taller de algoritmos
Taller de algoritmosTaller de algoritmos
Taller de algoritmos
 
Taller de algoritmos
Taller de algoritmosTaller de algoritmos
Taller de algoritmos
 
Deber 01
Deber 01Deber 01
Deber 01
 
FUNDAMENTOS DE PROGRAMACIÓN
FUNDAMENTOS DE PROGRAMACIÓNFUNDAMENTOS DE PROGRAMACIÓN
FUNDAMENTOS DE PROGRAMACIÓN
 
Ejercicios pseint omar web technology
Ejercicios pseint omar web technologyEjercicios pseint omar web technology
Ejercicios pseint omar web technology
 
Ejercicios pseint omar web technology
Ejercicios pseint omar web technologyEjercicios pseint omar web technology
Ejercicios pseint omar web technology
 
Alavaj
AlavajAlavaj
Alavaj
 
Ejercicios pseudocodigo pse_int_regf
Ejercicios pseudocodigo pse_int_regfEjercicios pseudocodigo pse_int_regf
Ejercicios pseudocodigo pse_int_regf
 
Ejercicios pseudocodigo pse_int_rpc
Ejercicios pseudocodigo pse_int_rpcEjercicios pseudocodigo pse_int_rpc
Ejercicios pseudocodigo pse_int_rpc
 

Más de inti cord

Formato de proyecto
Formato de proyectoFormato de proyecto
Formato de proyecto
inti cord
 
RENACIMIENTO
RENACIMIENTORENACIMIENTO
RENACIMIENTO
inti cord
 
Civilizaciones mesopotamia y egipcia
Civilizaciones mesopotamia y egipciaCivilizaciones mesopotamia y egipcia
Civilizaciones mesopotamia y egipcia
inti cord
 
Incidencia de estados unidos en la guerra de viednma y el golfo pérsico
Incidencia de estados unidos en la guerra de viednma y el golfo pérsicoIncidencia de estados unidos en la guerra de viednma y el golfo pérsico
Incidencia de estados unidos en la guerra de viednma y el golfo pérsico
inti cord
 
Revolución de cuba
Revolución de cubaRevolución de cuba
Revolución de cuba
inti cord
 
Plutocracia y revolución juliana
Plutocracia y revolución julianaPlutocracia y revolución juliana
Plutocracia y revolución juliana
inti cord
 
Muro de berlin y pinochet
Muro de berlin y pinochet Muro de berlin y pinochet
Muro de berlin y pinochet
inti cord
 
La primera guerra mundial
La primera guerra mundialLa primera guerra mundial
La primera guerra mundial
inti cord
 
Ideologias dictaduras
Ideologias dictadurasIdeologias dictaduras
Ideologias dictaduras
inti cord
 
Segunda guerra mundial
Segunda guerra mundialSegunda guerra mundial
Segunda guerra mundial
inti cord
 
Civilizaciones antiguas china e india
Civilizaciones antiguas china e indiaCivilizaciones antiguas china e india
Civilizaciones antiguas china e india
inti cord
 
Colonización y conquista española
Colonización y conquista españolaColonización y conquista española
Colonización y conquista española
inti cord
 
La revolución industrial
La revolución industrialLa revolución industrial
La revolución industrial
inti cord
 
Muro de Berlín
Muro de BerlínMuro de Berlín
Muro de Berlín
inti cord
 
Revolucion francesa
Revolucion francesaRevolucion francesa
Revolucion francesa
inti cord
 
El imperio romano
El imperio romanoEl imperio romano
El imperio romano
inti cord
 
Esparta y Atenas
Esparta y Atenas Esparta y Atenas
Esparta y Atenas
inti cord
 
Independencia de haití
Independencia de haitíIndependencia de haití
Independencia de haití
inti cord
 
Guerra fria
Guerra friaGuerra fria
Guerra fria
inti cord
 
Gran colombia
Gran colombiaGran colombia
Gran colombia
inti cord
 

Más de inti cord (20)

Formato de proyecto
Formato de proyectoFormato de proyecto
Formato de proyecto
 
RENACIMIENTO
RENACIMIENTORENACIMIENTO
RENACIMIENTO
 
Civilizaciones mesopotamia y egipcia
Civilizaciones mesopotamia y egipciaCivilizaciones mesopotamia y egipcia
Civilizaciones mesopotamia y egipcia
 
Incidencia de estados unidos en la guerra de viednma y el golfo pérsico
Incidencia de estados unidos en la guerra de viednma y el golfo pérsicoIncidencia de estados unidos en la guerra de viednma y el golfo pérsico
Incidencia de estados unidos en la guerra de viednma y el golfo pérsico
 
Revolución de cuba
Revolución de cubaRevolución de cuba
Revolución de cuba
 
Plutocracia y revolución juliana
Plutocracia y revolución julianaPlutocracia y revolución juliana
Plutocracia y revolución juliana
 
Muro de berlin y pinochet
Muro de berlin y pinochet Muro de berlin y pinochet
Muro de berlin y pinochet
 
La primera guerra mundial
La primera guerra mundialLa primera guerra mundial
La primera guerra mundial
 
Ideologias dictaduras
Ideologias dictadurasIdeologias dictaduras
Ideologias dictaduras
 
Segunda guerra mundial
Segunda guerra mundialSegunda guerra mundial
Segunda guerra mundial
 
Civilizaciones antiguas china e india
Civilizaciones antiguas china e indiaCivilizaciones antiguas china e india
Civilizaciones antiguas china e india
 
Colonización y conquista española
Colonización y conquista españolaColonización y conquista española
Colonización y conquista española
 
La revolución industrial
La revolución industrialLa revolución industrial
La revolución industrial
 
Muro de Berlín
Muro de BerlínMuro de Berlín
Muro de Berlín
 
Revolucion francesa
Revolucion francesaRevolucion francesa
Revolucion francesa
 
El imperio romano
El imperio romanoEl imperio romano
El imperio romano
 
Esparta y Atenas
Esparta y Atenas Esparta y Atenas
Esparta y Atenas
 
Independencia de haití
Independencia de haitíIndependencia de haití
Independencia de haití
 
Guerra fria
Guerra friaGuerra fria
Guerra fria
 
Gran colombia
Gran colombiaGran colombia
Gran colombia
 

Deber de progrmcion

  • 1. DEBER DE PROGRAMACION INTEGRANTES: INTI CORDOVA JOSUE CADENA EJERCICIO:1 Proceso suma Escribir "ingrese valor A y B"; Leer A; Leer B; C<-(A+B)/3; Escribir "su valor es:",C; FinProceso EJERCICIO:2 Proceso numero_entero Escribir "ingrese numero entero"; Leer numero; cuadrado<-numero*numero; cubo<-numero*numero*numero; Escribir "el resultado del cuadrado es:",cuadrado; Escribir "el resultado del cubo es:", cubo; FinProceso EJERCICIO:3 Proceso valor_numerico Escribir "ingrese valor numerico"; Leer valr; Si valr>1 y valr<100 Entonces Escribir "positivo"; Sino Si valr>-100 y valr<-1 Entonces Escribir "negativo"; Sino Si valr=0 Entonces Escribir " 0 "; FinSi FinSi FinSi FinProceso EJERCICIO:4 Proceso vehiculo
  • 2. Escribir "ingrese precio del vehiculo"; Leer precio; ganancia<-precio /0.12 impuesto<-precio/0.6 Escribir "la ganancia del vendedor es:",ganancia,".....","el iumpuesto es de:",impuesto; costo<-ganacia+impuesto Escribir "el costo final del automovil es :",costo; FinProceso EJERCICIO:5 Proceso CALIFICACION Escribir "INGRESE NOTAS"; Escribir "N1"; Leer N1; Escribir "N2"; Leer N2; Escribir "N3"; Leer N3; suma<-(N1+N2+N3)/3; Escribir "PROMEDIO ES:",suma; FinProceso EJERCICIO:6 Proceso promedio_mayor Dimension alumno[2]; Dimension nota1[2]; Dimension nota2[2]; Dimension nota3[2]; Dimension promedio[2]; i<-0 Para i<-1 Hasta 2 Con Paso 1 Hacer Escribir "ingrese alumno",i; Leer alumno[i]; Repetir Escribir "ingrese nota1"; Leer nota1[i]; Hasta Que nota1[i]>=1 y nota1[i]<=10 Repetir Escribir "ingrese nota2";
  • 3. Leer nota2[i]; Hasta Que nota2[i]>=1 y nota2[i]<=10 Repetir Escribir "ingrese nota3"; Leer nota3[i]; Hasta Que nota3[i]>=1 y nota3[i]<=10 promedio[i]<-(nota1[i]+nota2[i]+nota3[i])/3; FinPara Para i<-1 Hasta 2 Con Paso 1 Hacer Escribir "alumno",i," ",alumno[i]; Si promedio[i]>=9 Entonces Escribir "el promedio es mayor ",i,": ",promedio[i]; Sino Si promedio[i]<=9 Entonces Escribir "el promedio es menor",i,": ",promedio[i]; Sino Escribir "otro"; FinSi FinSi FinPara FinProceso EJERCICIO:7 Proceso calificacion dimension Alumno[2] dimension nota1[2] dimension nota2[2] Dimension nota3[2]; dimension promedio[2] i<-0; Para i<-1 Hasta 2 Con Paso 1 Hacer Escribir "ingrese alumno",i; Leer alumno[i]; Repetir Escribir "ingrese nota1",i; Leer nota1[i]; Hasta Que nota1[i]>=1 y nota1[i]<=10 Repetir Escribir "ingrese nota2",i; Leer nota2[i]; Hasta Que nota2[i]>=1 y nota2[i]<=10 Repetir Escribir "ingrese nota3"; Leer nota3[i]; Hasta Que nota3[i]>=1 y nota3[i]<=10 promedio[i]<-(nota1[i]+nota2[i]+nota3[i])/3; FinPara
  • 4. Para i<-1 Hasta 2 Con Paso 1 Hacer Escribir "alumno",i," ",alumno[i]; Escribir "el promedio es",i," ",promedio[i]; FinPara FinProceso EJERCICIO:8 Proceso numero Escribir "ingrese numeros"; Leer num1; Leer num2; Si num1>num2 Entonces Escribir " mayor es num1"; Sino Si num2>num1 Entonces Escribir "el mayor es num2"; Sino Escribir " son iguales"; FinSi FinSi FinProceso