SlideShare una empresa de Scribd logo
OSPF                PART 1                                                                             packetlife.net
                            Protocol Header                                                   Attributes
                    8               16                   24              32                  Type Link-State
        Version            Type                     Length                             Algorithm Dijkstra
                                  Router ID                                                Metric Cost (Bandwidth)
                                   Area ID                                                      AD 110
               Checksum                    Instance ID        Reserved                  Standard RFC 2328, 2740
                                    Data                                               Protocols IP
                                                                                       Transport IP/89
                        Link State Advertisements
                                                                                Authentication Plaintext, MD5
Router Link (Type 1)
Lists neighboring routers and the cost to each; flooded within an area          AllSPF Address 224.0.0.5

Network Link (Type 2)                                                            AllDR Address 224.0.0.6
Generated by a DR; lists all routers on an adjacent segment; flooded
                                                                                           Metric Formula
within an area
Network Summary (Type 3)                                                                        100,000 Kbps*
                                                                                       cost =
Generated by an ABR and advertised among areas                                                    link speed
ASBR Summary (Type 4)
                                                                                                           * modifiable with
Injected by an ABR into the backbone to advertise the presence of an                   ospf auto-cost reference-bandwidth
ASBR within an area
External Link (Type 5)                                                                    Adjacency States
Generated by an ASBR and flooded throughout the AS to advertise a
                                                                              1 Down                 5 Exstart
route external to OSPF
NSSA External Link (Type 7)                                                   2 Attempt              6 Exchange
Generated by an ASBR in a not-so-stubby area; converted into a                3 Init                 7 Loading
type 5 LSA by the ABR when leaving the area
                                                                              4 2-Way                8 Full
         Router Types                               Area Types
                                                                                          DR/BDR Election
Internal Router                          Standard Area
All interfaces reside within the         Default OSPF area type                The DR serves as a common point for
same area                                                                     all adjacencies on a multiaccess
                                         Stub Area                            segment
Backbone Router                          External link (type 5) LSAs are
A router with an interface in            replaced with a default route         The BDR also maintains adjacencies
area 0 (the backbone)                                                         with all routers in case the DR fails
                                         Totally Stubby Area
Area Border Router (ABR)                 Type 3, 4, and 5 LSAs are             Election does not occur on point-to-
Connects two or more areas               replaced with a default route        point or multipoint links
AS Boundary Router (ASBR)                Not So Stubby Area (NSSA)
                                                                               Default priority (0-255) is 1; highest
Connects to additional routing           A stub area containing an ASBR;
                                                                              priority wins; 0 cannot be elected
domains; typically located in            type 5 LSAs are converted to type
the backbone                             7 within the area                      DR preemption will not occur unless
                                                                              the current DR is reset
                          External Route Types
E1   Cost to the advertising ASBR plus the external cost of the route                        Virtual Links

E2 (Default)      Cost of the route as seen by the ASBR                        Tunnel formed to join two areas
                                                                              across an intermediate
                            Troubleshooting
                                                                               Both end routers must share a
show ip [route | protocols]               show ip ospf border-routers         common area
show ip ospf interface                    show ip ospf virtual-links           At least one end must reside in area 0
show ip ospf neighbor                     debug ip ospf […]                    Cannot traverse stub areas

by Jeremy Stretch                                                                                                      v2.1
OSPF                   PART 2                                                                           packetlife.net
                                                           Network Types
                               Nonbroadcast        Multipoint          Multipoint
                               (NBMA)              Broadcast           Nonbroadcast     Broadcast        Point-to-Point

      DR/BDR Elected Yes                           No                  No               Yes              No
  Neighbor Discovery No                            Yes                 No               Yes              Yes
  Hello/Dead Timers 30/120                         30/120              30/120           10/40            10/40
                 Defined By RFC 2328               RFC 2328            Cisco            Cisco            Cisco
 Supported Topology Full Mesh                      Any                 Any              Full Mesh        Point-to-Point

                                                       Configuration Example

                                                                       interface Serial0/0                       Router A
    WAN                 Area 0                         Area 9           description WAN Link
 172.16.0.0/18          Backbone               Totally Stubby Area      ip address 172.16.34.2 255.255.255.252
                                                                       !
                                                                       interface FastEthernet0/0
                                                                        description Area 0
                                                                        ip address 192.168.0.1 255.255.255.0
                 A                                                     !
                                                                       interface Loopback0
                                                                       ! Used as router ID
                                                                        ip address 10.0.34.1 255.255.255.0
                                                   C                   !
                           B
                                                                       router ospf 100
                                                                        ! Advertising the WAN cloud to OSPF
                                                                        redistribute static subnets
                                                                        network 192.168.0.0 0.0.0.255 area 0
                                                                       !
           Area 1                    Area 2                            ! Static route to the WAN cloud
           Stub Area               Standard Area                       ip route 172.16.0.0 255.255.192.0 172.16.34.1

                                                            Router B                                              Router C
interface Ethernet0/0                                                  interface Ethernet0/0
 description Area 0                                                     description Area 9
 ip address 192.168.0.2 255.255.255.0                                   ip address 192.168.9.1 255.255.255.0
 ip ospf 100 area 0                                                     ip ospf 100 area 9
!                                                                      !
interface Ethernet0/1                                                  interface Ethernet0/1
 description Area 2                                                     description Area 2
 ip address 192.168.2.1 255.255.255.0                                   ip address 192.168.2.2 255.255.255.0
 ip ospf 100 area 2                                                     ip ospf 100 area 2
 ! Optional MD5 authentication configured                               ! Optional MD5 authentication configured
 ip ospf authentication message-digest                                  ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 FooBar                                ip ospf message-digest-key 1 md5 FooBar
 ! Give B priority in DR election                                       ! Give C second priority (BDR) in election
 ip ospf priority 100                                                   ip ospf priority 50
!                                                                      !
interface Ethernet0/2                                                  !
 description Area 1                                                    !
 ip address 192.168.1.1 255.255.255.0                                  !
 ip ospf 100 area 1                                                    !
!                                                                      !
interface Loopback0                                                    interface Loopback0
 ip address 10.0.34.2 255.255.255.0                                     ip address 10.0.34.3 255.255.255.0
!                                                                      !
router ospf 100                                                        router ospf 100
 ! Define area 1 as a stub area                                         ! Define area 9 as a totally stubby area
 area 1 stub                                                            area 9 stub no-summary
 ! Virtual link from area 0 to area 9                                   ! Virtual link from area 9 to area 0
 area 2 virtual-link 10.0.34.3                                          area 2 virtual-link 10.0.34.2


by Jeremy Stretch                                                                                                     v2.1

Más contenido relacionado

La actualidad más candente

Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...
 Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат... Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...
Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...Cisco Russia
 
4G troubleshooting
4G troubleshooting4G troubleshooting
4G troubleshootingThang Dang
 
Local connect node b
Local connect node bLocal connect node b
Local connect node bajus ady
 
83092299 rru3804-overview
83092299 rru3804-overview83092299 rru3804-overview
83092299 rru3804-overviewSerik123
 
Differences of the Cisco Operating Systems
Differences of the Cisco Operating SystemsDifferences of the Cisco Operating Systems
Differences of the Cisco Operating Systems美兰 曾
 
3 lte mac_rrc(조봉열)
3 lte mac_rrc(조봉열)3 lte mac_rrc(조봉열)
3 lte mac_rrc(조봉열)Dattaraj Pangam
 
01 Bts3900 System Structure
01 Bts3900 System Structure01 Bts3900 System Structure
01 Bts3900 System StructureAtif Mahmood
 
Options for time-sensitive networking for 5G fronthaul
Options for time-sensitive networking for 5G fronthaulOptions for time-sensitive networking for 5G fronthaul
Options for time-sensitive networking for 5G fronthaulADVA
 
FlexiMultiradio Instalacion V_0.2.pdf
FlexiMultiradio Instalacion V_0.2.pdfFlexiMultiradio Instalacion V_0.2.pdf
FlexiMultiradio Instalacion V_0.2.pdfALFREDOCARRASCALGUAR2
 
Huawei GSM Principles
Huawei GSM PrinciplesHuawei GSM Principles
Huawei GSM PrinciplesAchmad Fauzi
 
Huawei umts node b configuration principle
Huawei umts node b configuration principleHuawei umts node b configuration principle
Huawei umts node b configuration principleYaser Al-Abdali
 
Subrack and cabinet numbering rules
Subrack and cabinet numbering rulesSubrack and cabinet numbering rules
Subrack and cabinet numbering rulesKhawla Boulaares
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bullsSwapnil Kapate
 
Huawei sran site configration principles
Huawei sran site configration principlesHuawei sran site configration principles
Huawei sran site configration principlessiddharth singatiya
 
Huawei node b technical-description
Huawei node b technical-descriptionHuawei node b technical-description
Huawei node b technical-descriptionYasir Jami
 
Cs irat degradation due to physical channel failure
Cs irat degradation due to physical channel failureCs irat degradation due to physical channel failure
Cs irat degradation due to physical channel failurefateh-med
 

La actualidad más candente (20)

Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...
 Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат... Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...
Cisco ASR1000 - архитектура, использование в сети предприятия, развитие плат...
 
RF Antenna Planning
RF Antenna PlanningRF Antenna Planning
RF Antenna Planning
 
4G troubleshooting
4G troubleshooting4G troubleshooting
4G troubleshooting
 
Local connect node b
Local connect node bLocal connect node b
Local connect node b
 
83092299 rru3804-overview
83092299 rru3804-overview83092299 rru3804-overview
83092299 rru3804-overview
 
Differences of the Cisco Operating Systems
Differences of the Cisco Operating SystemsDifferences of the Cisco Operating Systems
Differences of the Cisco Operating Systems
 
3 lte mac_rrc(조봉열)
3 lte mac_rrc(조봉열)3 lte mac_rrc(조봉열)
3 lte mac_rrc(조봉열)
 
01 Bts3900 System Structure
01 Bts3900 System Structure01 Bts3900 System Structure
01 Bts3900 System Structure
 
LTE Optimization
LTE OptimizationLTE Optimization
LTE Optimization
 
Options for time-sensitive networking for 5G fronthaul
Options for time-sensitive networking for 5G fronthaulOptions for time-sensitive networking for 5G fronthaul
Options for time-sensitive networking for 5G fronthaul
 
FlexiMultiradio Instalacion V_0.2.pdf
FlexiMultiradio Instalacion V_0.2.pdfFlexiMultiradio Instalacion V_0.2.pdf
FlexiMultiradio Instalacion V_0.2.pdf
 
Huawei GSM Principles
Huawei GSM PrinciplesHuawei GSM Principles
Huawei GSM Principles
 
W04 Profinet in process automation - Pete Brown, Siemens
W04   Profinet in process automation - Pete Brown, SiemensW04   Profinet in process automation - Pete Brown, Siemens
W04 Profinet in process automation - Pete Brown, Siemens
 
Huawei umts node b configuration principle
Huawei umts node b configuration principleHuawei umts node b configuration principle
Huawei umts node b configuration principle
 
Subrack and cabinet numbering rules
Subrack and cabinet numbering rulesSubrack and cabinet numbering rules
Subrack and cabinet numbering rules
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bulls
 
Reverse IMD
Reverse IMDReverse IMD
Reverse IMD
 
Huawei sran site configration principles
Huawei sran site configration principlesHuawei sran site configration principles
Huawei sran site configration principles
 
Huawei node b technical-description
Huawei node b technical-descriptionHuawei node b technical-description
Huawei node b technical-description
 
Cs irat degradation due to physical channel failure
Cs irat degradation due to physical channel failureCs irat degradation due to physical channel failure
Cs irat degradation due to physical channel failure
 

Destacado (20)

23100136 mpls
23100136 mpls23100136 mpls
23100136 mpls
 
Voip basics
Voip basicsVoip basics
Voip basics
 
The itil foundation_certificate_syllabus (2) (1)
The itil foundation_certificate_syllabus (2) (1)The itil foundation_certificate_syllabus (2) (1)
The itil foundation_certificate_syllabus (2) (1)
 
Ios zone based-firewall
Ios zone based-firewallIos zone based-firewall
Ios zone based-firewall
 
TCP Filtering on ASA
TCP Filtering on ASATCP Filtering on ASA
TCP Filtering on ASA
 
Dev + Ops + Azure = VL
Dev + Ops + Azure = VLDev + Ops + Azure = VL
Dev + Ops + Azure = VL
 
I pv6
I pv6I pv6
I pv6
 
Packet Inspection on ASA
Packet Inspection on ASAPacket Inspection on ASA
Packet Inspection on ASA
 
Fit nessecheatsheet
Fit nessecheatsheetFit nessecheatsheet
Fit nessecheatsheet
 
Acl
AclAcl
Acl
 
Ios i pv4_access_lists
Ios i pv4_access_listsIos i pv4_access_lists
Ios i pv4_access_lists
 
I pv4 multicast
I pv4 multicastI pv4 multicast
I pv4 multicast
 
Eigrp
EigrpEigrp
Eigrp
 
Nat
NatNat
Nat
 
QoS Cheatsheet by packetlife.net
QoS Cheatsheet by packetlife.netQoS Cheatsheet by packetlife.net
QoS Cheatsheet by packetlife.net
 
I psec
I psecI psec
I psec
 
Ios interior routing_protocols
Ios interior routing_protocolsIos interior routing_protocols
Ios interior routing_protocols
 
Frame mode mpls
Frame mode mplsFrame mode mpls
Frame mode mpls
 
vPC_Final
vPC_FinalvPC_Final
vPC_Final
 
Cheatsheet: Metasploit
Cheatsheet: MetasploitCheatsheet: Metasploit
Cheatsheet: Metasploit
 

Similar a Ospf

Ospf infografia
Ospf infografiaOspf infografia
Ospf infografiaw78ww
 
Networking Basics OSPF
Networking Basics OSPFNetworking Basics OSPF
Networking Basics OSPFHassan Tariq
 
Ospf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationOspf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationIT Tech
 
Routing and OSPF
Routing and OSPFRouting and OSPF
Routing and OSPFarpit
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf CiscoAlp isik
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccnarobertoxe
 
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptMenggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptRochmadGSaputra
 
OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)NetProtocol Xpert
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsAlejandro Marin
 
Designated & Backup Designated Router
Designated & Backup Designated RouterDesignated & Backup Designated Router
Designated & Backup Designated RouterNetProtocol Xpert
 
Dynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFDynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFAtakan ATAK
 

Similar a Ospf (20)

Ospf infografia
Ospf infografiaOspf infografia
Ospf infografia
 
Networking Basics OSPF
Networking Basics OSPFNetworking Basics OSPF
Networking Basics OSPF
 
Allwyn ospf ppt
Allwyn ospf pptAllwyn ospf ppt
Allwyn ospf ppt
 
Ospf
OspfOspf
Ospf
 
Ospf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationOspf and eigrp concepts and configuration
Ospf and eigrp concepts and configuration
 
Routing and OSPF
Routing and OSPFRouting and OSPF
Routing and OSPF
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf Cisco
 
OSPF Fundamental
OSPF FundamentalOSPF Fundamental
OSPF Fundamental
 
Ospf routing protocol
Ospf routing protocolOspf routing protocol
Ospf routing protocol
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptMenggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
 
ospf.ppt
ospf.pptospf.ppt
ospf.ppt
 
OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Designated & Backup Designated Router
Designated & Backup Designated RouterDesignated & Backup Designated Router
Designated & Backup Designated Router
 
Dynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFDynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPF
 
Day 12.2 enablingospf
Day 12.2 enablingospfDay 12.2 enablingospf
Day 12.2 enablingospf
 
OSPF - Copie.pptx
OSPF - Copie.pptxOSPF - Copie.pptx
OSPF - Copie.pptx
 
Ospf
OspfOspf
Ospf
 

Más de Swapnil Kapate (20)

Training development382
Training development382Training development382
Training development382
 
E governance
E governanceE governance
E governance
 
D2014082010
D2014082010D2014082010
D2014082010
 
Cloud computing e gov-12
Cloud computing e gov-12Cloud computing e gov-12
Cloud computing e gov-12
 
Cctns trg syllabus
Cctns trg syllabusCctns trg syllabus
Cctns trg syllabus
 
Advanced troubleshooting
Advanced troubleshootingAdvanced troubleshooting
Advanced troubleshooting
 
Ccna read
Ccna readCcna read
Ccna read
 
certificate
certificatecertificate
certificate
 
Networking
NetworkingNetworking
Networking
 
Ip addressing and subnetting instructors workbook
Ip addressing and subnetting   instructors workbookIp addressing and subnetting   instructors workbook
Ip addressing and subnetting instructors workbook
 
Vla ns
Vla nsVla ns
Vla ns
 
Tcpdump
TcpdumpTcpdump
Tcpdump
 
Spanning tree
Spanning treeSpanning tree
Spanning tree
 
Scapy
ScapyScapy
Scapy
 
Rip
RipRip
Rip
 
Qo s
Qo sQo s
Qo s
 
Ppp
PppPpp
Ppp
 
Physical terminations
Physical terminationsPhysical terminations
Physical terminations
 
Media wiki
Media wikiMedia wiki
Media wiki
 
Markdown
MarkdownMarkdown
Markdown
 

Ospf

  • 1. OSPF PART 1 packetlife.net Protocol Header Attributes 8 16 24 32 Type Link-State Version Type Length Algorithm Dijkstra Router ID Metric Cost (Bandwidth) Area ID AD 110 Checksum Instance ID Reserved Standard RFC 2328, 2740 Data Protocols IP Transport IP/89 Link State Advertisements Authentication Plaintext, MD5 Router Link (Type 1) Lists neighboring routers and the cost to each; flooded within an area AllSPF Address 224.0.0.5 Network Link (Type 2) AllDR Address 224.0.0.6 Generated by a DR; lists all routers on an adjacent segment; flooded Metric Formula within an area Network Summary (Type 3) 100,000 Kbps* cost = Generated by an ABR and advertised among areas link speed ASBR Summary (Type 4) * modifiable with Injected by an ABR into the backbone to advertise the presence of an ospf auto-cost reference-bandwidth ASBR within an area External Link (Type 5) Adjacency States Generated by an ASBR and flooded throughout the AS to advertise a 1 Down 5 Exstart route external to OSPF NSSA External Link (Type 7) 2 Attempt 6 Exchange Generated by an ASBR in a not-so-stubby area; converted into a 3 Init 7 Loading type 5 LSA by the ABR when leaving the area 4 2-Way 8 Full Router Types Area Types DR/BDR Election Internal Router Standard Area All interfaces reside within the Default OSPF area type The DR serves as a common point for same area all adjacencies on a multiaccess Stub Area segment Backbone Router External link (type 5) LSAs are A router with an interface in replaced with a default route The BDR also maintains adjacencies area 0 (the backbone) with all routers in case the DR fails Totally Stubby Area Area Border Router (ABR) Type 3, 4, and 5 LSAs are Election does not occur on point-to- Connects two or more areas replaced with a default route point or multipoint links AS Boundary Router (ASBR) Not So Stubby Area (NSSA) Default priority (0-255) is 1; highest Connects to additional routing A stub area containing an ASBR; priority wins; 0 cannot be elected domains; typically located in type 5 LSAs are converted to type the backbone 7 within the area DR preemption will not occur unless the current DR is reset External Route Types E1 Cost to the advertising ASBR plus the external cost of the route Virtual Links E2 (Default) Cost of the route as seen by the ASBR Tunnel formed to join two areas across an intermediate Troubleshooting Both end routers must share a show ip [route | protocols] show ip ospf border-routers common area show ip ospf interface show ip ospf virtual-links At least one end must reside in area 0 show ip ospf neighbor debug ip ospf […] Cannot traverse stub areas by Jeremy Stretch v2.1
  • 2. OSPF PART 2 packetlife.net Network Types Nonbroadcast Multipoint Multipoint (NBMA) Broadcast Nonbroadcast Broadcast Point-to-Point DR/BDR Elected Yes No No Yes No Neighbor Discovery No Yes No Yes Yes Hello/Dead Timers 30/120 30/120 30/120 10/40 10/40 Defined By RFC 2328 RFC 2328 Cisco Cisco Cisco Supported Topology Full Mesh Any Any Full Mesh Point-to-Point Configuration Example interface Serial0/0 Router A WAN Area 0 Area 9 description WAN Link 172.16.0.0/18 Backbone Totally Stubby Area ip address 172.16.34.2 255.255.255.252 ! interface FastEthernet0/0 description Area 0 ip address 192.168.0.1 255.255.255.0 A ! interface Loopback0 ! Used as router ID ip address 10.0.34.1 255.255.255.0 C ! B router ospf 100 ! Advertising the WAN cloud to OSPF redistribute static subnets network 192.168.0.0 0.0.0.255 area 0 ! Area 1 Area 2 ! Static route to the WAN cloud Stub Area Standard Area ip route 172.16.0.0 255.255.192.0 172.16.34.1 Router B Router C interface Ethernet0/0 interface Ethernet0/0 description Area 0 description Area 9 ip address 192.168.0.2 255.255.255.0 ip address 192.168.9.1 255.255.255.0 ip ospf 100 area 0 ip ospf 100 area 9 ! ! interface Ethernet0/1 interface Ethernet0/1 description Area 2 description Area 2 ip address 192.168.2.1 255.255.255.0 ip address 192.168.2.2 255.255.255.0 ip ospf 100 area 2 ip ospf 100 area 2 ! Optional MD5 authentication configured ! Optional MD5 authentication configured ip ospf authentication message-digest ip ospf authentication message-digest ip ospf message-digest-key 1 md5 FooBar ip ospf message-digest-key 1 md5 FooBar ! Give B priority in DR election ! Give C second priority (BDR) in election ip ospf priority 100 ip ospf priority 50 ! ! interface Ethernet0/2 ! description Area 1 ! ip address 192.168.1.1 255.255.255.0 ! ip ospf 100 area 1 ! ! ! interface Loopback0 interface Loopback0 ip address 10.0.34.2 255.255.255.0 ip address 10.0.34.3 255.255.255.0 ! ! router ospf 100 router ospf 100 ! Define area 1 as a stub area ! Define area 9 as a totally stubby area area 1 stub area 9 stub no-summary ! Virtual link from area 0 to area 9 ! Virtual link from area 9 to area 0 area 2 virtual-link 10.0.34.3 area 2 virtual-link 10.0.34.2 by Jeremy Stretch v2.1