Se ha denunciado esta presentación.
Utilizamos tu perfil de LinkedIn y tus datos de actividad para personalizar los anuncios y mostrarte publicidad más relevante. Puedes cambiar tus preferencias de publicidad en cualquier momento.

Ejercicios de arreglo

  • Sé el primero en comentar

Ejercicios de arreglo

  1. 1. UNIVERSIDAD NACIONAL EXPERIMENTAL DE LOS LLANOS OCCIDENTALES “EZEQUIEL ZAMORA” UNELLEZ-BARINAS Bachilleres: Profesor:Beiker Jaimes Juan LayaLópez José ManuelGénesis CamachoZabaleta José
  2. 2. EJERCICIO -01://Calcular el promedio de 50 valores almacenados en un vector. Determinar además//cuantos son mayores que el promedio, imprimir el promedio, el numero de datos//mayores que el promedio y una lista de valores mayores que el promedio.Proceso Arreglos_Ejercicio01 Limite<-5; J<-1; ConNumMayor<-0; SumaNum<-0; Dimension VectorA[Limite]; Dimension MayorAPromerio[Limite]; Para I<-1 Hasta Limite Hacer Escribir "Indique los Valores del Vector A:"; Leer Valor; VectorA[I]<-Valor; SumaNum<-SumaNum + Valor; FinPara Promedio<-SumaNum/Limite; Para I<-1 Hasta Limite Hacer Si VectorA[I]>Promedio Entonces ConNumMayor<-ConNumMayor+1; MayorAPromerio[J]<-VectorA[I]; J<-J+1; FinSi FinPara Escribir "El Promedio es: ",Promedio; Escribir "La Cantidad de Numeros Mayorsal Promedio es: ", ConNumMayor; Escribir "Los Numeros por Encima del Promedio son:"; J<-J-1;
  3. 3. Para I<-1 Hasta J Hacer Escribir MayorAPromerio[I]; FinParaFinProceso
  4. 4. EJERCICIO -02://Llenar dos vectores A y B de 45 elementos cada uno, sumar el elemento uno del vector//A con el elemento uno del vector B y así sucesivamente hasta 45, almacenar el//resultado en un vector C, e imprimir el vector resultante.Proceso Arreglos_Ejercicio02 L<-5; Dimension VA[L]; Dimension VB[L]; Dimension VC[L]; Para I<-1 Hasta L Hacer Escribir "Diga los Valores del Vector A:"; Leer V; VA[I]<-V; FinPara Para I<-1 Hasta L Hacer Escribir "Escriba los Valores del Vector B:"; Leer V; VB[I]<-V; FinPara Para I<-1 Hasta L Hacer VC[I]<-VA[I]+VB[I]; Escribir "El Resultado de la Posicion ", I," es: ",VC[I]; FinParaFinProceso
  5. 5. EJERCICIO -03://Llenar dos vectores A y B de 45 elementos cada uno, sumar el elemento uno del vector//A con el elemento uno del vector B y así sucesivamente hasta 45, almacenar el//resultado en un vector C, e imprimir el vector resultante.Proceso Arreglos_Ejercicio02 L<-5; Dimension VA[L]; Dimension VB[L]; Dimension VC[L]; Para I<-1 Hasta L Hacer Escribir "Diga los Valores del Vector A:"; Leer V; VA[I]<-V; FinPara Para I<-1 Hasta L Hacer Escribir "Escriba los Valores del Vector B:"; Leer V; VB[I]<-V; FinPara Para I<-1 Hasta L Hacer VC[I]<-VA[I]+VB[I]; Escribir "El Resultado de la Posicion ", I," es: ",VC[I]; FinParaFinProceso
  6. 6. EJERCICIO -04://Almacenar 500 números en un vector, elevar al cuadrado cada valor almacenado en el//vector, almacenar el resultado en otro vector. Imprimir el vector original y el vector//resultante.Proceso Arreglos_Ejercicio04 L<-3; Dimension VA[L]; Dimension VB[L]; Para I<-1 Hasta L Hacer Escribir "Indique los Valores del Vector A:"; Leer V; VA[I]<-V; FinPara Para I<-1 Hasta L Hacer VB[I]<-VA[I]^2; FinPara Para I<-1 Hasta L Hacer Escribir VA[I]," al cuadrado = ",VB[I]; FinParaFinProceso
  7. 7. EJERCICIO -05:/ /Almacenar 300 números en un vector, imprimir cuantos son ceros, cuantos son//negativos, cuantos positivos. Imprimir además la suma de los negativos y la suma de los//positivos.Proceso Arreglo_Ejercicio05 L<-5; CP<-0; CN<-0; AP<-0; AN<-0; C0<-0; Dimension VA[L]; Para I<-1 Hasta L Hacer Escribir "Escriba los Valores del Vector:"; Leer V; VA[I]<-V; FinPara Para I<-1 Hasta L Hacer Si VA[I]= 0 Entonces C0<-C0+1; FinSi Si VA[I]> 0 Entonces CP<-CP+1; AP<-AP + VA[I]; FinSi Si VA[I]< 0 Entonces CN<-CN+1; AN<-AN + VA[I]; FinSi FinPara
  8. 8. Escribir "Total de 0: ", C0; Escribir "Total de numeros +: ", CP; Escribir "Total Suma de +: ", AP; Escribir "Total de numeros -: ", CN; Escribir "Total Suma de -: ", AN;FinProceso
  9. 9. EJERCICIO -06://Almacenar 150 números en un vector, almacenarlos en otro vector en orden inverso al//vector original e imprimir el vector resultante.Proceso Arreglos_Ejercicio06 L<-5; Dimension VA[L]; Dimension VB[L]; Para I<-1 Hasta L Hacer Escribir "Escriba los Valores del Vector:"; Leer V; VA[I]<-V; FinPara a<-L; I<-1; Mientras a>0 Hacer VB[I]<-VA[a]; I<-I+1; a<-a-1; FinMientras Para I<-1 Hasta L Hacer Escribir VA[I], " -> ", VB[I]; FinParaFinProceso
  10. 10. EJERCICIO -07:Proceso vectotermnDimension m[100],n[100];para i<-1 hasta 100 HacerEscribir "ingrese valor en la posicion ",i," del vector M";leer m[i];Escribir "ingrese valor en la posicion ",i," del vector N";leer n[i];FinParai<-1;Mientras i<=100 hacersi m[i]<>n[i] entoncesi<-102;sinoi<-i+1;FinSiFinMientrassi i=101 EntoncesEscribir "Iguales";SinoEscribir "Diferentes";FinSiFinProceso
  11. 11. EJERCICIO -08://Diseñe un algoritmo que lea un numero cualquiera y lo busque en el vector X, el cual//tiene almacenados 80 elementos. Escribir la posición donde se encuentra almacenado el//numero en el vector o el mensaje “NO” si no lo encuentra. Búsqueda secuencial.Proceso Arreglos_Ejercicio09 L<-5; c<-0; Dimension VX[L]; VX[1]<-10; VX[2]<-12; VX[3]<-18; VX[4]<-5; VX[5]<-11; Escribir "Indique un Numero:"; Leer V; Para I<-1 Hasta L Hacer Si VX[I]=V Entonces Escribir "Ese Numero se Encuetra en la Posicion: ", I; c<-c+1; Sino c<-c+0; FinSi FinPara Si c=0 Entonces Escribir "NO"; FinSiFinProceso
  12. 12. EJERCICIO -09://Diseñe un algoritmo que lea un numero cualquiera y lo busque en el vector X, el cual//tiene almacenados 80 elementos. Escribir la posición donde se encuentra almacenado el//numero en el vector o el mensaje “NO” si no lo encuentra. Búsqueda secuencial.Proceso Arreglos_Ejercicio09 L<-5; c<-0; Dimension VX[L]; VX[1]<-10; VX[2]<-12; VX[3]<-18; VX[4]<-5; VX[5]<-11; Escribir "Indique un Numero:"; Leer V; Para I<-1 Hasta L Hacer Si VX[I]=V Entonces Escribir "Ese Numero se Encuetra en la Posicion: ", I; c<-c+1; Sino c<-c+0; FinSi FinPara Si c=0 Entonces Escribir "NO"; FinSiFinProceso
  13. 13. EJERCICIO -10://Diseñe un algoritmo que lea dos vectores A y B de 20 elementos cada uno y multiplique//el primer elemento de A con el ultimo elemento de B y luego el segundo elemento de A//por el diecinueveavo elemento de B y así sucesivamente hasta llegar al veinteavo//elemento de A por el primer elemento de B. El resultado de la multiplicación//almacenarlo en un vector C.Proceso Arreglos_Ejercicio10 L<-5; Dimension VA[L]; Dimension VB[L]; Dimension VC[L]; Para I<-1 Hasta L Hacer Escribir "Indique los Valores del Vector A:"; Leer V; VA[I]<-V; FinPara Para I<-1 Hasta L Hacer Escribir "Indique los Valores del Vector B:"; Leer V; VB[I]<-V; FinPara a<-L; I<-1; Mientras a>0 Hacer VC[I]<-VA[I]*VB[a]; Escribir VA[I]," * ",VB[a]," = ",VC[I]; I<-I+1; a<-a-1; FinMientrasFinProceso
  14. 14. EJERCICIO -11://Diseñe un algoritmo que almacene en un vector llamado FIB[100] los 100 primeros//números de la serie fibonacci.Proceso Arreglos_Ejercicio11 A<-0; B<-1; c<-0; Limite<-10; Dimension Vector[Limite]; Para K<-1 Hasta Limite Hacer c<-A+B; A<-B; B<-C; Vector[K]<-C; Escribir Vector[K]; FinParaFinProceso

×