Informe De Programa De Encuesta
Maestro: David Elvir
Asignatura: Programación
Integrantes
Sarahi Magdalena Cerna Valle
Áng...
Días De Reunión
Martes 27/10/15
De las 9:30 a las 11:30
Empezamos asiendo el programa de visual Basic 6.0 este
programa no...
Codificación En Visual Basic 6.0
Codificación En Pseint
Diagrama de flujo
V.B.6.0
Dim IntR As Integer
Dim IntA As Integer
Dim IntB As Integer
Dim IntAA As Integer
Dim IntBB As Integer
Private Sub ...
IntAA = Val(TxtAA.Text)
IntBB = Val(TxtBB.Text)
Select Case IntAA Or IntBB
Case Is <= 0
MsgBox "Debe De Contener Valores N...
MsgBox "Y El Resultado Es: " & "" & TxtR, vbInformation,
"Resultado"
End Select
End Sub
Private Sub Command2_Click()
MsgBo...
Pseint
Proceso EncuestaTelevisores
Resp<-'s'
Mientras Resp=='s'o Resp=='S' Hacer
SiPregunta1<-0;
SiPregunta2<-0;
SiPregunt...
Escribir "1. Si";
Escribir "2. No";
Leer OP;
Si OP = 1 Entonces
SiPregunta2<-SiPregunta2+1;
FinSi
Escribir "Piensa Comprar...
Escribir "El ",PorcentajePregunta3," por ciento Si Lo Ba
A Comprar";
Escribir "El ",PorcentajePregunta4," por ciento No Lo...
Próxima SlideShare
Cargando en…5
×

Informe de programa de encuesta

52 visualizaciones

Publicado el

Tarea De info

Publicado en: Educación
0 comentarios
0 recomendaciones
Estadísticas
Notas
  • Sé el primero en comentar

  • Sé el primero en recomendar esto

Sin descargas
Visualizaciones
Visualizaciones totales
52
En SlideShare
0
De insertados
0
Número de insertados
3
Acciones
Compartido
0
Descargas
0
Comentarios
0
Recomendaciones
0
Insertados 0
No insertados

No hay notas en la diapositiva.

Informe de programa de encuesta

  1. 1. Informe De Programa De Encuesta Maestro: David Elvir Asignatura: Programación Integrantes Sarahi Magdalena Cerna Valle Ángel Reynel Medina Martínez Edwar Fernando Romero Sánchez Junior Armando Alvarado Mendoza
  2. 2. Días De Reunión Martes 27/10/15 De las 9:30 a las 11:30 Empezamos asiendo el programa de visual Basic 6.0 este programa nos tomó todo el tiempo de reunión de este día. Miércoles 28/10/15 De las 9:40 a las 11:30 Empezamos a ser el programa en pseint un programa que no costó mucho tiempo un programa que tenía que ser repetitivo. Jueves 30/10/15 De las 9:30 a las 11:40 Arreglamos unos detalles de los programas anteriores y empezamos a ser este informe no muy grande pero detalla lo que hicimos en estos días.
  3. 3. Codificación En Visual Basic 6.0
  4. 4. Codificación En Pseint
  5. 5. Diagrama de flujo
  6. 6. V.B.6.0 Dim IntR As Integer Dim IntA As Integer Dim IntB As Integer Dim IntAA As Integer Dim IntBB As Integer Private Sub Command1_Click() IntA = Val(TxtA.Text) IntB = Val(TxtB.Text) Select Case IntA Or IntB Case Is <= 0 MsgBox "Debe De Contener Valores Numericos O Mayores A Cero" Case Is > 0 LblResultado = TxtA LblResultado = TxtB MsgBox "Tiene Tantos Televisores: " & "" & TxtA, vbInformation, "Encuesta" MsgBox "Son A Color: " & "" & TxtB, vbInformation, "Encuesta" Case Else MsgBox "Hay Casillas Vacias" End Select
  7. 7. IntAA = Val(TxtAA.Text) IntBB = Val(TxtBB.Text) Select Case IntAA Or IntBB Case Is <= 0 MsgBox "Debe De Contener Valores Numericos O Mayores A Cero" Case Is > 0 LblResultadoo = TxtAA LblResultadoo = TxtBB MsgBox "No Tiene Televisores: " & "" & TxtAA, vbInformation, "Encuesta" MsgBox "No Son A Color: " & "" & TxtBB, vbInformation, "Encuesta" Case Else MsgBox "Hay Casillas Vacias" End Select Select Case IntB Or IntBB Case Is > 0 TxtR = IntB + IntBB TxtR.Text = TxtR Case Is <= 0
  8. 8. MsgBox "Y El Resultado Es: " & "" & TxtR, vbInformation, "Resultado" End Select End Sub Private Sub Command2_Click() MsgBox "Seguro Que Desea Salir", vbInformation, "Gracias" End End Sub Private Sub Command3_Click() TxtA.Text= "" TxtB.Text = "" Text3.Text = "" TxtAA.Text= "" TxtBB.Text= "" Text6.Text = "" LblResultado.Caption = "" LblResultadoo.Caption = "" TxtR = "" End Sub
  9. 9. Pseint Proceso EncuestaTelevisores Resp<-'s' Mientras Resp=='s'o Resp=='S' Hacer SiPregunta1<-0; SiPregunta2<-0; SiPregunta3<-0; PorcentajePregunta1<-0; PorcentajePregunta2<-0; PorcentajePregunta3<-0; i<-0; Escribir "Ingrese el numero de personas a encuestar"; Leer NP; Para i<-1 HastaNP Con Paso 1 Hacer Escribir "Tienen Television O No Tienen:" Escribir "1. Si"; Escribir "2. No"; Leer OP; Si OP = 1 Entonces SiPregunta1<-SiPregunta1+1; FinSi Escribir "Es En Color O No Es En Color:"
  10. 10. Escribir "1. Si"; Escribir "2. No"; Leer OP; Si OP = 1 Entonces SiPregunta2<-SiPregunta2+1; FinSi Escribir "Piensa Comprarlos O No:" Escribir "1. Si"; Escribir "2. No"; Leer OP; Si OP = 1 Entonces SiPregunta3<-SiPregunta3+1; FinSi FinPara PorcentajePregunta1<-(SiPregunta1/NP)*100; PorcentajePregunta2<-(SiPregunta2/NP)*100; PorcentajePregunta3<-(SiPregunta3/NP)*100; PorcentajePregunta4<-(SiPregunta0/NP)*0; Escribir "Las personas encuestadas son ",NP; Escribir "El ",PorcentajePregunta1," por ciento Tiene Televisor"; Escribir "El ",PorcentajePregunta2," por ciento Es De Color";
  11. 11. Escribir "El ",PorcentajePregunta3," por ciento Si Lo Ba A Comprar"; Escribir "El ",PorcentajePregunta4," por ciento No Lo Ba A Comprar"; Escribir 'Desea Hacer Otra Encuesta (S/N):' Leer Resp FinMientras FinProceso

×