EJERCICIOS DE ALGORITMOS<br />LORENA RODRIGUEZ<br />DILA FERNANDA VEIRA<br />YENNI PAOLA YAÑEZ<br />1002<br />IET@G<br />
1.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. PROGRAMA contador1 ENTORNO: c <- 0 ALGORITMO: Borrar_pantal...
2.-Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden decreciente. 1. PROGRAMA contador2 2. ENTORNO: 3. ...
3.-Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100. 1. PROGRAMA pares 2. ENTORNO: 3. c <- 2 4. ALGORITMO...
4.-Hacer un programa que imprima la suma de los 100 primeros numeros. 1. PROGRAMA suma 2. ENTORNO: 3. c <- 1 4. suma <- 0 ...
5.-Hacer un pseudocódigo que imprima los numeros impares hasta el 100 y que imprima cuantos impares hay. 1. PROGRAMA impar...
6.-Hacer un pseudocodigo que imprima todos los numeros naturales que hay desde la unidad hasta un numero que introducimos ...
7.-Introducir tantas frases como queramos y contarlas. 1. PROGRAMA frases 2. ENTORNO: 3. res <- "S" 4. frase <- Espacios( ...
8.-Hacer un pseudocodigo que solo nos permita introducir S o N. 1. PROGRAMA sn 2. ENTORNO: 3. res <- " " 4. ALGORITMO: 5. ...
9.-Introducir un numero por teclado. Que nos diga si es positivo o negativo. 1. PROGRAMA signo 2. ENTORNO: 3. num<- 0 4. A...
10.-Introducir un numero por teclado. Que nos diga si es par o impar. 1. PROGRAMA paridad 2. ENTORNO: 3. num<- 0 4. ALGORI...
11.-Imprimir y contar los multiplos de 3 desde la unidad hasta un numero que introducimos por teclado. 1. PROGRAMA multipl...
12.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. Que calcule la  suma de todos los numeros pares por un lad...
13.-Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre 1 y 100. <br />1. PROGRAMA multiplo_2_3 2. E...
14.-.-Hacer un programa que calcule independientemente la suma de los pares y  los impares de los numeros entre 1 y 1000, ...
15.-Imprimir diez veces la serie de numeros del 1 al 10. 1. PROGRAMA diez 2. ENTORNO: 3. serie <- 0 4. ALGORITMO: 5. Borra...
16.-Hacer un pseudocodigo que imprima el mayor y el menor de una serie de cinco numeros que vamos introduciendo por teclad...
17.-Hacer un pseudocodigo que simule el funcionamiento de un reloj digital y  que permita ponerlo en hora. 1. PROGRAMA rel...
18.-Calcular el factorial de un numero.1. PROGRAMA factorial 2. ENTORNO: 3. res <- "S" 4. ALGORITMO: 5. MIENTRAS res = "S"...
19.-Hacer un programa que calcule independientemente la suma de los pares y  los impares de los numeros entre 1 y 1000, ut...
20.-Introducir una frase por teclado. Imprimirla cinco veces en filas consecutivas, pero cada impresion ir desplazada cuat...
21.-Hacer un pseudocodigo que imprima los n£meros del 0 al 100, controlando  las filas y las columnas. 1. PROGRAMA numeros...
22.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla. 1. PROGRAMA centro 2. ENTORNO: 3. res <- "S"...
23.-Realizar la tabla de multiplicar de un numero entre 0 y 10. 1. PROGRAMA tabla 2. ENTORNO: 3. num<- -1 4. ALGORITMO: 5....
24.-Simular el lanzamiento de una moneda al aire e imprimir si ha salido cara o cruz. 1. PROGRAMA moneda 2. ENTORNO: 3. re...
29.-Simular cien tiradas de dos dados y contar las veces que entre los dos  suman 10. 1. PROGRAMA dado 2. ENTORNO: 3. c <-...
Próxima SlideShare
Cargando en…5
×

Ejercicios de algoritmos

24.057 visualizaciones

Publicado el

LORENA RODRIGUEZ
DILA FERNANDA VEIRA
YENNI PAOLA YAÑEZ
1002

Publicado en: Tecnología
0 comentarios
1 recomendación
Estadísticas
Notas
  • Sé el primero en comentar

Sin descargas
Visualizaciones
Visualizaciones totales
24.057
En SlideShare
0
De insertados
0
Número de insertados
789
Acciones
Compartido
0
Descargas
235
Comentarios
0
Recomendaciones
1
Insertados 0
No insertados

No hay notas en la diapositiva.

Ejercicios de algoritmos

  1. 1. EJERCICIOS DE ALGORITMOS<br />LORENA RODRIGUEZ<br />DILA FERNANDA VEIRA<br />YENNI PAOLA YAÑEZ<br />1002<br />IET@G<br />
  2. 2. 1.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. PROGRAMA contador1 ENTORNO: c <- 0 ALGORITMO: Borrar_pantalla( ) MIENTRAS c < 101 HACER ESCRIBIR c c <- c + 1 FINMIENTRAS FINPROGRAMA <br />
  3. 3. 2.-Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden decreciente. 1. PROGRAMA contador2 2. ENTORNO: 3. c <- 100 4. ALGORITMO: 5. Borrar_pantalla( ) 6. MIENTRAS c <= 0 HACER 7. ESCRIBIR c 8. c <- c - 1 9. FIN_MIENTRAS 10. FINPROGRAMA <br />
  4. 4. 3.-Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100. 1. PROGRAMA pares 2. ENTORNO: 3. c <- 2 4. ALGORITMO: 5. Borrar_pantalla( ) 6. MIENTRAS c < 101 HACER 7. ESCRIBIR c 8. c <- c + 2 9. FIN_MIENTRAS 10. FINPROGRAMA <br />
  5. 5. 4.-Hacer un programa que imprima la suma de los 100 primeros numeros. 1. PROGRAMA suma 2. ENTORNO: 3. c <- 1 4. suma <- 0 5. ALGORITMO: 6. Borrar_pantalla( ) 7. MIENTRAS c <= 100 HACER 8. suma <- suma + c 9. c <- c + 1 10. FIN_MIENTRAS 11. ESCRIBIR "La suma de los 100 primeros n£meros es: " 12. ESCRIBIR suma 13. FINPROGRAMA <br />
  6. 6. 5.-Hacer un pseudocódigo que imprima los numeros impares hasta el 100 y que imprima cuantos impares hay. 1. PROGRAMA impares 2. ENTORNO: 3. c <- 1 4. son <- 0 5. ALGORITMO: 6. Borrar_pantalla( ) 7. MIENTRAS c < 100 8. ESCRIBIR c 9. c <- c + 2 10. son <- son + 1 11. FIN_MIENTRAS 12. ESCRIBIR "El n£mero de impares: " 13. ESCRIBIR son 14. FINPROGRAMA <br />
  7. 7. 6.-Hacer un pseudocodigo que imprima todos los numeros naturales que hay desde la unidad hasta un numero que introducimos por teclado. 1. PROGRAMA natural 2. ENTORNO: 3. i <- 0 4. n <- 0 5. ALGORITMO: 6. Borrar_pantalla( ) 7. ESCRIBIR "Introduce un n£mero: " 8. LEER (n) 9. MIENTRAS i < n HACER 10. i <- i + 1 11. ESCRIBIR i 12. FIN_MIENTRAS 13. FINPROGRAMA <br />
  8. 8. 7.-Introducir tantas frases como queramos y contarlas. 1. PROGRAMA frases 2. ENTORNO: 3. res <- "S" 4. frase <- Espacios( 30 ) 5. c <- 0 6. ALGORITMO: 7. Borrar_pantalla( ) 8. MIENTRAS res = "S" HACER 9. ESCRIBIR "Frase: " 10. LEER( frase) 11. c <- c + 1 12. ESCRIBIR "Deseas introducir m s frases (S/N): " 13. LEER res 14. FIN_MIENTRAS 15. ESCRIBIR "El n£mero de frases introducidas son: " 16. ESCRIBIR c 17. FINPROGRAMA <br />
  9. 9. 8.-Hacer un pseudocodigo que solo nos permita introducir S o N. 1. PROGRAMA sn 2. ENTORNO: 3. res <- " " 4. ALGORITMO: 5. Borrar_pantalla( ) 6. MIENTRAS res <> "S" Y res <> "N" HACER 7. ESCRIBIR "Introduce S o N" 8. LEER( res) 9. res <- Convertir_may£sculas( res ) 10. FIN_MIENTRAS 11. FINPROGRAMA <br />
  10. 10. 9.-Introducir un numero por teclado. Que nos diga si es positivo o negativo. 1. PROGRAMA signo 2. ENTORNO: 3. num<- 0 4. ALGORITMO: 5. Borrar_pantalla( ) 6. ESCRIBIR "Introduce un n£mero: " 7. LEER num 8. SI num >= 0 ENTONCES 9. ESCRIBIR "es positivo" 10. SINO 11. ESCRIBIR "es negativo" 12. FIN_SI 13. FINPROGRAMA <br />
  11. 11. 10.-Introducir un numero por teclado. Que nos diga si es par o impar. 1. PROGRAMA paridad 2. ENTORNO: 3. num<- 0 4. ALGORITMO: 5. Borrar_pantalla( ) 6. ESCRIBIR "Introduce un n£mero: " 7. LEER num 8. SI num = int( num / 2 ) * 2 ENTONCES 9. ESCRIBIR "es par" 10. SINO 11. ESCRIBIR "es impar" 12. FIN_SI 13. FINPROGRAMA <br />
  12. 12. 11.-Imprimir y contar los multiplos de 3 desde la unidad hasta un numero que introducimos por teclado. 1. PROGRAMA multiplo3 2. ENTORNO: 3. i <- 3 4. n <- 0 5. c <- 0 6. ALGORITMO: 7. Borrar_pantalla( ) 8. ESCRIBIR "N£mero: " 9. LEER n 10. MIENTRAS i <= n HACER 11. SI i = int( i / 3 ) * 3 ENTONCES 12. ESCRIBIR i 13. c <- c + 1 14. FIN_SI 15. i <- i + 1 16. FINMIENTRAS 17. ESCRIBIR "El n£mero de m£ltiplos de 3 son: " 18. ESCRIBIR c 19. FINPROGRAMA <br />
  13. 13. 12.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. Que calcule la  suma de todos los numeros pares por un lado, y por otro, la de todos los impares. 1. PROGRAMA par_impar 2. ENTORNO: 3. i <- 1 4. sumapar<- 0 5. sumaimp<- 0 6. ALGORITMO: 7. Borrar_pantalla( ) 8. MIENTRAS i < 101 HACER 9. SI i = int( i / 2 ) * 2 ENTONCES 10. sumapar<- sumapar + i 11. SINO 12. sumaimp<- sumaimp + i 13. FIN_SI 14. i <- i + 1 15. FIN_MIENTRAS 16. ESCRIBIR "La suma de los pares es: " 17. ESCRIBIR sumapar 18. ESCRIBIR "La suma de los impares es: " 19. ESCRIBIR sumaimp 20. FINPROGRAMA <br />
  14. 14. 13.-Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre 1 y 100. <br />1. PROGRAMA multiplo_2_3 2. ENTORNO: 3. i <- 1 4. c <- 0 5. ALGORITMO: 6. Borrar_pantalla( ) 7. MIENTRAS i < 101 HACER 8. SI i = int( i / 2 ) * 2 O i = int( i / 3 ) * 3 ENTONCES 9. c <- c + 1 10. ESCRIBIR i 11. FIN_SI 12. i <- i + 1 13. FINMIENTRAS 14. ESCRIBIR "El n£mero de m£ltiplos es de: " 15. ESCRIBIR c 16. FIN_PROGRAMA <br />
  15. 15. 14.-.-Hacer un programa que calcule independientemente la suma de los pares y  los impares de los numeros entre 1 y 1000, utilizando un switch. 1.PROGRAMA suma 2. ENTORNO: 3. par <- 0 4. impar <- 0 5. sw<- 0 6. i <- 1 7. ALGORITMO: 8. Borrar_pantalla( ) 9. MIENTRAS i <= 1000 HACER 10.SI sw = 0 ENTONCES 11. impar <- impar + i 12. sw<- 1 13. SINO 14. par <- par + i 15. sw<- 0 16. FIN_SI 17. i <- i + 1 18. FIN_MIENTRAS 19. ESCRIBIR "La suma de los pares es: " 20. ESCRIBIR par 21. ESCRIBIR "La suma de los impares es: " 22. ESCRIBIR impar 23. FIN_PROGRAMA <br />
  16. 16. 15.-Imprimir diez veces la serie de numeros del 1 al 10. 1. PROGRAMA diez 2. ENTORNO: 3. serie <- 0 4. ALGORITMO: 5. Borrar_pantalla( ) 6. MIENTRAS serie <= 10 HACER 7. numero <- 1 8. MIENTRAS numero <= 10 HACER 9. ESCRIBIR numero 10. numero <- numero + 1 11. FIN_MIENTRAS 12. serie <- serie + 1 13. FIN_MIENTRAS 14. FIN_PROGRAMA <br />
  17. 17. 16.-Hacer un pseudocodigo que imprima el mayor y el menor de una serie de cinco numeros que vamos introduciendo por teclado. 1. PROGRAMA mayor_menor 2. ENTORNO: 3. con <- 0 4. n <- 0 5. maximo<- 0 6. minimo<- 99999 7. ALGORITMO: 8. Borrar_pantalla( ) 9. MIENTRAS con <= 5 HACER 10. ESCRIBIR "Numero: " 11. LEER (n)12. SI n > maximo ENTONCES 13. maximo= n 14. FIN_SI 15. SI n < minimo ENTONCES 16. minimo<- n 17. FIN_SI 18. con <- con + 1 19. FIN_MIENTRAS 20. ESCRIBIR "El mayor de los numeroses: " 21. ESCRIBIR maximo 22. ESCRIBIR "El menor de los numeroses: " 23. ESCRIBIR minimo 24. FINPROGRAMA <br />
  18. 18. 17.-Hacer un pseudocodigo que simule el funcionamiento de un reloj digital y  que permita ponerlo en hora. 1. PROGRAMA reloj 2. ENTORNO: 3. horas <- 0 4. minutos <- 0 5. segundos <- 0 6. res <- "S" 7. ALGORITMO: 8. Borrar_pantalla( ) 9. ESCRIBIR "Horas: " 10. LEER horas 11. ESCRIBIR "Minutos: " 12. LEER (minutos) 13. ESCRIBIR "Segundos: " 14. LEER (segundos) 15. MIENTRAS res = "S" HACER 16. MIENTRAS horas < 24 HACER  17. MIENTRAS minutos < 60 HACER 18. MIENTRAS segundos < 60 HACER 19. ESCRIBIR horas 20. ESCRIBIR minutos 21. ESCRIBIR segundos 22. segundos <- segundos + 1 23. FIN_MIENTRAS 24. minutos <- minutos + 1 26. segundos <- 0 27. FIN_MIENTRAS 28. horas <- horas + 1 29. minutos <- 0 30. FIN_MIENTRAS 31. horas <- 0 32. FIN_MIENTRAS 33. FIN_PROGRAMA <br />
  19. 19. 18.-Calcular el factorial de un numero.1. PROGRAMA factorial 2. ENTORNO: 3. res <- "S" 4. ALGORITMO: 5. MIENTRAS res = "S" HACER 6. Borrar_pantalla( ) 7. factorial <- 1 8. ESCRIBIR "N£mero: " 9. LEER (numero)10. SI numero < 0 ENTONCES 11. ESCRIBIR "No tiene factorial" 12. SINO 13. HACER Calculos 14. FIN_SI 15. HACER Mas 16. FIN_MIENTRAS 17. FINPROGRAMA <br />
  20. 20. 19.-Hacer un programa que calcule independientemente la suma de los pares y  los impares de los numeros entre 1 y 1000, utilizando un switch. 1. PROGRAMA suma 2. ENTORNO: 3. par <- 0 4. impar <- 0 5. sw<- 0 6. i <- 1 7. ALGORITMO: 8. Borrar_pantalla( ) 9. MIENTRAS i <= 1000 HACER 10. SI sw = 0 ENTONCES 11. impar <- impar + i 12. sw<- 1 13. SINO 14. par <- par + i 15. sw<- 0 16. FIN_SI 17. i <- i + 1 18. FIN_MIENTRAS 19. ESCRIBIR "La suma de los pares es: " 20. ESCRIBIR par 21. ESCRIBIR "La suma de los impares es: " 22. ESCRIBIR impar 23. FINPROGRAMA <br />
  21. 21. 20.-Introducir una frase por teclado. Imprimirla cinco veces en filas consecutivas, pero cada impresion ir desplazada cuatro columnas hacia la  derecha. 1. PROGRAMA frase 2. ENTORNO: 3. frase <- Espacios( 30 ) 4. ALGORITMO: 5. Borrar_pantalla( ) 6. EN 5,15 ESCRIBIR "Frase: " 7. EN 5,22 LEER frase 8. fi <- 8 9. co<- 15 10. veces <- 0 11. MIENTRAS veces <= 5 HACER 12. EN fi,co ESCRIBIR frase 13. veces <- veces + 1 14. co<- co + 4 15. fi <- fi + 1 16. FINMIENTRAS 17. FINPROGRAMA <br />
  22. 22. 21.-Hacer un pseudocodigo que imprima los n£meros del 0 al 100, controlando  las filas y las columnas. 1. PROGRAMA numeros 2. ENTORNO: 3. c <- 0 4. ALGORITMO: 5. Borrar_pantalla( ) 6. EN 5,20 ESCRIBIR "Los n£meros del 0 al 100 son: " 7. fi <- 7 8. col <- 5 9. MIENTRAS c < 101 HACER 10. EN fi,col ESCRIBIR c 11.- c <- c + 1 12. col <- col + 4 13. SI col > 75 ENTONCES 14. fi <- fi + 2 15. col <- 5 16. FINSI 17. FINMIENTRAS 18. FINPROGRAMA <br />
  23. 23. 22.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla. 1. PROGRAMA centro 2. ENTORNO: 3. res <- "S" 4. frase <- Espacios( 40 ) 5. ALGORITMO: 6. MIENTRAS res = "S" HACER 7. Borrar_pantalla( ) 8. EN 5,15 ESCRIBIR "Frase: " 9. EN 5,22 LEER frase 10. EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase 11. HACER Mas 12. FINMIENTRAS 13. FINPROGRAMA <br />
  24. 24. 23.-Realizar la tabla de multiplicar de un numero entre 0 y 10. 1. PROGRAMA tabla 2. ENTORNO: 3. num<- -1 4. ALGORITMO: 5. HACER Numero 6. Borrar_pantalla( ) 7. EN 5,10 ESCRIBIR "Tabla de multiplicar del n£mero: " 8. EN 5,40 LEER num 9. i <- 0 10. fi <- 8 11. MIENTRAS i <= 10 HACER 12. EN fi,15 ESCRIBIR num 13. EN fi,19 ESCRIBIR " * " 14. EN fi,23 ESCRIBIR i 15. EN fi,25 ESCRIBIR " = " 16. EN fi,29 ESCRIBIR num * i 17. fi <- fi + 1 18. i <- i + 1 19. FIN_MIENTRAS20. FINPROGRAMA <br />
  25. 25. 24.-Simular el lanzamiento de una moneda al aire e imprimir si ha salido cara o cruz. 1. PROGRAMA moneda 2. ENTORNO: 3. res <- "S" 4. ALGORITMO: 5. MIENTRAS res = "S" HACER 6. Borrar_pantalla( ) 7. SI Rnd( ) <= 0.5 ENTONCES 8. EN 10,35 ESCRIBIR "Cara" 9. SINO 10. EN 10,35 ESCRIBIR "Cruz" 11. FIN_SI 12. HACER Mas 13. FIN_MIENTRAS 14. FINPROGRAMA <br />
  26. 26. 29.-Simular cien tiradas de dos dados y contar las veces que entre los dos  suman 10. 1. PROGRAMA dado 2. ENTORNO: 3. c <- 0 4. i <- 0 5. ALGORITMO: 6. Borrar_pantalla( ) 7. MIENTRAS i < 101 HACER 8. SI Int( Rnd( ) * 6 ) + Int( Rnd( ) * 6 ) + 2 = 10 ENTONCES 9. c <- c + 1 10. FINSI 11. i <- i + 1 12. FIN_MIENTRAS 13. EN 10,20 ESCRIBIR "Las veces que suman 10 son: " 14. EN 10,48 ESCRIBIR c 15. FINPROGRAMA <br />

×